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CHAPTER 1

Get Started

This document is intended to help users set up the software environment for the development of audio applications using
hardware based on the ESP32 family of chips by Espressif. After that, a simple example will show you how to use
ESP-ADF (Espressif Audio Development Framework).

1.1 Development Board Overview

For easier start with ESP-ADF, Espressif designed ESP32, ESP32-S2, and ESP32-S3 based development boards intended
for audio applications. Click the links below to learn more about the available boards.

e ESP32-LyraT

e ESP32-LyraT-Mini

e ESP32-LyraTD-MSC
» ESP32-S2-Kaluga-1

e ESP32-Korvo-DU1906
e ESP32-§3-Korvo-2

e ESP32-C3-Lyra

If you do not have any of the above boards, you can still use ESP-ADF for the ESP32 and ESP32-S2 based audio
applications. For this, your board needs to have a compatible audio codec or DSP chip; alternatively, you can develop a
driver to support communication with your specific chip.



https://docs.espressif.com/projects/esp-idf/en/latest/esp32s2/hw-reference/esp32s2/user-guide-esp32-s2-kaluga-1-kit.html
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1.2 About ESP-ADF

The ESP-ADF is available as a set of components to extend the functionality already delivered by the ESP-IDF (Espressif
IoT Development Framework).

To use ESP-ADF you need set up the ESP-IDF first, and this is described in the next section.

£ 1:: ESP-ADF provides support for specific ESP-IDF versions. If your have already set up another version, please
switch to a supported ESP-IDF version, or you may not be able to compile ESP-ADF applications. In addition, the python
version needs to be between 3.7 and 3.11.

1.3 Quick Start

This section provides quick steps to run a simple ADF sample project on an ESP device for experienced users. For
beginners, please go through the complete steps from Step 1. Set up ESP-IDF to Step 9. Monitor to build a project.

411z If you encounter issues in the following steps, you could refer to the complete steps from Step 1. Set up ESP-IDF
to Step 9. Monitor or describe them in GitHub Issues or ESP Forum.

1.3.1 Linux and macOS

The operating environment below is on Linux Ubuntu 18.04 and above.

1. Download the full ESP-ADF repository from GitHub by running:

’git clone —-recursive https://github.com/espressif/esp-adf.git

For users located in China, it is faster to download from Gitee:

’git clone —-recursive https://gitee.com/EspressifSystems/esp-adf.git

2. Configure the SESP-IDF and SESP-ADF compilation environment by running:

cd esp-adf
./install.sh
./export.sh

3. After completing the above environment variable configuration, you can compile the ADF sample project
SADF_PATH/examples/get—-started/play_mp3_control. Switch to the project’ s directory, com-
pile, and flash it onto your ESP device by running the following command. Then, you will see the serial port of the
routine is printed.

cd $ADF_PATH/examples/get-started/play_mp3_control
idf.py build flash monitor

4 Chapter 1. Get Started
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1.3.2 Windows

1.

1.4

Download the full ESP-ADF repository from GitHub by running:

’git clone —-recursive https://github.com/espressif/esp-adf.git

For users located in China, it is faster to download from Gitee:

’git clone —-recursive https://gitee.com/EspressifSystems/esp-adf.git

Install the SESP—-IDF compilation environment in the command prompt window:

cd esp-adf
.\install.bat

Or first download the full ESP-IDF Windows Installer from ESP-IDF Windows Installer (Please download the
ESP-IDF versions supported by ESP-ADF). And then turn off the antivirus software (Because it may prevent the
installation as the software writes the Windows system regedit) and install the downloaded file. After the installation
is complete, open the ESP-IDF CMD shortcut icon on the desktop, the script will automatically help you download
submodules, and set environment variables such as IDF_PATH.

Set the ADF_PATH by running the following commands:

.\export .bat
echo %ADF_PATHS

If your ADF_PATH variable prints correctly, it’ s time to compile the ADF routines:

cd %ADF_PATH%\examples\get-started\play_mp3_control
idf.py build flash monitor

Installation Step by Step

This is a detailed roadmap to walk you through the installation process.

1.4.1 Setting up Development Environment

Step 1. Set up ESP-IDF for Windows, Linux or Mac OS
Step 2. Get ESP-ADF

Step 3. Set up the environment

1.4.2 Creating Your First Project

Step 4. Start a Project

Step 5. Connect Your Device
Step 6. Configure

Step 7. Build the Project
Step 8. Flash onto the Device
Step 9. Monitor

1.4. Installation Step by Step 5
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1.5 Step 1. Set up ESP-IDF

Configure your PC according to Getting Started section of ESP-IDF Programming Guide. Windows, Linux and Mac
OS operating systems are supported. Please select and follow the guide specific to ESP32 or ESP32-S2 chip. The chip
name is provided in the board name.

41122 This guide uses the directory ~ /e sp on Linux and macOS or $userprofile%\esp on Windows as an instal-
lation folder for ESP-ADF. You can use any directory, but you will need to adjust paths for the commands accordingly.
Keep in mind that ESP-ADF does not support spaces in paths.

To make the installation easier and less prone to errors, use the ~/esp default directory for the installation.

If this is your first exposure to the ESP-IDF, then it is recommended to get familiar with hello_world or blink example
first.

After getting familiar with ESP-IDF, decide on which ESP-IDF version to use for your application depending on the
Espressif chip that you have and your project type. For this, consult Versions section of ESP-IDF Programming Guide.

Once you successfully build, upload, and run examples for your version of ESP-IDF, you can proceed to the next step.

1.6 Step 2. Get ESP-ADF

Now you can start installing audio-specific API / libraries provided in ESP-ADF repository.

1.6.1 Windows

Open Command Prompt and run the following commands:

cd %userprofile%\esp
git clone —--recursive https://github.com/espressif/esp-adf.git

1.6.2 Linux and macOS

Open Terminal, and run the following commands:

cd ~/esp
git clone —-recursive https://github.com/espressif/esp-adf.git

1.7 Step 3. Set up the environment

Before being able to compile ESP-ADF projects, on each new session, ESP-IDF tools should be added to the PATH
environment variable. To make the tools usable from the command line, some environment variables must be set. ESP-
ADF provides a script which does that.

6 Chapter 1. Get Started
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1.7.1 Windows

ESP-IDF Tools Installer for Windows creates an “ESP-IDF Command Prompt” shortcut in the Start Menu. This shortcut
opens the Command Prompt and sets up all the required environment variables. You can open this shortcut and proceed
to the next step.

Alternatively, if you want to use ESP-IDF in an existing Command Prompt window, you can run:

*userprofile%\esp\esp-adf\export.bat

1.7.2 Linux and macOS

In the terminal where you have installed ESP-IDF, run:

SHOME /esp/esp-adf/export.sh

Note the space between the leading dot and the path!

You can also create an alias for the export script to your .profile or .bash_profile script. This way you can set
up the environment in a new terminal window by typing get_idf:

alias get_idf='. $HOME/esp/esp-adf/export.sh'

Note that it is not recommended to source export . sh from the profile script directly. Doing so activates IDF virtual
environment in every terminal session (even in those where IDF is not needed), defeating the purpose of the virtual
environment and likely affecting other software.

1.8 Step 4. Start a Project

After initial preparation you are ready to build the first audio application. The process has already been described in
ESP-IDF documentation. Now we would like to discuss remaining key steps and show how the toolchain is able to access
the ESP-ADF components by using the ADF_PATH variable.

To demonstrate how to build an application, we will use get-started/play_mp3_control project from examples directory
in the ADF.

1.8.1 Windows

cd fuserprofile$\esp
xcopy /e /i %ADF_PATH%\examples\get-started\play_mp3_control play_mp3_control

1.8.2 Linux and macOS

cd ~/esp

cp -r SADF_PATH/examples/get-started/play_mp3_control

There is a range of example projects in the examples directory in ESP-ADF. You can copy any project in the same way
as presented above and run it.

It is also possible to build examples in-place, without copying them first.

1.8. Step 4. Start a Project 7
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Ji%E: The ESP-IDF build system does not support spaces in the paths to either ESP-IDF or to projects.

1.9 Step 5. Connect Your Device

Connect the audio board to the PC, check under what serial port the board is visible and verify, if serial communication
works as described in ESP-IDF documentation.

$51:: Keep the port name handy as you will need it in the next steps.

1.10 Step 6. Configure

Navigate to your play_mp3_control directory from Step 4. Start a Project and configure the project:

1.10.1 Windows

cd Suserprofile%\esp\play_mp3_control
idf.py set-target esp32
idf.py menuconfig

1.10.2 Linux and macOS

cd ~/esp/play_mp3_control
idf.py set-target esp32
idf.py menuconfig

$&11:: If you are using an ESP32-S2 based board, then the second command above should be idf .py set-target
esp32s2.

Setting the target with idf .py set-target <target> should be done once, after opening a new project. If the
project contains some existing builds and configuration, they will be cleared and initialized. The target may be saved in
environment variable to skip this step at all. See Selecting the Target in ESP-IDF Programming Guide for additional
information.

If the previous steps have been done correctly, the following menu appears:

You are using this menu to set up your board type and other project specific variables, e.g. Wi-Fi network name and
password, the processor speed, etc.

Select your board from the menu, press S to save configuration and then Q to exit.

%2 The colors of the menu could be different in your terminal. You can change the appearance with the option
—-style. Please run idf.py menuconfig —-help for further information.

8 Chapter 1. Get Started
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ment Framework Configuration

SDK tool configuration ---=
Build type --->

Application manager ---=
Bootloader config --->
Security features ---=
serial flasher config ---=>
Partition Table --->

My Audio Board ---=
Recorder Engine Configuration --->
ESP Speech Recognition --->
Compiler options --->
Component config ---=
Compatibility options --->

[Space/Enter] Toggle/enter [ESC] Leave menu [5] save

[0] Load [?] symbol info [/] Jump to symbol
[F] Toggle show-help mode C e show-name mode [A] T = ow-all mode
1[Q] Quit (prompts for }

K 1: Project configuration - Home window

(Top) — Audio HAL — Audio board

Espressif IoT Development Framework Configuration
i i Custom audio board

(X) ESP32-Lyrat V4.3

( ) ESP32-Lyrat v4.2
( ) ESP32-LyraTD-MSC V2.1
( ) ESP32-LyraTD-MSC V2.2
( ) ESP32-Lyrat-Mini V1.1

( ) ESP32_KORVO_DU1906
( ) ESP32-52-Kaluga-1 v1.2

[Space/Enter] Toggle/enter [ESC] Leave menu [5] save

[0] d [?] symbol info [/] Jump to symbol
[F] gle show-help mode [C] Toggle show-name mode ggle show-all mode
[Q] Quit (prompts for save) [D] Save minimal config (advanced)

[¥] 2: Project configuration - Board selection

1.10. Step 6. Configure 9
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1.11 Step 7. Build the Project

Build the project by running:

idf.py build

This command will compile the application and all ESP-IDF and ESP-ADF components, then it will generate the boot-
loader, partition table, and application binaries.

$ idf.py build
Executing action: all (aliases: build)
Running ninja in directory /path/to/esp/play_mp3_control/build
Executing "ninja all"...
[0/1] Re-running CMake...

(more lines of build system output)

[1064/1064] Generating binary image from built executable
esptool.py v3.0-dev
Generated /path/to/esp/play_mp3_control/build/play_mp3_control.bin

Project build complete. To flash it, run this command:
/path/to/.espressif/python_env/idf4.2_py2.7_env/bin/python ../esp-idf/components/
—esptool_py/esptool/esptool.py —-p (PORT) -b 460800 --before default_reset --after.
—hard_reset —--chip esp32 write_flash —--flash_mode dio --flash_size detect —--flash_
—freq 40m 0x1000 build/bootloader/bootloader.bin 0x8000 build/partition_table/
—partition-table.bin 0x10000 build/play_mp3_control.bin

or run 'idf.py -p (PORT) flash'

If there are no errors, the build will finish by generating the firmware binary .bin file.

1.12 Step 8. Flash onto the Device

Flash the binaries that you just built onto your board by running:

idf.py —-p PORT [-b BAUD] flash monitor

Replace PORT with your board’ s serial port name from Step 5. Connect Your Device.

You can also change the flasher baud rate by replacing BAUD with the baud rate you need. The default baud rate is
460800.

For more information on idf.py arguments, see Using the Build System in ESP-IDF Programming Guide.

$41:: The option £1ash automatically builds and flashes the project, so running idf .py build is not necessary.

To upload the binaries, the board should be put into upload mode. To do so, hold down Boot button, momentarily press
Reset button and release the Boot button. The upload mode may be initiated anytime during the application build, but
no later than “Connecting” message is being displayed:

esptool.py v3.0-dev

(@NE327)

10 Chapter 1. Get Started
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[CAWY)
Serial port /dev/ttyUSBO
Connecting........
Without the upload mode enabled, after showing several . . . . . , the connection will eventually time out.

Once build and upload is complete, you should see the following:

Leaving...

Hard resetting via RTS pin...

Executing action: monitor

Running idf_monitor in directory /path/to/esp/play_mp3_control

Executing "/path/to/.espressif/python_env/idf4.2_py2.7_env/bin/python /path/to/esp/
—esp-idf/tools/idf_monitor.py -p /dev/ttyUSBO -b 115200 --toolchain-prefix xtensa-
—esp32-elf- /path/to/esp/play_mp3_control/build/play_mp3_control.elf -m '/path/to/.
—espressif/python_env/idf4.2_py2.7_env/bin/python' '/path/to/esp/esp-idf/tools/idf.py
(H'"---

—-—— idf_monitor on /dev/ttyUSBO 115200 -—-

—-—— Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H —-—-

If there are no issues by the end of the flash process, the board will reboot and start up the “play_mp3_control” application.

1.13 Step 9. Monitor

At this point press the Reset button to start the application. Following several lines of start up log, the
play_mp3_control application specific messages should be displayed:

I (397) PLAY_FLASH_MP3_CONTROL: [ 1 ] Start audio codec chip

I (427) PLAY_FLASH_MP3_CONTROL: [ 2 ] Create audio pipeline, add all elements to.
—pipeline, and subscribe pipeline event

I (427) PLAY_FLASH_MP3_CONTROL: [2.1] Create mp3 decoder to decode mp3 file and set.
—custom read callback

I (437) PLAY_FLASH_MP3_CONTROL: [2.
I (467) PLAY_FLASH_MP3_CONTROL: [2.
I (467) PLAY_FLASH_MP3_CONTROL: [2.
—decoder-->12s_stream——->[codec_chi

2] Create 1i2s stream to write data to codec chip
3] Register all elements to audio pipeline

4] Link it together [mp3_music_read_cb]-->mp3_
Pl

]

1

]

]

I (477) PLAY FLASH MP3_CONTROL: [ 3 Set up event listener

I (477) PLAY_FLASH_MP3_CONTROL: [3.1] Listening event from all elements of pipeline
I (487) PLAY_FLASH_MP3_CONTROL: [ 4 Start audio_pipeline

I (507) PLAY FLASH MP3_CONTROL: [ * Receive music info from mp3 decoder, sample_
—rates=44100, bits=16, ch=2

I (7277) PLAY_FLASH_MP3_CONTROL: [ 5 ] Stop audio_pipeline

If there are no issues, besides the above log, you should hear a sound played for about 7 seconds by the speakers or
headphones connected to your audio board. Reset the board to hear it again if required.

Now you are ready to try some other examples, or go right to developing your own applications. Check how the examples
are made aware of location of the ESP-ADF. Open the get-started/play_mp3_control/Makefile and you should see

include (SENV{ADF_PATH}/CMakeLists.txt)
include (SENV{IDF_PATH}/tools/cmake/project.cmake)

1.13. Step 9. Monitor 11
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The first line contains ADF_PATH to point the toolchain to another file in ESP-ADF directory that provides configuration
variables and path to ESP-ADF components reacquired by the toolchain. You need similar Makefile in your own
applications developed with the ESP-ADF.

1.14 VS Code Extension

1. Follow VS Code Extension Quick Installation Guide to install ESP-IDF Visual Studio Code Extension. If the
previous steps have been done correctly, the following toolbar appears:

> Bg

> PROJECT COMPONENTS ESP-IDF Build, Flash and Menitor

X 201 © U/deviityusBo [Eesp32 B & @ B w $§ O & B @140 @ CMake: [Debug):Ready 3% [GCC 5.2.0xtensa-esp32-elf] @ Build [all #F [> GitGraph & Downloading .NET...

B 3: VS Code Extension Toolbar

2. To install the ESP-ADF extension, open Command Palette and enter install adf. Then, a progress bar
shows up in the lower right corner.

If you have cloned the ESP-ADF repository before, please enter open settings (ui) in Command
Palette. Goto User > Extensions > ESP_IDF and manually set the ESP-ADF path in idf.
espAdfPath or idf.espAdfPathWin (for Windows). You can also set the ESP-ADF path in .
vscode/settings. json.

3. In Command Palette, enter show examples project, and then a window will be opened with a list of
example projects.

4. Selectan example, click Create project using example XX, andselectthe directory to save the current
example.

5. On the toolbar at the bottom of VS Code, click the gear symbol menuconf ig to configure the example and click
the column symbol Bui 1d to build the example. See available shortcut keys for VS code extensions.

6. On the toolbar at the bottom of VS Code, click the plug-in symbol Select Port to configure the serial port
and click the lightning symbol F1ash Device to flash firmware. After the firmware is flashed successfully, click
Monitor Device to start the monitor function. Or, you can also use the flame symbol to build, flash, and
monitor the example at the same time.

1.15 IDF Eclipse Plugin and Espressif IDE

1.15.1 Install and Set up Environment Variables

1. Follow IDF Eclipse Plugin Quick Installation Guide to install IDF Eclipse Plugin or download and install Espressif
IDE from Espressif IDE Download Link. If the previous steps have been done correctly, you can create, build and
flash IDF project in the Eclipse environment.

2. To install ESP-ADF, follow section Step 2. Get ESP-ADF'.

3. To set ADF_PATH environment variable, open Window > Preferences > C/C++ > Build >
Environment panel, click Add button and fill in ADF_PATH. After you complete the above steps, select
ADF_PATH in Environment variables table and click Edit and OK button without changing any value
(There is a bug in Eclipse CDT that is appending a null value before the path hence we need to click on edit and
save it.).

If this step does not work, you can delete ADF_PATH set in Eclipse and set ADF_PATH as system envi-
ronment variable. For Windows, set environment variable in Advanced System Setting panel. For

12 Chapter 1. Get Started
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File Edit Source Refactor Navigate Search Project Run Espressif Window Help

sdkconfig.old

R]O|[®] ORu [] play_mp3_control on: | @ esp32s3 [mifid - Bi0iw A E-S8-E-@-iH-O0O-Q- @I RE T
FINET™S vl Q iy |E
& Project Wyplorei™y = Launch CMakeLists.tx. Launch Launch Opena = O g outline x @BuildTargets = O
ETTEn T, Mode Config - Target Terminal There s no active edibor et proAdes s
) & Binaries 2# (Automatically Cewsssecd Trom project MakeTItesywonvert to_cmake.py.) ke
» i Archives 4# The following lines of boilerplate have to be in your project's CMakeLists
» & build 5# in this exact order for cmake to work correctly
g 6 cmake_minimum_required(VERSION 3.5)
» & components 2
~ ¢ main DF_PATH}/CMakeLists. txt)
» [@ play_mp3_control_exam DF_PATH}/tools/cmake/project.cmake)
SRS = " y_mp3_control)
A CMakeLists.txt
& component.mk
13 music-16b-2¢:22050hz.mp3 q
1O music-16b-2c-44100hz.mp3 Build Launch
10 music-16b-2¢:8000hz.mp3
musiccredits
A CMakeLists.txt
 Makefile
7/ README_CN.md
4| README.md
& sdkeonfig
X o g «8 -0 =0

workspace - play_mp3_control/CMakeLists.txt - Espressif-IDE

82 Problems &) Tasks @ Console X [ Properties & Terminal = Progress

CDT Build Console [play_mp3_control]

[1217/1224] /home/pl/.espressif/tools/xtensa-esp32s3-€lf/esp-2021r2-patch3-8.4.0/xtensa-esp32s3-elf/bin/xtensa-esp32s3-elf-gcc -DADF VER=!
[1218/1224] /home/pl/.espressif/tools/xtensa-esp32s3-elf/esp-2021r2-patch3-8.4.0/xtensa-esp32s3-elf/bin/xtensa-esp32s3-elf-gcc -DADF VER=! -DHAVE_CONFIG H -DMBEDTLS CONFIG_FILE=\|
[1219/1224] : && /home/pl/.espressif/tools/cmake/3.23.1/bin/cmake -E rm -f esp-idf/main/libmain.a & /home/pl/.espressif/tools/xtensa-esp: elf/esp-2021r2-patch3-8.4.0/xtensa-esp3]
[1220/1224] cd /home/pl/esp_ide/Espressif-IDE-2.4.1-1inux.gtk.x86_64/Espressif-IDE/workspace/play mp3 _control/build/esp-idf/esp system && python /home/pl/esp adf master/esp-adf/esp-
[1221/1224] /home/pl/.espressif/tools/xtensa-esp32s3-elf/esp-2021r2-patch3-8.4.0/xtensa-esp32s3-elf/bin/xtensa-esp32s3-elf-gcc -DADF VER=\"\" -DHAVE CONFIG H -DMBEDTLS CONFIG FILE=\|
[1222/1224] : & /home/pl/.espressif/tools/xtensa-esp32s3-elf/esp-2021r2-patch3-8.4.0/xtensa-esp32s3-elf/bin/xtensa-esp32s3-elf-g++ -mlongcalls CMakeFiles/play mp3 control.elf.dir/|
[1223/1224] cd /home/pl/esp_ide/Espressif-IDE-2.4.1-linux.gtk.x86_64/Espressif-IDE/workspace/play mp3_control/build & python /home/pl/esp adf master/esp-adf/esp-idf/components/espt(

-DHAVE_CONFIG H -DMBEDTLS CONFIG FILE=\

esptool.py v3.3.2-dev
Creating esp32s3 image...

Merged 2 ELF sections

Successfully created esp32s3 image.

Generated /home/pl/esp_ide/Espressif-IDE-2.4.1-linux.gtk.x86_64/Espressif-IDE/workspace/play mp3_control/build/play mp3_control.bin

[1224/1224] cd /home/pl/esp_ide/Espressif-IDE-2.4.1-linux.gtk.x86_64/Espressif-IDE/workspace/play mp3_control/build/esp-idf/esptool py & python /home/pl/esp adf master/esp-adf/esp-

nlav mo3 control.hin hinarv size Axc94ad bvtes. Smallest ann partition is x17708 bvtes. Axadb6A hvtes (46%) free

Writable Smart Insert 8:39:278

(]

[¥] 4: Espressif IDE (Reskinned Eclipse)

Linux and macOS, add export ADF_PATH=your adf path infile /etc/profile. However,
it is not recommended. Doing so activates ADF virtual environment in every terminal session (including
those where ADF is not needed), defeating the purpose of the virtual environment and likely affecting other

software.

1.15.2 Create a New Project

1. To create new project, goto File > New > Espressif IDF Project and provide a project name.

2. Click Finish to create an empty project. Or click Next and check Create a project using one of

the templates to create a project using ESP-IDF templates.

After creating a new project, you can use ESP-IDF and ESP-ADF to develop the project.

1.15.3 Import Existing Project

To import existing ESP-ADF examples, go to File > Import > Espressif > Existing IDF Project and
select an ESP-ADF example (Opening an existing project directly may not be able to set the ESP target).

1.15.4 Quick Start

1. Select a project from Project Explorer.
In the Launch Mode drop-down menu, select Run.

In the Launch Configuration (auto-detected) drop-down menu, select your application.

Ll

Launch Target to set Serial Port.

. Double click sdkconfig file to launch the SDK Configuration Editor.

Select ESP target from the third drop-down, which is called Launch Target. Click gear symbol Edit button of

1.15. IDF Eclipse Plugin and Espressif IDE
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6. Click Build button to build the project.
7. Click Launch button to flash the project.
8. Click Open a Terminal button and select ESP-IDF Serial Monitor to view serial output.

For more information about IDF Eclipse Plugin and Espressif IDE, please refer to ESP-IDF Eclipse Plugin.

1.16 Update ESP-ADF

After some time of using ESP-ADF, you may want to update it to take advantage of new features or bug fixes. The
simplest way to do so is by deleting existing esp—adf folder and cloning it again, which is same as when doing initial
installation described in sections Step 2. Get ESP-ADF .

Another solution is to update only what has changed. This method is useful if you have a slow connection to the GitHub.
To do the update run the following commands:

cd ~/esp/esp-adf
git pull
git submodule update —--init --recursive

The git pull command is fetching and merging changes from ESP-ADF repository on GitHub. Then git
submodule update --init —--recursive is updating existing submodules or getting a fresh copy of new
ones. On GitHub the submodules are represented as links to other repositories and require this additional command to
get them onto your PC.
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CHAPTER 2

API Reference

This API provides a way to develop audio applications using Elements like Codecs (Decoders and Encoders), Streams or
Audio Processing functions.

Ty 0 i [ )
ALC
125 AMR Do iz
HTTF FLAC AMRHMNE Equalizer
FatFs MP3 AMRWE Resample Filtar
Raw el Wway .
Spifss aPuUs sonic
WA
] . . Z ~, -

Streams l\_\‘ Decoders l\_\‘ Encoders Il\‘ Audo Processing Il‘

|4 1: Elements of the Audio Development Framework

The application is developed by combining the Elements into a Pipeline. A diagram below presents organization of two
elements, MP3 decoder and I2S stream, in the Audio Pipeline, that has been used in get-started/play_mp3_control ex-
ample.

The audio data is typically acquired using an input Stream, processed with Codecs and in some cases with Audio Processing
functions, and finally output with another Stream. There is an Event Interface to facilitate communication of the application
events. Interfacing with specific hardware is done using Peripherals.

See a table of contents below with links to description of all the above components.
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file =P

€] 2: Sample Organization of Elements in Audio Pipeline

2.1 Audio Framework

2.1.1 Audio Element

The basic building block for the application programmer developing with ADF is the audio_element object. Every
decoder, encoder, filter, input stream, or output stream is in fact an Audio Element.

This API has been designed and then used to implement Audio Elements provided by ADF.

The general functionality of an Element is to take some data on input, processes it, and output to the next. Each Element
is run as a separate task. To enable control on particular stages of the data lifecycle from the input, during process-
ing and up to the output, the audio_element object provides possibility to trigger callbacks per stage. There are
seven types of available callback functions: open, seek, process, close, destroy, read and write, and they are defined in
audio_element_cfqg_t. Particular Elements typically use a subset of all available callbacks. For instance the MP3
Decoder is using open, process, close and destroy callback functions.

The available Audio Element types intended for development with this API are listed in description of audio_common.h
header file under audio_element_type_ t enumerator.

API Reference

Header File

» components/audio_pipeline/include/audio_element.h

Functions

audio_element_handle_t audio_element_init (audio_element cfg_t *config)

Initialize audio element with config.
%%t config —The configuration
Bl
* audio_elemenent handle object
* NULL

esp_err_t audio_element_deinit (audio_element_handle_t el)

Destroy audio element handle object, stop, clear, deletel all.

%% el —[in] The audio element handle
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gml
« ESP_OK
« ESP_FAIL

esp_err_t audio_element_setdata (audio_element_handle_t el, void *data)

Set context data to element handle object. It can be retrieved by calling audio_element_getdata.
SH
¢ el —[in] The audio element handle
* data The data pointer
B
* ESP_OK
» ESP_FAIL

void *audio_element_getdata (audio_element_handle_t el)

Get context data from element handle object.
%% el —[in] The audio element handle
1R[] data pointer

esp_err_t audio_element_set_tag (audio_element_handle_t el, const char *tag)

Set elemenet tag name, or clear if tag = NULL.
BH
¢ el —[in] The audio element handle
* tag —[in] The tag name pointer
R
* ESP_OK
» ESP_FAIL

char *audio_element_get_tag (audio_element _handle_t el)

Get element tag name.
%% el —[in] The audio element handle
&l Element tag name pointer

esp_err_t audio_element_setinfo (audio_element_handle_t el, audio_element_info_t *info)

Set audio element infomation.
ZH
e el —[in] The audio element handle

* info —The information pointer

ESP_OK
» ESP_FAIL
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esp_err_t audio_element_getinfo (audio_element_handle_t el, audio_element_info_t *info)

Get audio element infomation.
S8
¢ el [in] The audio element handle
* info —The information pointer
Bl
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_uri (audio_element_handle_t el, const char *uri)

Set audio element URI.
S
¢ el [in] The audio element handle
e uri —[in] The uri pointer
Bl
* ESP_OK
* ESP_FAIL

char *audio_element_get_uri (audio_element_handle_t el)
Get audio element URL

%% el —[in] The audio element handle
&1l URI pointer

esp_err_t audio_element_run (audio_element_handle_t el)

Start Audio Element. With this function, audio_element will start as freeRTOS task, and put the task into
‘PAUSED’ state. Note: Element does not actually start when this function returns.

%% el —[in] The audio element handle
PR

« ESP_OK

e ESP_FAIL

esp_err_t audio_element_terminate (audio_element_handle_t el)

Terminate Audio Element. With this function, audio_element will exit the task function. Note: this API only sends
request. It does not actually terminate immediately when this function returns.

%% el —[in] The audio element handle
B

* ESP_OK

* ESP_FAIL

esp_err_t audio_element_terminate_with_ticks (audio_element_handle_t el, TickType_t ticks_to_wait)

Terminate Audio Element with specific ticks for timeout. With this function, audio_element will exit the task
function. Note: this API only sends request. It does not actually terminate immediately when this function returns.

S
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¢ el [in] The audio element handle

* ticks_to_wait —[in] The maximum amount of time to blocking
B

* ESP_OK

* ESP_FAIL

esp_err_t audio_element_stop (audio_element_handle_t el)

Request stop of the Audio Element. After receiving the stop request, the element will ignore the actions being
performed (read/write, wait for the ringbuffer ---) and close the task, reset the state variables. Note: this API only
sends requests, Element does not actually stop when this function returns.

Z¥ el —[in] The audio element handle
R

* ESP_OK

* ESP_FAIL

esp_err_t audio_element_wait_for_stop (audio_element_handle_t el)

After the audio_element_stop function is called, the Element task will perform some abort procedures. This
function will be blocked (Time is DEFAULT_MAX_WAIT_TIME) until Element Task has done and exit.

%% el —[in] The audio element handle

B
e ESP_OK, Success
o ESP_FAIL, The state is not AEL_STATE_RUNNING
¢ ESP_ERR_TIMEOUT, Timeout

esp_err_t audio_element_wait_for_ stop_ms (audio_clement_handle_t el, TickType_t ticks_to_wait)

After the audio_element_stop function is called, the Element task will perform some abort procedures. The
maximum amount of time should block waiting for Element task has stopped.

S

¢ el [in] The audio element handle

* ticks_to_wait [in] The maximum amount of time to wait for stop
Bl

e ESP_OK, Success

* ESP_FAIL, The state is not AEL_STATE_RUNNING

» ESP_ERR_TIMEOUT, Timeout

esp_err_t audio_element_pause (audio_element_handle_t el)

Request audio Element enter ‘PAUSE’ state. In this state, the task will wait for any event.
Z¥ el —[in] The audio element handle
R m
* ESP_OK
» ESP_FAIL
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esp_err_t audio_element_resume (audio_element_handle_t el, float wait_for_rb_threshold, TickType_t
timeout)

Request audio Element enter ‘RUNNING’ state. In this state, the task listens to events and invokes the callback
functions. At the same time it will wait until the size/total_size of the output ringbuffer is greater than or equal to
wait_for_rb_threshold. If the timeout period has been exceeded and ringbuffer output has not yet reached
wait_for_rb_threshold then the function will return.

S
¢ el [in] The audio element handle
* wait_for_rb_threshold [in] The wait for rb threshold (0 .. 1)
¢ timeout [in] The timeout
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_msg_set_listener (audio_element_handle_t el, audio_event_iface_handle_t
listener)

This function will add a 1listener to listen to all events from audio element el. Any event from el-
>external_event will be send to the 1istener.

S

el —The audio element handle

* listener —The event will be listen to
B

* ESP_OK

* ESP_FAIL

esp_err_t audio_element_set_event_callback (audio_element_handle_t el, event_cb_func cb_func, void
*ctx)

This function will add a callback to be called from audio element e1. Any event to caller will cause to call
callback function.

S

el —The audio element handle
* cb_func —The callback function
* ctx —Caller context
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_msg_remove_listener (audio_element_handle_t el, audio_event iface_handle_t
listener)

Remove listener out of el. No new events will be sent to the listener.
S
¢ el [in] The audio element handle

¢ listener —The listener
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gml
« ESP_OK
« ESP_FAIL

esp_err_t audio_element_set_input_ringbuf (audio_element_handle_t el, ringbuf_handle_t rb)

Set Element input ringbuffer.
SH
¢ el —[in] The audio element handle
e rb —[in] The ringbuffer handle
Bl
* ESP_OK
» ESP_FAIL

ringbuf _handle_t audio_element_get_input_ringbuf (audio_clement_handle_t el)

Get Element input ringbuffer.
%% el —[in] The audio element handle
&[] ringbuf_handle_t

esp_err_t audio_element_set_output_ringbuf (audio_element_handle_t el, ringbuf_handle_t tb)

Set Element output ringbuffer.
S8
¢ el —[in] The audio element handle
* rb —[in] The ringbuffer handle
Bl
* ESP_OK
» ESP_FAIL

ringbuf _handle_t audio_element_get_output_ringbuf (audio_element_handle_t el)

Get Element output ringbuffer.
%% el —[in] The audio element handle
1R 0] ringbuf_handle_t

audio_element_state_t audio_element_get_state (audio_element_handle_t el)

Get current Element state.
%%t el —[in] The audio element handle
j&[H] audio_element_state_t

esp_err_t audio_element_abort_input_ringbuf (audio_element_handle_t el)

If the element is requesting data from the input ringbufter, this function forces it to abort.
Z¥ el —[in] The audio element handle
&
» ESP_OK
» ESP_FAIL
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esp_err_t audio_element_abort_output_ringbuf (audio_element_handle_t el)

If the element is waiting to write data to the ringbuffer output, this function forces it to abort.
Z¥ el —[in] The audio element handle
B
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_wait_for_ buffer (audio_element_handle_t el, int size_expect, TickType_t
timeout)

This function will wait until the sizeof the output ringbuffer is greater than or equal to size_expect. If the
timeout period has been exceeded and ringbuffer output has not yet reached size_expect then the function will
return ESP_FAIL

S
¢ el —[in] The audio element handle
* size_expect —[in] The size expect
¢ timeout —[in] The timeout
Bl
 ESP_OK
* ESP_FAIL

esp_err_t audio_element_report_status (audio_element_handle_t el, audio_element_status_t status)

Element will sendout event (status) to event by this function.
e
¢ el [in] The audio element handle
e status -[in] The status
B
» ESP_OK
» ESP_FAIL

esp_err_t audio_element_report_info (audio_element_handle_t el)

Element will sendout event (information) to event by this function.
%% el —[in] The audio element handle
&
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_report_codec_fmt (audio_element_handle_t el)

Element will sendout event (codec format) to event by this function.
Z¥ el —[in] The audio element handle
Bl
 ESP_OK
* ESP_FAIL
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esp_err_t audio_element_report_pos (audio_element_handle_t el)

Element will sendout event with a duplicate information by this function.
%% el —[in] The audio element handle
A
» ESP_OK
» ESP_FAIL
* ESP_ERR_NO_MEM

esp_err_t audio_element_set_input_timeout (audio_element _handle_t el, TickType_t timeout)
Set input read timeout (default is portMAX_DELAY).

SH
e el —[in] The audio element handle
¢ timeout —[in] The timeout
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_output_timeout (audio_element_handle_t el, TickType_t timeout)
Set output read timeout (default is port MAX_DELAY).

S8
¢ el —[in] The audio element handle
e timeout —[in] The timeout
B
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_reset_input_ringbuf (audio_element_handle_t el)

Reset inputbuffer.
%% el —[in] The audio element handle
Rl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_finish_state (audio_element_handle_t el)

Set element finish state.
%% el —[in] The audio element handle
PR
 ESP_OK
* ESP_FAIL
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esp_err_t audio_element_change_cmd (audio_element_handle_t el, audio_element_msg_cmd_t cmd)

Change element running state with specific command.
S8
¢ el [in] The audio element handle
* cmd —[in] Specific command from audio_element_msg_cmd_t
Bl
* ESP_OK
» ESP_FAIL
« ESP_ERR_INVALID ARG Element handle is null

esp_err_t audio_element_reset_output_ringbuf (audio_element_handle_t el)

Reset outputbuffer.
%% el —[in] The audio element handle
PR
« ESP_OK
* ESP_FAIL

audio_element_err_t audio_element_input (audio_element_handle_t el, char *buffer, int wanted_size)

Call this function to provide Element input data. Depending on setup using ringbuffer or function callback, Element
invokes read ringbuffer, or calls read callback funtion.

BH

e el —[in] The audio element handle

* buffer —The buffer pointer

* wanted_size —[in] The wanted size
Bl

* > 0 number of bytes produced

¢ <=0 audio_element_err_t

audio_element_err_t audio_element_output (audio_element_handle_t el, char *buffer, int write_size)

Call this function to sendout Element output data. Depending on setup using ringbuffer or function callback,
Element will invoke write to ringbuffer, or call write callback funtion.

S8
¢ el [in] The audio element handle
* buffer —The buffer pointer
* write_size —[in] The write size
Bl
* > 0 number of bytes written

¢ <=0 audio_element_err_t
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esp_err_t audio_element_set_read_cb (audio_element_handle_t el, stream_func fn, void *context)

This API allows the application to set a read callback for the first audio_element in the pipeline for allowing the
pipeline to interface with other systems. The callback is invoked every time the audio element requires data to be

processed.
BH
¢ el —[in] The audio element handle
» f£n [in] Callback read function. The callback function should return number of bytes read
or -1 in case of error in reading. Note that the callback function may decide to block and that
may block the entire pipeline.
* context —[in] An optional context which will be passed to callback function on every invo-
cation
Bl
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_write_cb (audio_element_handle_t el, stream_func fn, void *context)

This API allows the application to set a write callback for the last audio_element in the pipeline for allowing the
pipeline to interface with other systems. The callback is invoked every time the audio element has a processed data
that needs to be passed forward.

ZH
¢ el —[in] The audio element

» £n —[in] Callback write function The callback function should return number of bytes written
or -1 in case of error in writing. Note that the callback function may decide to block and that
may block the entire pipeline.

* context —[in] An optional context which will be passed to callback function on every invo-
cation

Bml
« ESP_OK
« ESP_FAIL

stream_func audio_element_get_write_cb (audio_element_handle_t el)

Get callback write function that register to the element.
%% el —[in] The audio element
Bl
* Callback write function pointer
* NULL Failed
stream_func audio_element_get_read_cb (audio_element_handle_t el)
Get callback read function that register to the element.
¥ el —[in] The audio element
B
* Callback read function pointer

e NULL Failed
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QueueHandle_t audio_element_get_event_queue (audio_element_handle_t el)

Get External queue of Emitter. We can read any event that has been send out of Element from this
QueueHandle_t.

%% el —[in] The audio element handle
&M QueueHandle_t

esp_err_t audio_element_set_ringbuf_done (audio_element_handle_t el)

Set inputbuffer and outputbuffer have finished.
% el —[in] The audio element handle
R m
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_reset_state (audio_element_handle_t el)
Enforce ‘AEL_STATE_INIT’ state.

%% el —[in] The audio element handle
Bl

 ESP_OK

* ESP_FAIL

int audio_element_get_output_ringbuf_size (audio_eclement_handle_t el)

Get Element output ringbuffer size.
%% el —[in] The audio element handle
Bl
e =0: Parameter NULL
* >0: Size of ringbuffer

esp_err_t audio_element_set_output_ringbuf_size (audio_element_handle_t el, int rb_size)

Set Element output ringbuffer size.
S8
¢ el [in] The audio element handle
* rb_size [in] Size of the ringbuffer
Bl
* ESP_OK
* ESP_FAIL

int audio_element_multi_input (audio_element_handle_t el, char *buffer, int wanted_size, int index,
TickType_t ticks_to_wait)

Call this function to read data from multi input ringbuffer by given index.
SH
* el —The audio element handle
* buffer —The buffer pointer

* wanted_size —The wanted size

26 Chapter 2. API Reference



ADF &4 R ZIESRF M, X7 latest

* index -The index of multi input ringbuffer, start from O, should be less than
NUMBER_OF_MULTI_RINGBUF

* ticks_to_wait —Timeout of ringbuffer
Bl

* ESP_ERR_INVALID_SIZE

* Others are same as the rb_read

int audio_element_multi_output (audio_clement_handle_t el, char *buffer, int wanted_size, TickType_t
ticks_to_wait)

Call this function write data by multi output ringbuffer.

S

¢ el [in] The audio element handle

* buffer —The buffer pointer

e wanted_size —[in] The wanted size

* ticks_to_wait —Timeout of ringbuffer
Bl

* The return value is same as the rb_write

esp_err_t audio_element_set_multi_input_ringbuf (audio_element_handle_t el, ringbuf _handle_t 1b,
int index)

Set multi input ringbuffer Element.
S8
¢ el [in] The audio element handle
* rb —[in] The ringbuffer handle

e index -[in] Index of multi ringbuffer, starts from 0, should be less than
NUMBER_OF_MULTI_RINGBUF

gml
- ESP_OK
« ESP_FAIL

esp_err_t audio_element_set_multi_output_ringbuf (audio_element_handle_t el, ringbuf _handle_t rb,
int index)

Set multi output ringbuffer Element.
SH
¢ el —[in] The audio element handle
e rb —[in] The ringbuffer handle

e index -[in] Index of multi ringbuffer, starts from 0, should be less than
NUMBER_OF_MULTI_RINGBUF

R
* ESP_OK
* ESP_ERR_INVALID_ARG
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ringbuf_handle_t audio_element_get_multi_input_ringbuf (audio_element_handle_t el, int index)

Get handle of multi input ringbuffer Element by index.
BH
¢ el [in] The audio element handle

e index -[in] Index of multi ringbuffer, starts from 0, should be less than
NUMBER_OF_MULTI_RINGBUF

R m
e NULL Error
¢ Others ringbuf_handle_t

ringbuf_handle_t audio_element_get_multi_output_ringbuf (audio_element_handle_t el, int index)

Get handle of multi output ringbuffer Element by index.
SH
¢ el —[in] The audio element handle

e index -[in] Index of multi ringbuffer, starts from 0, should be less than
NUMBER_OF_MULTI_RINGBUF

$EA |
e NULL Error
¢ Others ringbuf_handle_t

esp_err_t audio_element_process_init (audio_element_handle_t el)

Provides a way to call element’ s open
Z¥ el —[in] The audio element handle
Rl
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_process_deinit (audio_element_handle_t el)

Provides a way to call element’ s close
%% el —[in] The audio element handle
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_seek (audio_element_handle_t el, void *in_data, int in_size, void *out_data, int
*out_size)

Call element’ s seek
S8
¢ el —[in] The audio element handle
* in_data —[in] A pointer to in data
e in_size —[in] The size of the in_data

* out_data —[out] A pointer to the out data

28 Chapter 2. API Reference



ADF &4 R ZIESRF M, X7 latest

* out_size —[out] The size of the out_data
B

* ESP_OK

» ESP_FAIL

* ESP_ERR_NOT_SUPPORTED

bool audio_element_is_stopping (audio_clement_handle_t el)

Get Element stopping flag.
%%t el —[in] The audio element handle
R[] element’ s stopping flag

esp_err_t audio_element_update_byte_pos (audio_element_handle_t el, int pos)

Update the byte position of element information.
BH
¢ el [in] The audio element handle
» pos —[in] The byte_pos accumulated by this value
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_byte_pos (audio_element_handle_t el, int pos)

Set the byte position of element information.
S
¢ el —[in] The audio element handle
* pos —[in] This value is assigned to byte_pos
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_update_total_bytes (audio_element_handle_t el, int total_bytes)

Update the total bytes of element information.
S8
e el —[in] The audio element handle
* total_bytes [in] The total_bytes accumulated by this value
B
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_set_total_bytes (audio_element_handle_t el, int total_bytes)

Set the total bytes of element information.

S

¢ el [in] The audio element handle
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* total_bytes —[in] This value is assigned to total_bytes
B

» ESP_OK

» ESP_FAIL

esp_err_t audio_element_set_bps (audio_element_handle_t el, int bit_rate)

Set the bps of element information.
BH
¢ el —[in] The audio element handle
* bit_rate —[in] This value is assigned to bps
R M
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_codec_£mt (audio_element_handle_t el, int format)

Set the codec format of element information.
S8
¢ el —[in] The audio element handle
* format —[in] This value is assigned to codec_fmt
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_set_music_info (audio_element_handle_t el, int sample_rates, int channels, int
bits)

Set the sample_rate, channels, bits of element information.

S8
¢ el [in] The audio element handle
e sample_rates —[in] Sample_rates of music information
¢ channels —[in] Channels of music information
e bits —[in] Bits of music information

Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_set_duration (audio_element_handle_t el, int duration)

Set the duration of element information.
S8
¢ el —[in] The audio element handle
* duration —[in] This value is assigned to duration

B
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* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_reserve_userO0 (audio_element_handle_t el, int user_data0)

Set the user_data_0 of element information.
S8
¢ el [in] The audio element handle
* user_data0 —[in] This value is assigned to user_data_0
B
» ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_reserve_userl (audio_element_handle_t el, int user_datal )

Set the user_data_1 of element information.
S8
¢ el —[in] The audio element handle
* user_datal —[in] This value is assigned to user_data_1
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_set_reserve_user2 (audio_element_handle_t el, int user_data2)

Set the user_data_2 of element information.
S8
¢ el —[in] The audio element handle
* user_data2 —[in] This value is assigned to user_data_2
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_element_set_reserve_user3 (audio_element_handle_t el, int user_data3)

Set the user_data_3 of element information.
S
e el [in] The audio element handle
* user_data3 —[in] This value is assigned to user_data_3
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_element_set_reserve_user4 (audio_element_handle_t el, int user_data4)

Set the user_data_4 of element information.

S
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¢ el [in] The audio element handle

* user_data4 —[in] This value is assigned to user_data_4
B

* ESP_OK

* ESP_FAIL

Structures

struct audio_element_reserve_data_t

Audio Element user reserved data.

Public Members

int user_data_0

user data O

intuser_data_1

user data 1

int user_data_2

user data 2

intuser_data_3

user data 3

intuser_data_4

user data 4

struct audio_element_info_t

Audio Element informations.

Public Members

int sample_rates

Sample rates in Hz

int channels

Number of audio channel, mono is 1, stereo is 2

intbits
Bit wide (8, 16, 24, 32 bits)
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int bps

Bit per second

int64_t byte_pos

The current position (in bytes) being processed for an element

int64_t total_bytes

The total bytes for an element

int duration

The duration for an element (optional)

char *uri
URI (optional)

esp_codec_type_t codec_fmt

Music format (optional)

audio_element_reserve_data_t reserve_data

This value is reserved for user use (optional)

struct audio_element_cfg_t

Audio Element configurations. Each Element at startup will be a self-running task. These tasks will execute the
callback open -> [loop: read -> process -> write] -> close. These callback functions are provided by the user

corresponding to this configuration.

Public Members

el_io_func open

Open callback function

ctrl_func seek

Seek callback function

process_func process

Process callback function

el_io_func close

Close callback function

el_io_func destroy

Destroy callback function

stream_func read

Read callback function
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stream_func write

Write callback function

intbuffer_len

Buffer length use for an Element

int task_stack

Element task stack

int task_prio

Element task priority (based on freeRTOS priority)

int task_core

Element task running in core (0 or 1)

int out_rb_size

Output ringbuffer size

void *data

User context

const char *tag

Element tag

bool stack_in_ext

Try to allocate stack in external memory

intmulti_in_rb_num

The number of multiple input ringbuffer

intmulti_out_rb_num

The number of multiple output ringbuffer

Macros

AUDIO_ELEMENT_INFO_DEFAULT ()

DEFAULT_ELEMENT RINGBUF_SIZE

DEFAULT_ELEMENT_ BUFFER_LENGTH

DEFAULT_ELEMENT_ STACK_SIZE

DEFAULT_ ELEMENT_TASK_PRIO
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DEFAULT_ELEMENT_TASK_ CORE

DEFAULT_AUDIO_ELEMENT_CONFIG ()

Type Definitions

typedef struct audio_element *audio_element_handle_t

typedef esp_err_t (*el_io_func)(audio_element_handle_t self)

typedef audio_element_err_t (*process_func)(audio_element_handle_t self, char *el_buffer, int el_buf_len)

typedef audio_element_err_t (*stream_f£unc)(audio_element_handle_t self, char *buffer, int len, TickType_t
ticks_to_wait, void *context)

typedef esp_err_t (*event_cb_ func)(audio_element_handle_t el, audio_event_iface_msg_t *event, void *ctx)

typedef esp_err_t (*etrl_func)(audio_element_handle_t self, void *in_data, int in_size, void *out_data, int
*out_size)

Enumerations

enum audio_element_err_t

Values:

enumerator AEL_IO_OK

enumerator AEL,_IO_FAIL

enumerator AEL_IO_DONE

enumerator AEL,_IO_ABORT

enumerator AEL_IO_TIMEOUT

enumerator AEL_PROCESS_FAIL

enum audio_element_state_t

Audio element state.

Values:

enumerator AEL_STATE_NONE
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enumerator AEL_STATE_INIT

enumerator AEL_STATE_INITIALIZING

enumerator AEL_STATE_RUNNING

enumerator AEL_STATE_PAUSED

enumerator AEL,_STATE_STOPPED

enumerator AEL_STATE_FINISHED

enumerator AEL_STATE_ERROR

enum audio_element_msg_cmd_t

Audio element action command, process on dispatcher

Values:

enumerator AEL,_MSG_CMD_NONE

enumerator AEL_MSG_CMD_FINISH

enumerator AEL_MSG_CMD_STOP

enumerator AEL_MSG_CMD_PAUSE

enumerator AEL_MSG_CMD_RESUME

enumerator AEL_MSG_CMD_DESTROY

enumerator AEL_MSG_CMD_REPORT_STATUS

enumerator AEL_MSG_CMD_REPORT_MUSIC_INFO

enumerator AEL_MSG_CMD_REPORT_CODEC_FMT

enumerator AEL,_MSG_CMD_REPORT_POSITION

enum audio_element_status_t

Audio element status report

Values:
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enumerator AEL_STATUS__NONE

enumerator AEL,_STATUS_ERROR_OPEN

enumerator AEL_STATUS_ERROR_INPUT

enumerator AEL_STATUS_ERROR_PROCESS

enumerator AEL_STATUS_ERROR_OUTPUT

enumerator AEL_STATUS_ERROR_CLOSE

enumerator AEL_STATUS_ERROR_TIMEOUT

enumerator AEL_STATUS_ERROR_UNKNOWN

enumerator AEL_STATUS_INPUT_DONE

enumerator AEL_STATUS_INPUT_BUFFERING

enumerator AEL_STATUS_OUTPUT_DONE

enumerator AEL_STATUS_OUTPUT_BUFFERING

enumerator AEL_STATUS_STATE_RUNNING

enumerator AEL_STATUS_STATE_PAUSED

enumerator AEL_STATUS_STATE_STOPPED

enumerator AEL_STATUS_STATE_FINISHED

enumerator AEL_STATUS_MOUNTED

enumerator AEL_STATUS__UNMOUNTED
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2.1.2 Audio Pipeline

Dynamic combination of a group of linked Elements is done using the Audio Pipeline. You do not deal with the individual
elements but with just one audio pipeline. Every element is connected by a ringbuffer. The Audio Pipeline also takes care
of forwarding messages from the element tasks to an application.

A diagram below presents organization of three elements, HTTP reader stream, MP3 decoder and I2S writer stream, in
the Audio Pipeline, that has been used in player/pipeline_http_mp3 example.

&udia Pipeline

HTTP
reader
stream

125
writer

stream

Codec
chip

MP3
decoder

& 3: Sample Organization of Elements in Audio Pipeline

API Reference

Header File

» components/audio_pipeline/include/audio_pipeline.h

Functions

audio_pipeline_handle_t audio_pipeline_init (audio_pipeline_cfg_t *config)

Initialize audio_pipeline_handle_t object audio_pipeline is responsible for controlling the audio data stream and
connecting the audio elements with the ringbuffer It will connect and start the audio element in order, responsible
for retrieving the data from the previous element and passing it to the element after it. Also get events from each
element, process events or pass it to a higher layer.

%4 config —The configuration - audio_pipeline_cfg_t
Bl

* audio_pipeline_handle_t on success

* NULL when any errors

esp_err_t audio_pipeline_deinit (audio_pipeline_handle_t pipeline)

This function removes all of the element’ s links in audio_pipeline, cancels the registration of all events, invokes
the destroy functions of the registered elements, and frees the memory allocated by the init function. Briefly, frees
all memory.

%% pipeline —[in] The Audio Pipeline Handle
&l ESP_OK

esp_err_t audio_pipeline_register (audio_pipeline_handle_t pipeline, audio_element_handle_t el, const char
*name)

Registering an element for audio_pipeline, each element can be registered multiple times, but name (as String)
must be unique in audio_pipeline, which is used to identify the element for link creation mentioned in the
audio_pipeline_1link

38 Chapter 2. API Reference


https://github.com/espressif/esp-adf/tree/1bc914b/examples/player/pipeline_http_mp3
https://github.com/espressif/esp-adf/blob/1bc914b/components/audio_pipeline/include/audio_pipeline.h

ADF &4 R ZIESRF M, X7 latest

$511:: Because of stop pipeline or pause pipeline depend much on register order. Please register element strictly
in the following order: input element first, process middle, output element last.

SH
* pipeline —[in] The Audio Pipeline Handle
¢ el —[in] The Audio Element Handle

* name —[in] The name identifier of the audio_element in this audio_pipeline

ESP_OK on success
* ESP_FAIL when any errors

esp_err_t audio_pipeline_unregister (audio_pipeline_handle_t pipeline, audio_element_handle_t el)

Unregister the audio_element in audio_pipeline, remove it from the list.
S8
* pipeline [in] The Audio Pipeline Handle
¢ el —[in] The Audio Element Handle
Bl
e ESP_OK on success
* ESP_FAIL when any errors

esp_err_t audio_pipeline_run (audio_pipeline_handle_t pipeline)

Start Audio Pipeline.

With this function audio_pipeline will create tasks for all elements,
that have been linked using the linking functions.

%% pipeline —[in] The Audio Pipeline Handle
A

e ESP_OK on success

» ESP_FAIL when any errors

esp_err_t audio_pipeline_terminate (audio_pipeline_handle_t pipeline)
Stop Audio Pipeline.

With this function audio_pipeline will destroy tasks of all elements,
that have been linked using the linking functions.

%% pipeline —[in] The Audio Pipeline Handle
g}
¢ ESP_OK on success
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» ESP_FAIL when any errors

esp_err_t audio_pipeline_terminate_with_ticks (audio_pipeline_handle_t pipeline, TickType_t
ticks_to_wait)

Stop Audio Pipeline with specific ticks for timeout.

With this function audio_pipeline will destroy tasks of all elements,
that have been linked using the linking functions.

SH
* pipeline —[in] The Audio Pipeline Handle

* ticks_to_wait —[in] The maximum amount of time to block wait for element destroy

B

ESP_OK
» ESP_FAIL

esp_err_t audio_pipeline_resume (audio_pipeline_handle_t pipeline)
This function will set all the elements to the RUNNING state and process the audio data as an inherent feature of
audio_pipeline.

%% pipeline —[in] The Audio Pipeline Handle
Bl

* ESP_OK on success

» ESP_FAIL when any errors

esp_err_t audio_pipeline_pause (audio_pipeline_handle_t pipeline)
This function will set all the elements to the PAUSED state. Everything remains the same except the data processing
is stopped.

%% pipeline —[in] The Audio Pipeline Handle
Bl

e ESP_OK on success

» ESP_FAIL when any errors

esp_err_t audio_pipeline_stop (audio_pipeline_handle_t pipeline)
Stop all of the linked elements. Used with audio_pipeline_wait_for_stop to keep in sync. The link
state of the elements in the pipeline is kept, events are still registered. The stopped audio_pipeline restart by

audio_pipeline_resume.
%% pipeline —[in] The Audio Pipeline Handle
Bl
¢ ESP_OK on success
* ESP_FAIL when any errors
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esp_err_t audio_pipeline_wait_for_stop (audio_pipeline_handle_t pipeline)

The audio_pipeline_stop function sends requests to the elements and exits. But they need time to get rid
of time-blocking tasks. This function will wait portMAX_DELAY until all the Elements in the pipeline actually
stop.

%4 pipeline —[in] The Audio Pipeline Handle
Bl

* ESP_OK on success

* ESP_FAIL when any errors

esp_err_t audio_pipeline_wait_for_stop_with_ticks (audio_pipeline_handle_t pipeline, TickType_t
ticks_to_wait)

The audio_pipeline_stop function sends requests to the elements and exits. But they need time to get rid
of time-blocking tasks. This function will wait ticks_to_wait until all the Elements in the pipeline actually
stop.

S8

* pipeline —[in] The Audio Pipeline Handle

* ticks_to_wait —[in] The maximum amount of time to block wait for stop
Bl

* ESP_OK on success

* ESP_FAIL when any errors

esp_err_t audio_pipeline_link (audio_pipeline_handle_t pipeline, const char *link_tag[], int link_num)

The audio_element added to audio_pipeline will be unconnected before it is called by this function. Based on
element’ s name already registered by audio_pipeline_register, the path of the data will be linked in
the order of the link_tag. Element at index O is first, and index 1ink_num -1 is final. As well as audio_pipeline
will subscribe all element’ s events.

S8
* pipeline —[in] The Audio Pipeline Handle
* link_tag —Array of element name was registered by audio_pipeline_register
* link_num -[in] Total number of elements of the 1ink_tag array
A
¢ ESP_OK on success
» ESP_FAIL when any errors
esp_err_t audio_pipeline_unlink (audio_pipeline_handle_t pipeline)
Removes the connection of the elements, as well as unsubscribe events.
%% pipeline —[in] The Audio Pipeline Handle
Bl
e ESP_OK on success
» ESP_FAIL when any errors

audio_element_handle_t audio_pipeline_get_el_by_tag (audio_pipeline_handle_t pipeline, const char
*tag)

Find un-kept element from registered pipeline by tag.
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BH
* pipeline [in] The Audio Pipeline Handle
* tag —[in] A char pointer
Bl
* NULL when any errors
* Others on success

audio_element_handle_t audio_pipeline_get_el_once (audio_pipeline_handle_t pipeline, const
audio_element_handle_t start_el, const char *tag)

Based on beginning element to find un-kept element from registered pipeline by tag.
S
* pipeline —[in] The Audio Pipeline Handle
* start_el —[in] Specific beginning element
* tag —[in] A char pointer
Bl
* NULL when any errors
* Others on success

esp_err_t audio_pipeline_remove_listener (audio_pipeline_handle_t pipeline)

Remove event listener from this audio_pipeline.
%% pipeline —[in] The Audio Pipeline Handle
&Ml
* ESP_OK on success
* ESP_FAIL when any errors

esp_err_t audio_pipeline_set_listener (audio_pipeline_handle_t pipeline, audio_event_iface_handle_t
evt)

Set event listner for this audio_pipeline, any event from this pipeline can be listen to by evt
SH
* pipeline —[in] The Audio Pipeline Handle
¢ evt —[in] The Event Handle
B
¢ ESP_OK on success
* ESP_FAIL when any errors

audio_event_iface_handle_t audio_pipeline_get_event_iface (audio_pipeline_handle_t pipeline)
Get the event iface using by this pipeline.

%% pipeline —[in] The pipeline
jJRM The Event Handle
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esp_err_t audio_pipeline_link_insert (audio_pipeline_handle_t pipeline, bool first,
audio_element_handle_t prev, ringbuf _handle_t conect_rb,
audio_element_handle_t next)

Insert the specific audio_element to audio_pipeline, previous element connect to the next element by ring buffer.
» pipeline —[in] The audio pipeline handle
» first —[in] Previous element is first input element, need to set t rue
* prev —[in] Previous element
* conect_rb —[in] Connect ring buffer
* next —[in] Next element

Bl

* ESP_OK
» ESP_FAIL

esp_err_t audio_pipeline_register_more (audio_pipeline_handle_t pipeline, audio_element_handle_t
element_1, ...)

Register a NULL-terminated list of elements to audio_pipeline.
SH
* pipeline —[in] The audio pipeline handle
* element_1 —[in] The element to add to the audio_pipeline.
* ... —[in] Additional elements to add to the audio_pipeline.
Bl
* ESP_OK
» ESP_FAIL

esp_err_t audio_pipeline_unregister_more (audio_pipeline_handle_t pipeline, audio_element_handle_t
element_1, ...)

Unregister a NULL-terminated list of elements to audio_pipeline.
SH
* pipeline —[in] The audio pipeline handle
* element_1 —[in] The element to add to the audio_pipeline.
* ... [in] Additional elements to add to the audio_pipeline.
R m
* ESP_OK
» ESP_FAIL
esp_err_t audio_pipeline_link_more (audio_pipeline_handle_t pipeline, audio_element_handle_t element_1,
o)
Adds a NULL-terminated list of elements to audio_pipeline.

SH
* pipeline —[in] The audio pipeline handle
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* element_1 —[in] The element to add to the audio_pipeline.

* ... -[in] Additional elements to add to the audio_pipeline.
B

* ESP_OK

» ESP_FAIL

esp_err_t audio_pipeline_listen_more (audio_pipeline_handle_t pipeline, audio_element _handle_t
element 1, ...)

Subscribe a NULL-terminated list of element’ s events to audio_pipeline.
B8
* pipeline —[in] The audio pipeline handle
* element_1 [in] The element event to subscribe to the audio_pipeline.
* ... —-[in] Additional elements event to subscribe to the audio_pipeline.
B
* ESP_OK
» ESP_FAIL

esp_err_t audio_pipeline_check_items_state (audio_pipeline_handle_t pipeline, audio_element_handle_t
dest_el, audio element status_t status)

Update the destination element state and check the all of linked elements state are same.
S8
* pipeline —[in] The audio pipeline handle
* dest_el —[in] Destination element
e status —[in] The new status
Bl
 ESP_OK All linked elements state are same.
e ESP_FAIL All linked elements state are not same.

esp_err_t audio_pipeline_reset_items_state (audio_pipeline_handle_t pipeline)
Reset pipeline element items state to AEL_STATUS_NONE

%% pipeline —[in] The Audio Pipeline Handle
Bl

¢ ESP_OK on success

* ESP_FAIL when any errors

esp_err_t audio_pipeline_reset_ringbuffer (audio_pipeline_handle_t pipeline)
Reset pipeline element ringbuffer.

%% pipeline —[in] The Audio Pipeline Handle
Bl

¢ ESP_OK on success

* ESP_FAIL when any errors
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esp_err_t audio_pipeline_reset_elements (audio_pipeline_handle_t pipeline)
Reset Pipeline linked elements state.
%% pipeline —[in] The Audio Pipeline Handle
A
¢ ESP_OK on success
» ESP_FAIL when any errors

esp_err_t audio_pipeline_reset_kept_state (audio_pipeline_handle_t pipeline, audio_element_handle_t
el)

Reset the specific element kept state.
S8
* pipeline —[in] The Audio Pipeline Handle
* el [in] The Audio element Handle
Bl
* ESP_OK on success
* ESP_FAIL when any errors

esp_err_t audio_pipeline_breakup_elements (audio_pipeline_handle_t pipeline, audio_element_handle_t
kept_ctx_el)

Break up all the linked elements of specific pipeline. The include and before kept_ctx_el working
(AEL_STATE_RUNNING or AEL_STATE_PAUSED) elements and connected ringbuffer will be reserved.

£57E: There is no element reserved when kept_ctx_el is NULL. This function will unsubscribe all element’
S events.

S8

» pipeline —[in] The audio pipeline handle

* kept_ctx_el —[in] Destination keep elements
Bl

e ESP_OK All linked elements state are same.

* ESP_ERR_INVALID_ARG Invalid parameters.

esp_err_t audio_pipeline_relink (audio_pipeline_handle_t pipeline, const char *link_tag[], int link_num)

Basing on element’ s name already registered by audio_pipeline_register, relink the pipeline following
the order of names in the ‘link_tag.

$51:: If the ringbuffer is not enough to connect the new pipeline will create new ringbutffer.

S
* pipeline —[in] The Audio Pipeline Handle

* link_tag  —Array of  elements name that  was registered by
audio_pipeline_register
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* link_num -[in] Total number of elements of the 1ink_tag array
A

e ESP_OK All linked elements state are same.

e ESP_FAIL Error.
ESP_ERR_INVALID_ARG Invalid parameters.

esp_err_t audio_pipeline_relink_more (audio_pipeline_handle_t pipeline, audio_element _handle_t
element 1, ...)

Adds a NULL-terminated list of elements to audio_pipeline.

41z If the ringbuffer is not enough to connect the new pipeline will create new ringbutffer.

BH
* pipeline —[in] The Audio Pipeline Handle
* element_1 —[in] The element to add to the audio_pipeline.

e ... —[in] Additional elements to add to the audio_pipeline.

B

ESP_OK All linked elements state are same.
* ESP_FAIL Error.
* ESP_ERR_INVALID_ARG Invalid parameters.

esp_err_t audio_pipeline_change_state (audio_pipeline_handle_t pipeline, audio_element _state_t
new_state)

Set the pipeline state.
S
* pipeline —[in] The Audio Pipeline Handle
* new_state —[in] The new state will be set
Bl
 ESP_OK All linked elements state are same.
e ESP_FAIL Error.

Structures

struct audio_pipeline_cfg

Audio Pipeline configurations.

46 Chapter 2. API Reference



ADF E45R AF ZEZRF M, A7 latest

Public Members

int rb_size

Audio Pipeline ringbuffer size

Macros

DEFAULT PIPELINE_RINGBUF_SIZE

DEFAULT_AUDIO_PIPELINE_CONFIG ()

Type Definitions

typedef struct audio_pipeline *audio_pipeline_handle_t

typedef struct audio_pipeline_cfg audio_pipeline_cfg_t
Audio Pipeline configurations.
2.1.3 Event Interface
The ADF provides the Event Interface API to establish communication between Audio Elements in a pipeline. The API

is built around FreeRTOS queue. It implements ‘listeners’ to watch for incoming messages and inform about them with
a callback function.

Application Examples

Implementation of this API is demonstrated in couple of examples including get-started/play_mp3_control.

API Reference

Header File

» components/audio_pipeline/include/audio_event_iface.h

Functions

audio_event_iface_handle_t audio_event_iface_init (audio_event iface_cfg_t *config)

Initialize audio event.
%% config —The configurations
&I
* ESP_OK
» ESP_FAIL
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esp_err_t audio_event_iface_destroy (audio_event_iface_handle_t evt)

Cleanup event, it doesn’ t free evt pointer.
%4 evt —The event
&
» ESP_OK
» ESP_FAIL

esp_err_t audio_event_iface_set_listener (audio_event iface_handle_t evt, audio_event_iface_handle_t
listener)

Add audio event evt to the listener, then we can listen evt event from 1isten
S8
* listener —The event can listen another event
* evt —The event to be added to
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_event_iface_remove_listener (audio_event_iface_handle_t listener,
audio_event_iface_handle_t evt)

Remove audio event evt from the listener.
S8
* listener —The event listener
* evt —The event to be removed from
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_event_iface_set_cmd_waiting timeout (audio_event iface_handle_t evt, TickType_t
wait_time)

Set current queue wait time for the event.
S
* evt —The event
* wait_time —[in] The wait time
Bl
* ESP_OK
» ESP_FAIL
esp_err_t audio_event_iface_waiting_cmd_msg (audio_event_iface_handle_t evt)
Waiting internal queue message.
%%t evt —The event
Bl
* ESP_OK
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» ESP_FAIL

esp_err_t audio_event_iface_cmd (audio_event_iface_handle_t evt, audio_event_iface_msg_t *msg)

Trigger an event for internal queue with a message.
S8
* evt —The event
* msg —The message
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_event_iface_cmd_from_isr (audio_event iface_handle_t evt, audio_event_iface_msg_t
£
msg)

It’ ssame with audio_event_iface_cmd, but can send a message from ISR.
S8
¢ evt —[in] The event
* msg —The message
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_event_iface_sendout (audio_event_iface_handle_t evt, audio_event_iface_msg_t *msg)

Trigger and event out with a message.
BH
* evt —The event
* msg —The message
R M
* ESP_OK
» ESP_FAIL

esp_err_t audio_event_iface_discard (audio_event iface_handle_t evt)

Discard all ongoing event message.
%% evt —The event
Bl
* ESP_OK
* ESP_FAIL

esp_err_t audio_event_iface_listen (audio_event iface_handle_t evt, audio_event_iface_msg_t *msg,
TickType_t wait_time)

Listening and invoke callback function if there are any event are comming.
SH
* evt —The event

* msg —The message
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* wait_time —The wait time
B

* ESP_OK

» ESP_FAIL

QueueHandle_t audio_event_iface_get_queue_handle (audio_event_iface_handle_t evt)

Get External queue handle of Emmitter.
%4 evt —[in] The external queue
&M External QueueHandle_t

esp_err_t audio_event_iface_read (audio_event iface_handle_t evt, audio_event_iface_msg_t *msg,
TickType_t wait_time)

Read the event from all the registered event emitters in the queue set of the interface.
SH
e evt —[in] The event interface
* msg —[out] The pointer to structure in which event is to be received
* wait_time —[in] Timeout for receiving event
Bl
* ESP_OK On successful receiving of event
* ESP_FAIL In case of a timeout or invalid parameter passed

QueueHandle_t audio_event_iface_get_msg_queue_handle (audio_event_iface_handle_t evt)
Get Internal queue handle of Emmitter.

%% evt —[in] The Internal queue
&M Internal QueueHandle_t

esp_err_t audio_event_iface_set_msg_listener (audio_event iface_handle_t evt,
audio_event_iface_handle_t listener)

Add audio internal event evt to the listener, then we can listen evt event from 1isten
S8
* listener —The event can listen another event
* evt —The event to be added to
Bl
* ESP_OK
* ESP_FAIL
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Structures

struct audio_event_iface_msg_t

Event message

Public Members

int emd

Command id

void *data

Data pointer

int data_len

Data length

void *source

Source event

int source_type

Source type (To know where it came from)

bool need_free_data

Need to free data pointer after the event has been processed

struct audio_event_iface_cfg_t

Event interface configurations

Public Members

int internal_queue_size

It’ s optional, Queue size for event internal_queue

int external_queue_size

It’ s optional, Queue size for event external_queue

int queue_set_size

It’ s optional, QueueSet size for event queue_set

on_event_iface_func on_cmd

Function callback for listener when any event arrived

void *context

Context will pass to callback function
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TickType_t wait_time

Timeout to check for event queue

int type

it will pass to audio_event_iface_msg_t source_type (To know where it came from)

Macros

DEFAULT_AUDIO_EVENT_IFACE_SIZE

AUDIO_EVENT_ IFACE_DEFAULT_CFG ()

Type Definitions

typedef esp_err_t (*on_event_iface_func)(audio_event_iface_msg_t¥*, void*)

typedef struct audio_event_iface *audio_event_iface_handle_t

2.1.4 Audio Common

Enumerations that define type of Audio Elements, type and format of Codecs and type of Streams.

API Reference

Header File

» components/audio_pipeline/include/audio_common.h

Macros

ELEMENT_SUB_TYPE_OFFSET

mem_assert (Xx)

Enumerations

enum audio_element_type_t

Values:

enumerator AUDIO_ELEMENT TYPE_UNKNOW
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enumerator AUDIO_ELEMENT_TYPE_ELEMENT

enumerator AUDIO_ELEMENT TYPE_PLAYER

enumerator AUDIO_ELEMENT_TYPE_SERVICE

enumerator AUDIO_ELEMENT_ TYPE_PERIPH

enum audio_stream_type_t

Values:

enumerator AUDIO_STREAM NONE

enumerator AUDIO_STREAM READER

enumerator AUDIO_STREAM WRITER

enum audio_codec_type_t

Values:

enumerator AUDIO_CODEC_TYPE_NONE

enumerator AUDIO_CODEC_TYPE_DECODER

enumerator AUDIO_CODEC_TYPE_ENCODER

2.1.5 ESP Audio

This component provides several simple high level APIs. It is intended for quick implementation of audio applications

based on typical interconnections of standardized audio elements.

API Reference

Header File

* components/esp-adf-libs/esp_audio/include/audio_def.h
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Structures

struct esp_audio_state_t

esp_audio status information parameters

Public Members

esp_audio_status_t status

Status of esp_audio

audio_err_t err_msg

Status is AUDIO_STATUS_ERROR, err_msg will be setup

media_source_type_t media_src

Media source type

Macros

ESP_ERR_AUDIO_BASE

Starting number of ESP audio error codes

Type Definitions

typedef void (*esp_audio_event_callback)(esp_audio_state_t *audio, void *ctx)

typedef esp_err_t (*faudio_volume_set)(void *hd, int vol)

typedef esp_err_t (*faudio_volume_get)(void *hd, int *vol)

Enumerations

enum audio_err_t

Values:

enumerator ESP_ERR_AUDIO_NO_ERROR
enumerator ESP_ERR_AUDIO_FAIL

enumerator ESP_ERR_AUDIO_NO_INPUT_STREAM
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enumerator ESP_ERR_AUDIO_NO_OUTPUT_STREAM

enumerator ESP_ERR_AUDIO_NO_CODEC

enumerator ESP_ERR_AUDIO_HAL_FAIL

enumerator ESP_ERR_AUDIO_MEMORY_LACK

enumerator ESP_ERR_AUDIO_INVALID_URI

enumerator ESP_ERR_AUDIO_INVALID_PATH

enumerator ESP_ERR_AUDIO_INVALID_ PARAMETER

enumerator ESP_ERR_AUDIO_NOT_READY

enumerator ESP_ERR_AUDIO_NOT_SUPPORT

enumerator ESP_ERR_AUDIO_TIMEOUT

enumerator ESP_ERR_AUDIO_ALREADY EXISTS

enumerator ESP_ERR_AUDIO_LINK_FAIL

enumerator ESP_ERR_AUDIO_UNKNOWN

enumerator ESP_ERR_AUDIO_OUT_OF_RANGE

enumerator ESP_ERR_AUDIO_STOP_BY_ USER

enumerator ESP_ERR_AUDIO_OPEN

enumerator ESP_ERR_AUDIO_INPUT

enumerator ESP_ERR_AUDIO_PROCESS

enumerator ESP_ERR_AUDIO_OUTPUT

enumerator ESP_ERR_AUDIO_CLOSE

enum esp_audio_status_t

Values:

2.1. Audio Framework 55



ADF E4R AFF A HESRF M, &7 latest

enumerator AUDIO_STATUS_UNKNOWN

enumerator AUDIO_STATUS_RUNNING

enumerator AUDIO_STATUS_PAUSED

enumerator AUDIO_STATUS_STOPPED

enumerator AUDIO_STATUS_FINISHED

enumerator AUDIO_STATUS_ERROR

enum audio_termination_type_t

Values:

enumerator TERMINATION_TYPE_NOW

Audio operation will be terminated immediately

enumerator TERMINATION_TYPE_DONE
Audio operation will be stopped when finished

enumerator TERMINATION_TYPE_MAX

enum esp_audio_prefer_t

Values:

enumerator ESP_AUDIO_PREFER_MEM

enumerator ESP_AUDIO_PREFER_SPEED

enum media_source_type_t

Values:

enumerator MEDIA_SRC_TYPE_NULL

enumerator MEDIA_SRC_TYPE_MUSIC_BASE

enumerator MEDIA_SRC_TYPE_MUSIC_SD

enumerator MEDIA_SRC_TYPE_MUSIC_HTTP

enumerator MEDIA SRC_TYPE_MUSIC_FLASH
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enumerator MEDIA_SRC_TYPE_MUSIC_A2DP

enumerator MEDIA_SRC_TYPE_MUSIC_DLNA

enumerator MEDIA_SRC_TYPE_MUSIC_RAW

enumerator MEDIA_ SRC_TYPE_MUSIC_MAX

enumerator MEDIA_ SRC_TYPE_TONE_BASE

enumerator MEDIA_SRC_TYPE_TONE_SD

enumerator MEDIA_SRC_TYPE_TONE_HTTP

enumerator MEDIA_SRC_TYPE_TONE_FLASH

enumerator MEDIA_ SRC_TYPE_TONE_MAX

enumerator MEDIA_SRC_TYPE_RESERVE_BASE

enumerator MEDIA_SRC_TYPE_RESERVE_MAX

Header File

¢ components/esp-adf-libs/esp_audio/include/esp_audio.h

Functions

esp_audio_handle_t esp_audio_create (const esp_audio_cfg_t *cfg)

Create esp_audio instance according to ‘cfg’ parameter.
This function create an esp_audio instance, at the specified configuration.
24 cfqg -[in] Provide esp_audio initialization configuration
Bl
e NULL: Error
* Others: esp_audio instance fully certifying

audio_err_t esp_audio_destroy (esp_audio_handle_t handle)
Specific esp_audio instance will be destroyed.

%% handle —[in] The esp_audio instance
$EA |
¢« ESP_ERR_AUDIO_NO_ERROR: on success
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* ESP_ERR_AUDIO_INVALID_PARAMETER: no instance to free, call esp_audio_init first

audio_err_t esp_audio_input_stream_add (esp_audio_handle_t handle, audio_element_handle_t in_stream)

Add audio input stream to specific esp_audio instance.

S8
* handle —[in] The esp_audio instance
e in_stream —[in] Audio stream instance

Bl
* ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_MEMORY_LACK: allocate memory fail

audio_err_t esp_audio_output_stream_add (esp_audio_handle_t handle, audio_element_handle_t
out_stream)

Add audio output stream to specific esp_audio instance.

S8
* handle —[in] The esp_audio instance
e out_stream —[in] The audio stream element instance

Bl
* ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_MEMORY_LACK: allocate memory fail

audio_err_t esp_audio_codec_lib_add (esp_audio_handle_t handle, audio_codec_type_t type,
audio_element_handle_t 1ib)

Add a new codec lib that can decode or encode a music file.
S8
* handle —[in] The esp_audio instance
* type —[in] The audio codec type(encoder or decoder)

e 1lib —[in] To provide audio stream element

¢ ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_MEMORY_LACK: allocate memory fail

audio_err_t esp_audio_codec_lib_query (esp_audio_handle_t handle, audio_codec_type_t type, const char
*extension)

Check if this kind of music extension is supported or not.

£41:: This function just query the codec which has already add by esp_audio_codec_lib_add. The max length of
extension is 6.
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* handle —[in] The esp_audio instance
* type —[in] The CODEC_ENCODER or CODEC_DECODER
* extension —[in] Suchas “mp3” , “wav” , “aac”
&Ml
* ESP_ERR_AUDIO_NO_ERROR: supported
* ESP_ERR_AUDIO_NOT_SUPPORT: not support

» ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_play (esp_audio_handle_t handle, audio_codec_type_t type, const char *uri, int pos)

Play the given uri.

The esp_audio_play have follow activity, setup inputstream, outputstream and codec by uri, start all of them. There
is a rule that esp_audio will select input stream, codec and output stream by URI field.

Rule of URI field are as follow.

L]

UF_SCHEMA field of URI for choose input stream from existing streams. e.g:” http” ,” file”
UF_PATH field of URI for choose codec from existing codecs. e.g:” /audio/mp3_music.mp3”
UF_FRAGMENT field of URI for choose output stream from existing streams, output stream is I2S by default.

UF_USERINFO field of URI for specific sample rate and channels at encode mode.

The format “user:password” in the userinfo field, “user” is sample rate, “password” is channels.

Now esp_audio_play support follow URIs.

L]

7

https://dl.espressif.com/dl/audio/mp3_music.mp3”
” http://media-ice.musicradio.com/ClassicFMMP3”
" file://sdcard/test.mp3”

7 iis://16000:2@from.pcm/rec.wavifile”

iis://16000:1 @record.pcm/record. wav#raw”
aadp://44100:2@bt/sink/stream.pcm”
” hfp://8000:1@bt/hfp/stream.pcm”

The URI parse by http_parser_parse_url,any illegal string will be return
ESP_ERR_AUDIO_INVALID_URI.

If the esp_decoder codec is added to handle, then the handle of esp_decoder will be set as the default
decoder, even if other decoders are added.

Enabled CONFIG_FATFS_API_ENCODING_UTF_8, the URI can be support Chinese characters.
Asynchronous interface

The maximum of block time can be modify by esp_audio_play_timeout_set, default value is 25
seconds.

BH
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* handle The esp_audio_handle_t instance

* uri —Suchas “file://sdcard/test.wav” or “http://iot.espressif.com/file/example.mp3” . If
NULL to be set, the uri setup byesp_audio_setup will used.

* type —Specific handle type decoder or encoder
» pos —Specific starting position by bytes
A
* ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_TIMEOUT: timeout the play activity
e ESP_ERR_AUDIO_NOT_SUPPORT: Currently status is AUDIO_STATUS_RUNNING
e ESP_ERR_AUDIO_INVALID_URI: URI is illegal
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_STOP_BY_USER: Exit without play due to esp_audio_stop has been

called.

audio_err_t esp_audio_sync_play (esp_audio_handle_t handle, const char *uri, int pos)

Play the given uri until music finished or error occured.

ik
¢ All features are same with esp_audio_play
* Synchronous interface
 Support decoder mode only

» No any events post during playing

S8
* handle —The esp_audio_handle_t instance
e uri -Suchas ‘“file://sdcard/test.wav” or “http://iot.espressif.com/file/example.mp3” ,
* pos —Specific starting position by bytes
&I
e ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_TIMEOUT: timeout the play activity
* ESP_ERR_AUDIO_NOT_SUPPORT: Currently status is AUDIO_STATUS_RUNNING
* ESP_ERR_AUDIO_INVALID_URI: URI is illegal
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_stop (esp_audio_handle_t handle, audio_termination_type_t type)
A synchronous interface for stop the esp_audio. The maximum of block time is 8000ms.

f&1k: 1. If user queue has been registered by evt_que, AUDIO_STATUS_STOPPED event for success or
AUDIO_STATUS_ERROR event for error will be received.
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a. TERMINATION_TYPE_DONE only works with input stream which can’ t stopped by itself, e.g. raw
read/write stream, others streams are no effect.

b. The synchronous interface is used to ensure that working pipeline is stopped.

S8
* handle —[in] The esp_audio instance
* type —[in] Stop immediately or done
Bl
e« ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

 ESP_ERR_AUDIO_NOT_READY: The status is not AUDIO_STATUS_RUNNING or AU-
DIO_STATUS_PAUSED or element has not created

e ESP_ERR_AUDIO_TIMEOUT: timeout(8000ms) the stop activity.

audio_err_t esp_audio_pause (esp_audio_handle_t handle)
Pause the esp_audio.

£ 1. Only support music and without live stream. If user queue has been registered by evt_que, AU-
DIO_STATUS_PAUSED event for success or AUDIO_STATUS_ERROR event for error will be received.

a. The Paused music must be stoped by esp_audio_stop before new playing, otherwise got block on new
play.

%%, handle —[in] The esp_audio instance
P

ESP_ERR_AUDIO_NO_ERROR: on success
ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_NOT_READY: the status is not running

* ESP_ERR_AUDIO_TIMEOUT: timeout the pause activity.

audio_err_t esp_audio_resume (esp_audio_handle_t handle)

Resume the music paused.

£ 7¥:  Only support music and without live stream. If user queue has been registered by evt_que, AU-
DIO_STATUS_RUNNING event for success or AUDIO_STATUS_ERROR event for error will be received.

%%, handle —[in] The esp_audio instance

B
¢« ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments
* ESP_ERR_AUDIO_TIMEOUT: timeout the resume activity.
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audio_err_t esp_audio_eq gain_set (esp_audio_handle_t handle, int band_index, int nch, int eq_gain)

Set the audio gain to be processed by the equalizer.
BH
* handle —[in] The esp_audio instance

* band_index —[in] The position of center frequencies of equalizer. The range of eq band
index is [0 - 9].

* nch —[in] The number of channel. As for mono, the nch can only set to 1. As for dual, thc
nch can set to 1 and 2.

* eq_gain —[in] The value of audio gain which in band_index.
Bl

« ESP_ERR_AUDIO_NO_ERROR: on success

* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_eq gain_get (esp_audio_handle_t handle, int band_index, int nch, int *eq_gain)

Get the audio gain to be processed by the equalizer.
S
* handle [in] Audio element handle

* band_index —[in] The position of center frequencies of equalizer. The range of eq band
index is [0 - 9].

* nch —[in] The number of channel. As for mono, the nch can only set to 1. As for dual, thc
nch can set to 1 and 2.

* eq_gain —[out] The pointer of the gain processed by equalizer
A

e ESP_ERR_AUDIO_NO_ERROR: on success

* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_speed_get (esp_audio_handle_t handle, esp_audio_play_speed_t *speed_index)

Getting esp_audio play speed index, index value is from “esp_audio_speed_t” enum.
BH
* handle —[in] The esp_audio instance
* speed_index —[out] Current audio play speed index.
Bl
* ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_speed_set (esp_audio_handle_t handle, esp_audio_play_speed_t speed_index)

Use speed_index which is from ‘“esp_audio_speed_t” enum to set esp_audio play speed.
SH
* handle —[in] The esp_audio instance
* speed_index —[in] Value from “esp_audio_speed_t” enum.

B
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e ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_speed_idx_to_float (esp_audio_handle_t handle, esp_audio_play_speed_t
speed_index, float *speed)

Use speed_index which is from “esp_audio_speed_t” enum to get esp_audio play speed which is float type.
S
* handle —[in] The esp_audio instance
* speed_index —[in] Current audio play speed index.
* speed —[out] Current audio play speed.
Bl
« ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_vol_set (esp_audio_handle_t handle, int vol)

Setting esp_audio volume.
S8
* handle —[in] The esp_audio instance
* vol —[in] Specific volume will be set. 0-100 is legal. 0 will be mute.
A
e ESP_ERR_AUDIO_NO_ERROR: on success
« ESP_ERR_AUDIO_CTRL_HAL_FAIL: error with hardware.
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_vol_get (esp_audio_handle_t handle, int *vol)

Get esp_audio volume.

S8
* handle —[in] The esp_audio instance
* vol —[out] A pointer to int that indicates esp_audio volume.

Bl
e ESP_ ERR_AUDIO NO_ERROR: on success
e ESP_ERR_AUDIO_CTRL_HAL_FAIL: error with hardware.
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_state_get (esp_audio_handle_t handle, esp_audio_state_t *state)
Get esp_audio status.

S8

* handle [in] The esp_audio instance

* state —[out] A pointer to esp_audio_state_t that indicates esp_audio status.
Bl

¢ ESP_ ERR_AUDIO NO_ERROR: on success
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* ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance or esp_audio does not
playing
audio_err_t esp_audio_pos_get (esp_audio_handle_t handle, int *pos)
Get the position in bytes of currently played music.

$41E: This function works only with decoding music.

* handle —[in] The esp_audio instance

» pos —[out] A pointer to int that indicates esp_audio decoding position.

e ESP_ERR_AUDIO_NO_ERROR: on success
ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance
ESP_ERR_AUDIO_NOT_READY: no codec element

audio_err_t esp_audio_time_get (esp_audio_handle_t handle, int *time)

Get the position in microseconds of currently played music.

£ 1#: This function works only with decoding music.

BH
* handle —[in] The esp_audio instance
* time [out] A pointer to int that indicates esp_audio decoding position.
Bl
e« ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance
e ESP_ ERR_AUDIO _NOT _READY: no out stream

audio_err_t esp_audio_setup (esp_audio_handle_t handle, esp_audio_setup_t *sets)

Choose the in_stream, codec and out_stream definitely, and set uri.

%5 1:  This function provide a manual way to select in/out stream and codec, should be called before the
esp_audio_play, then ignore the esp_audio_play URI parameter only one time.

S8
* handle —[in] The esp_audio instance
* sets —[in] A pointer to esp_audio_setup_t.
Bl
¢« ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance
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* ESP_ERR_AUDIO_MEMORY_LACK: allocate memory fail

audio_err_t esp_audio_media_type_set (esp_audio_handle_t handle, media_source_type_t type)
audio_err_t esp_audio_music_info_get (esp_audio_handle_t handle, esp_audio_music_info_t *info)
audio_err_t esp_audio_info_get (esp_audio_handle_t handle, esp_audio_info_t *info)

audio_err_t esp_audio_info_set (esp_audio_handle_t handle, esp_audio_info_t *info)

audio_err_t esp_audio_callback_set (esp_audio_handle_t handle, esp_audio_event _callback cb, void
*cb_ctx)

audio_err_t esp_audio_seek (esp_audio_handle_t handle, int seek_time_sec)

Seek the position in second of currently played music.

4122 This function works only with decoding music.

S8

* handle —[in] The esp_audio instance

* seek_time_sec —[out] A pointer to int that indicates esp_audio decoding position.
Bl

* ESP_ERR_AUDIO_NO_ERROR: on success

« ESP_ERR_AUDIO_FAIL: codec or allocation fail

* ESP_ERR_AUDIO_TIMEOUT: timeout for sync the element status

* ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance

* ESP_ERR_AUDIO_NOT_SUPPORT: codec has finished

* ESP_ERR_AUDIO_OUT_OF_RANGE: the seek_time_ms is out of the range

* ESP_ERR_AUDIO_NOT_READY: the status is neither running nor paused

audio_err_t esp_audio_duration_get (esp_audio_handle_t handle, int *duration)

Get the duration in microseconds of playing music.

$41E: This function works only with decoding music.

* handle —[in] The esp_audio instance

* duration —[out] A pointer to int that indicates decoding total time.

B m

ESP_ERR_AUDIO_NO_ERROR: on success
ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance

« ESP_ERR_AUDIO_NOT_READY: no codec element or no in element
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audio_err_t esp_audio_play_timeout_set (esp_audio_handle_t handle, int time_ms)

Setting the maximum amount of time to waiting for esp_audio_play only.
S8
* handle —[in] The esp_audio instance
e time_ms —[in] The maximum amount of time
Bl
e ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: invalid arguments

audio_err_t esp_audio_prefer_type_get (esp_audio_handle_t handle, esp_audio_prefer_t *type)
Get the type of esp_audio_prefer_t

S
* handle —[in] The esp_audio instance
* type —[out] A pointer to esp_audio_prefer_t
Bl
e ESP_ERR_AUDIO_NO_ERROR: on success
* ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance

audio_err_t esp_audio_event_que_set (esp_audio_handle_t handle, QueueHandle_t que)
Set event queue to notify the esp_audio status.

B8

* handle —[in] The esp_audio instance

* que —[out] A pointer to QueueHandle_t
A

ESP_ERR_AUDIO_NO_ERROR: on success
ESP_ERR_AUDIO_INVALID_PARAMETER: no esp_audio instance

Structures

struct esp_audio_cfg_t

esp_audio configuration parameters

Public Members

int in_stream_buf_size

Input buffer size

int out_stream_buf_size

Output buffer size
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int resample_rate

Destination sample rate, O: disable resample; others: 44.1K, 48K, 32K, 16K, 8K has supported It should be
make sure same with I2S stream sample_rate

int component_select

The select of audio forge component. eg. To choose equalizer and ALC together, please enter
ESP_AUDIO_COMPONENT_SELECT_ALC | ESP_AUDIO_COMPONENT_SELECT_EQUALIZER.

QueueHandle_t evt_que

For received esp_audio events (optional)

esp_audio_event_callback cb_£func

esp_audio events callback (optional)

void *cb_ctx

esp_audio callback context (optional)

esp_audio_prefer_t prefer_type
esp_audio works on sepcific type, default memory is preferred.

e ESP_AUDIO_PREFER_MEM mode stopped the previous linked elements before the new pipeline start-
ing, except out stream element.

e ESP_AUDIO_PREFER_SPEED mode kept the previous linked elements before the new pipeline start-

ing, except out stream element.

void *vol_handle

Volume change instance

audio_volume_set vol_set

Set volume callback

audio_volume_get vol_get

Get volume callback

int task_prio

esp_audio task priority

int task_stack

Size of esp_audio task stack

struct esp_audio_setup_t

esp_audio setup parameters by manual
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Public Members

audio_codec_type_t set_type
Set codec type

int set_sample_rate

Set music sample rate

int set_channel

Set music channels

int set_pos

Set starting position

int set_time

Set starting position of the microseconds time (optional)

char *set_uri
Set URI

char *set_in_stream

Tag of in_stream

char *set_codec

Tag of the codec

char *set_out_stream

Tag of out_stream

struct esp_audio_info_t

esp_audio information

Public Members

audio_element_info_t codec_info

Codec information

audio_element_handle_t in_el

Handle of the in stream

audio_element_handle_t out_el

Handle of the out stream

audio_element_handle_t codec_el

Handle of the codec
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audio_element_handle_t £ilter_el
Handle of the filter

esp_audio_state_t st

The state of esp_audio

int time_pos

Position of the microseconds time

float audio_speed

Play speed of audio

intb4_t in_stream_total_size

Total size of in stream

struct esp_audio_music_info_t

The music informations.

Public Members

int sample_rates

Sample rates in Hz

int channels

Number of audio channel, mono is 1, stereo is 2

intbits
Bit wide (8, 16, 24, 32 bits)

int bps

Bit per second

esp_codec_type_t codec_fmt

Music format

Macros
ESP_AUDIO_COMPONENT_SELECT_DEFAULT
Default selected

ESP_AUDIO_COMPONENT_SELECT_ALC
ALC selected
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ESP_AUDIO_COMPONENT_ SELECT_ EQUALIZER

Equalizer selected

DEFAULT_ESP_AUDIO_CONFIG ()
Type Definitions

typedef void *esp_audio_handle_t
Enumerations

enum esp_audio_play_speed_t
esp_audio play speed

Values:

enumerator ESP_AUDIO_PLAY_ SPEED_UNKNOW
enumerator ESP_AUDIO_PLAY_SPEED_0_50
enumerator ESP_AUDIO_PLAY_SPEED_O0_75
enumerator ESP_AUDIO_PLAY_SPEED_1_00
enumerator ESP_AUDIO_PLAY_SPEED_1_25
enumerator ESP_AUDIO_PLAY SPEED_1_50
enumerator ESP_AUDIO_PLAY_SPEED_1_75
enumerator ESP_AUDIO_PLAY_SPEED_2_00

enumerator ESP_AUDIO_PLAY SPEED_ MAX
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o FatFs %
o HTTP i
o 2SR

o PWM 3
hd },—‘?‘&é‘/ﬂfh

AR (stream) A5 — > 5K AE B B A S T w0 s 4k, HR [ #) audio_element_handle_t
A R A audio_element.h o & 4. K £ i B A7 AUDIO_STREAM_READER (i) Hl
AUDIO_STREAM_WRITER (&) WiFhk#Al, fldn, w{lifHi2s_stream init () Mlil2s_stream_cfqg t
Kl B 128 8y,

AKX APLIYTEAIE R, WS T .
221 EiEiR
SR (algorithm stream) £ =2 (0] F K B (AEC). A 3f3fand= il (AGC). MErs | (NS) SFpismiayk, T

GBI B, # T VoI, EEHRR, iR T WU ERA A . R esps, Lk R
KWAE, HHZF; AUDIO_STREAM_READER KA,

Rz R R fi
* advanced_examples/algorithm/main/algorithm_examples.c
e protocols/voip/main/voip_app.c

Header File

e components/audio_stream/include/algorithm_stream.h

Functions

audio_element_handle_t algo_stream_init (algorithm_stream_cfg_t *config)

Initialize algorithm stream.
%% config —The algorithm Stream configuration

& [n] The audio element handle
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audio_element_err_t algo_stream_set_delay (audio_element_handle_t el, ringbuf_handle_t ringbuf, int
delay_ms)

Set playback signal or recording signal delay when use type2.

£ 1:: The AEC internal buffering mechanism requires that the recording signal is delayed by around 0 - 10 ms
compared to the corresponding reference (playback) signal.

BH
* el —Handle of element
* ringbuf -Handle of ringbuf

* delay_ms —The delay between playback and recording in ms This delay_ms can be debugged
by yourself, you can set the configuration debug_input to true, then get the original input data
(left channel is the signal captured from the microphone, right channel is the signal played to
the speaker), and check the delay with an audio analysis tool.

* ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t algorithm_mono_f£ix (uint8_t *sbuff, uint32_t len)

Fix I2S mono noise issue.

£ 1i: This API only for ESP32 with 12S 16bits

SH
* sbuff -12S data buffer
* len -I2S data len

&\ ESP_OK

Structures

struct algorithm_stream_cfg_t

Algorithm stream configurations.
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Public Members

algorithm_stream_input_type_t input_type

Input type of stream

int task_stack

Task stack size

int task_prio
Task peroid

int task_core

The core that task to be created

int out_rb_size

Size of output ringbuffer

bool stack_in_ext

Try to allocate stack in external memory

int rec_linear_factor

The linear amplication factor of record signal

int ref_linear_ factor

The linear amplication factor of reference signal

bool debug_input
debug algorithm input data

bool swap_ch

Swap left and right channels

int8_t algo_mask

Choose algorithm to use

int sample_rate
The sampling rate of the input PCM (in Hz)

intmic_ch

MIC channel num

int age_gain

AGC gain(dB) for voice communication

bool aec_low_cost

AEC uses less cpu and ram resources, but has poor suppression of nonlinear distortion
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char *partition_label

Partition label which stored the model data

Macros

ALGORITHM_STREAM PINNED_TO_CORE

ALGORITHM_ STREAM TASK_PERIOD

ALGORITHM_STREAM_ RINGBUFFER_SIZE

ALGORITHM_STREAM TASK_ STACK_SIZE

ALGORITHM STREAM DEFAULT_SAMPLE_RATE_HZ

ALGORITHM STREAM DEFAULT_SAMPLE_BIT

ALGORITHM STREAM DEFAULT_MIC_CHANNELS

ALGORITHM_STREAM DEFAULT_AGC_GAIN_DB

ALGORITHM_STREAM DEFAULT_ MASK

ALGORITHM STREAM CFG_DEFAULT ()

Enumerations

enum algorithm_stream_input_type_t
Two types of algorithm stream input method.

Values:

enumerator ALGORITHM_STREAM_INPUT_TYPE1l

Type 1 is default used by mini-board, the reference signal and the recording signal are respectively read in
from the left channel and the right channel of the same 12S

enumerator ALGORITHM_STREAM_INPUT_TYPE2

As the simple diagram above shows, when type?2 is choosen, the recording signal and reference signal should
be input by users.

enum algorithm_stream_mask_t

Choose the algorithm to be used.

Values:
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enumerator ALGORITHM_STREAM_USE_AEC
Use AEC

enumerator ALGORITHM_STREAM_USE_AGC
Use AGC

enumerator ALGORITHM_STREAM_USE_NS
Use NS

enumerator ALGORITHM_STREAM_USE_VAD
Use VAD

2.2.2 FatFs &

FatFs Jii )\ FatFs SCUF RGeSO G A%ds, BAEMEWMER, KA Haudio stream type t & L.

R R BI

o SERARIRM: player/pipeline_play_sdcard_music

o HRAIRH: recorder/pipeline_recording_to_sdcard
Header File

¢ components/audio_stream/include/fatfs_stream.h

Functions

audio_element_handle_t fatfs_stream_init (fatfs_stream_cfg_t *config)

Create a handle to an Audio Element to stream data from FatFs to another Element or get data from other ele-
ments written to FatFs, depending on the configuration the stream type, either AUDIO_STREAM_READER or
AUDIO_STREAM_WRITER.

%% config —The configuration
&l The Audio Element handle

Structures

struct fatfs_stream_cfg t

FATEFS Stream configurations, if any entry is zero then the configuration will be set to default values.
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Public Members

audio_stream_type_t type

Stream type

intbuf_sz

Audio Element Buffer size

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool ext_stack

Allocate stack on extern ram

bool write_header

Choose to write amrnb/amrwb header in fatfs whether or not (true or false, true means choose to write amrnb

header)

Macros

FATFS_STREAM BUF_SIZE

FATFS_STREAM TASK_STACK

FATFS_STREAM TASK_CORE

FATFS_STREAM_ TASK_PRIO

FATFS_STREAM RINGBUFFER_SIZE

FATFS_STREAM CFG_DEFAULT ()
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223 HTTP %

e

HTTP i il i esp_http_client () 3R WU Al & 2% $c 4, H A &M 5 W M2k 8, X
Haudio_stream type t % ¥, AUDIO_STREAM_READER 3 ## HTTP., HTTPS #1 HTTP i B % it

sl (HTTP Live Stream) 5 ML, {03 75 20 e 2

=%

Rz R R

* BERAURH]
— player/pipeline_living_stream
— player/pipeline_http_mp3

- BHREURHI

— recorder/pipeline_raw_http

Header File

» components/audio_stream/include/http_stream.h

Functions

audio_element_handle_t http_stream_init (h#p_stream_cfg_t *config)
Create a handle to an Audio Element to stream data from HTTP to another Element or get data from other el-
ements sent to HTTP, depending on the configuration the stream type, either AUDIO_STREAM_READER or

AUDIO_STREAM_WRITER.
%% config —The configuration
&[] The Audio Element handle

esp_err_t http_stream_next_track (audio_element_handle_t el)

Connect to next track in the playlist.

This function can be used in event_handler of http_stream.
User can call this function to connect to next track in playlist when he/
—she gets "HTTP_STREAM_FINISH_TRACK® event

%% el —The http_stream element handle
Bl

* ESP_OK on success

e ESP_FAIL on errors

esp_err_t http_stream_restart (audio_element_handle_t el)

esp_err_t http_stream_fetch_again (audio_element_handle_t el)

Try to fetch the tracks again.
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If this is live stream we will need to keep fetching URIs.

%4 el —The http_stream element handle
Bl
* ESP_OK on success
* ESP_ERR_NOT_SUPPORTED if playlist is finished

esp_err_t http_stream_set_server_cert (audio_clement_handle_t el, const char *cert)

Set SSL server certification.

412 EM format as string, if the client requires to verify server

S

* el —The http_stream element handle
* cert —server certification

B
¢ ESP_OK on success

Structures

struct http_stream_event_msg_t

Stream event message.

Public Members

http_stream_event_id_t event_id
Event ID

void *http_client
Reference to HTTP Client using by this HTTP Stream

void *buffer

Reference to Buffer using by the Audio Element

intbuffer_len
Length of buffer

void *user_data

User data context, from http stream cfg t
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audio_element_handle_t el

Audio element context

struct http_stream_cfg_t

HTTP Stream configurations Default value will be used if any entry is zero.

Public Members

audio_stream_type_t type

Type of stream

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

http_stream_event_handle_t event _handle
The hook function for HTTP Stream

void *user_data

User data context

bool auto_connect_next_track

connect next track without open/close

bool enable_playlist_parser
Enable playlist parser

intmulti_out_num

The number of multiple output

const char *cert_pem

SSL server certification, PEM format as string, if the client requires to verify server

2.2, FR

79



ADF E4R AFF A HESRF M, &7 latest

esp_err_t (*ert_bundle_attach)(void *conf)

Function pointer to esp_crt_bundle_attach. Enables the use of certification bundle for server verification,
must be enabled in menuconfig

int request_size

Request data size each time from http_client Defaults use DE-
FAULT_ELEMENT_BUFFER_LENGTH if set to O Need care this setting if audio frame size is
small and want low latency playback

int request_range_size

Range size setting for header Range: bytes=start-end Request full range of resource if set to 0
Range size bigger than request size is recommended

const char *user_agent

The User Agent string to send with HTTP requests

Macros

HTTP_STREAM_TASK_STACK

HTTP_STREAM_TASK_CORE

HTTP_STREAM_TASK_PRIO

HTTP_STREAM_ RINGBUFFER_SIZE

HTTP_STREAM_CFG_DEFAULT ()

Type Definitions

typedef int (*http_stream_event_handle_t)(htp_stream_event_msg_t *msg)

Enumerations

enum http_stream_event_id_t

HTTP Stream hook type.

Values:

enumerator HTTP_ STREAM PRE_REQUEST

The event handler will be called before HTTP Client making the connection to the server
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enumerator HTTP_ STREAM ON_REQUEST

The event handler will be called when HTTP Client is requesting data, If the fucntion return the value (-1:
ESP_FAIL), HTTP Client will be stopped If the fucntion return the value > 0, HTTP Stream will ignore the
post_field If the fucntion return the value = 0, HTTP Stream continue send data from post_field (if any)

enumerator HTTP_ STREAM_ON_RESPONSE

The event handler will be called when HTTP Client is receiving data If the fucntion return the value (-1:
ESP_FAIL), HTTP Client will be stopped If the fucntion return the value > 0, HTTP Stream will ignore the
read function If the fucntion return the value = 0, HTTP Stream continue read data from HTTP Server

enumerator HTTP_ STREAM POST_REQUEST
The event handler will be called after HTTP Client send header and body to the server, before fetching the

headers

enumerator HTTP_ STREAM FINISH_REQUEST
The event handler will be called after HTTP Client fetch the header and ready to read HTTP body

enumerator HTTP_ STREAM_RESOLVE_ALL_TRACKS
enumerator HTTP_STREAM FINISH_TRACK

enumerator HTTP_STREAM_FINISH_PLAYLIST

2.24 12S i
128 it i 12S. PDM. ADC. DAC £ HHZWON Sk i, Hod ADC. DAC ZhRETG 20t g X

SOC_I2S_SUPPORTS_ADC_DAC, I2S Jiii Sl H B T4 (ALC) R IHAT & &, ZiHiEH By R AR S
BRI TE , M AT E XAE 125 _stream cfg_t W,

Rz R R4

o ZHKRRB: recorder/pipeline_wav_amr_sdcard
o HRRIRH: get-started/play_mp3_control

Header File

* components/audio_stream/include/i2s_stream.h
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Functions

audio_element_handle_t 12s_stream_init (i2s_stream_cfg_t *config)
Create a handle to an Audio Element to stream data from I2S to another Element or get data from other el-
ements sent to 12S, depending on the configuration of stream type is AUDIO_STREAM_READER or AU-
DIO_STREAM_WRITER.

f4{k:  If 12S stream is enabled with built-in DAC mode, please don’ t use I2S_NUM_1. The built-in DAC
functions are only supported on 12S0 for the current ESP32 chip.

%% config —The configuration
j&[\ The Audio Element handle

esp_err_t i2s_stream_set_channel_type (i2s_stream_cfg_t *config, i2s_channel_type_t type)
Set 12S stream channel format type.

£41:: : This function only updates i2s_stream_cfg_t, so it needs to be called before i2s_stream_init.

BH
* config —[in] The I2S stream configuration
* type —[in] I2S channel format type
B
* ESP_OK
* ESP_ERR_INVALID_ARG

esp_err_t i2s_stream_set_clk (audio_element_handle_t i2s_stream, int rate, int bits, int ch)

Setup clock for I2S Stream, this function is only used with handle created by 12s_stream_init
SH
e i2s_stream —[in] The i2s element handle
e rate [in] Clock rate (in Hz)
* bits —[in] Audio bit width (8, 16, 24, 32)

¢ ch—[in] Number of Audio channels (1: Mono, 2: Stereo). But when set to tdm mode, ch is slot
mask.(ex: 12S_TDM_SLOTO | 12S_TDM_SLOT1 | 12S_TDM_SLOT2 | 12S_TDM_SLOT?3)

gml
« ESP_OK
« ESP_FAIL

esp_err_t i2s_alc_volume_set (audio_element_handle_t i2s_stream, int volume)

Set the volume of input audio stream with ALC. Positive value indicates an increase in volume, negative value
indicates a decrease in volume, 0 indicates the volume level remains unchanged.

ZH

e i2s_stream —[in] The i2s element handle
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* volume —[in] The gain of input audio stream:
— Supported range [-64, 63], unit: dB
B
* ESP_OK
» ESP_FAIL

esp_err_t i2s_alc_volume_get (audio_element_handle_t i2s_stream, int *volume)

Get volume of stream.
S8
e i2s_stream —[in] The i2s element handle
¢ volume —[in] The volume of stream
Bl
* ESP_OK
» ESP_FAIL

esp_err_t i2s_stream_sync_delay (audio_element_handle_t i2s_stream, int delay_ms)

Set sync delay of stream.
S8
e i2s_stream [in] The i2s element handle
* delay_ms —[in] The delay of stream
Bl
* ESP_OK
* ESP_FAIL

Structures

struct i2s_stream_cfg_t

12S Stream configurations Default value will be used if any entry is zero.

Public Members

audio_stream_type_t type

Type of stream

i2s_comm_mode_t transmit_mode

12S transmit mode

i2s_chan_config_t chan_cfg

I12S controller channel configuration
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i2s_std_config_t std_cfg

12S standard mode major configuration that including clock/slot/gpio configuration

i2s_data_bit_width_t expand_src_bits

The source bits per sample when data expand

bool use_alc

It is a flag for ALC. If use ALC, the value is true. Or the value is false

int volume

The volume of audio input data will be set.

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

intmulti_out_num

The number of multiple output

bool uninstall_drv

whether uninstall the i2s driver when stream destroyed

bool need_expand

whether to expand i2s data

intbuffer_len

Buffer length use for an Element. Note: when ‘bits_per_sample’ is 24 bit, the buffer length must be a
multiple of 3. The recommended value is 3600
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Macros

I2S_STREAM TASK_STACK

I12S_STREAM BUF_SIZE

I2S_STREAM TASK_PRIO

I2S_STREAM_TASK_CORE

I2S_STREAM_RINGBUFFER_SIZE
I2S_STREAM_CFG_DEFAULT ()

I2S_STREAM CFG_DEFAULT_ WITH_PARA (port, rate, bits, stream_type)

I2S_STD_PHILIPS_SLOT_DEFAULT_ADF_CONFIG (bits_per_sample, mono_or_stereo)

I2S_STREAM CFG_DEFAULT_WITH_TYLE_AND_CH (port, rate, bits, stream_type, channel)

Enumerations
enum i2s_channel_type_t

Values:

enumerator I2S_CHANNEL_TYPE_RIGHT_LEFT
Separated left and right channel

enumerator I2S_CHANNEL_TYPE_ALL_RIGHT

Load right channel data in both two channels

enumerator I2S_CHANNEL_TYPE_ALL_LEFT

Load left channel data in both two channels

enumerator I2S_CHANNEL_TYPE_ONLY_ RIGHT

Only load data in right channel (mono mode)

enumerator I2S_CHANNEL_TYPE_ONLY_LEFT

Only load data in left channel (mono mode)
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2.2.5 PWM %

— B ARGUR s, EE S A DAC $E T, M2 PWM XI5 5304708 il 9 28 40 958 ipl riL ik 52
P, PWM JLsEBl 145t 0 A i PWM A8 0 &% DiRE, N AUDIO_STREAM_WRITER %Y,
R, PWM BB (E IR AR

2 R R fi

o ERARMHI: player/pipeline_play_mp3_with_dac_or_pwm

Header File

e components/audio_stream/include/pwm_stream.h

Functions

audio_element_handle_t pwm_stream_init (pwm_stream_cfg_t *config)
Initialize PWM stream Only support AUDIO_STREAM_READER type.

%%t config-The PWM Stream configuration
& 0] The audio element handle

esp_err_t pwm_stream_set_clk (audio_element_handle_t pwm_stream, int rate, int bits, int ch)

Setup clock for PWM Stream, this function is only used with handle created by pwm_stream_init
S8
* pwm_stream —[in] The pwm element handle
e rate —[in] Clock rate (in Hz)
* bits —[in] Audio bit width (16, 32)
¢ ch [in] Number of Audio channels (1: Mono, 2: Stereo)
Bl
* ESP_OK
* ESP_FAIL

Structures

struct audio_pwm_config_t

PWM audio configurations.
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Public Members

timer_group_t tg_num

timer group number (0 - 1)

timer_idx_t timer_num

timer number (0 - 1)

int gpio_num_left

the LEDC output gpio_num, Left channel

int gpio_num_right

the LEDC output gpio_num, Right channel

ledc_channel_t ledc_channel_left
LEDC channel (0 - 7), Corresponding to left channel

ledc_channel_t ledec_channel_right

LEDC channel (0 - 7), Corresponding to right channel

ledc_timer_t ledc_timer_ sel

Select the timer source of channel (0 - 3)

ledc_timer_bit_t duty_resolution

ledc pwm bits

uint32_t data_1len

ringbuffer size

struct pwm_stream_cfg_t

PWM Stream configurations Default value will be used if any entry is zero.

Public Members

audio_stream_type_t type

Type of stream

audio_pwm_config_t pwm_config

driver configurations

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size
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int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

intbuffer_len

pwm_stream buffer length

bool ext_stack

Allocate stack on extern ram
Macros

PWM_STREAM GPIO_NUM_LEFT
PWM_STREAM GPIO_NUM_RIGHT
PWM_STREAM_TASK_STACK
PWM_STREAM BUF_SIZE
PWM_STREAM_TASK_PRIO
PWM_STREAM_TASK_CORE
PWM_STREAM RINGBUFFER_SIZE

PWM_CONFIG_RINGBUFFER_SIZE

PWM_STREAM_CFG_DEFAULT ()

2.2.6 [Ri8%

JR IR (raw stream) FH T 3K O 82 B9 BT goc R f h BUE, BB NSRRI CRIH R, A5 A&
.2k FE. AUDIO_STREAM_READER HJ R J5 28 [i2s] -> [filter] -> [raw] B{ [i2s] -> [codec-amr] -> [raw],
AUDIO_STREAM_WRITER [ 7N [raw]->[codec-mp3]->[i2s].
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Rz R R

o BERAURHI: protocols/voip

o ERARAI: advanced_examples/downmix_pipeline

Header File

» components/audio_stream/include/raw_stream.h

Functions

audio_element_handle_t raw_stream_init (raw_stream_cfg_t *cfg)

Initialize RAW stream.
%% cfg-The RAW Stream configuration
#&[n] The audio element handle

int raw_stream_read (audio_element_handle_t pipeline, char *buffer, int buf_size)

Read data from Stream.
SH
* pipeline —The audio pipeline handle
* buffer -The buffer
* buf_size -Maximum number of bytes to be read.
&1l Number of bytes actually read.

int raw_stream_write (audio_element_handle_t pipeline, char *buffer, int buf_size)

Write data to Stream.
BH
* pipeline —The audio pipeline handle
* buffer The buffer
* buf_size —Number of bytes to write

J& 8] Number of bytes written

Structures

struct raw_stream_cfg_t

Raw stream provides APIs to obtain the pipeline data without output stream or fill the pipeline data without input
stream. The stream has two types / modes, reader and writer:

¢ AUDIO_STREAM_READER, e.g. [i2s]->[filter]->[raw],[i2s]->[codec-amr]->[raw]
¢ AUDIO_STREAM_WRITER, e.g. [raw]->[codec-mp3]->[i2s] Raw Stream configurations
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Public Members

audio_stream_type_t type

Type of stream

int out_rb_size

Size of output ringbuffer
Macros

RAW_STREAM RINGBUFFER_SIZE

RAW_STREAM CFG_DEFAULT ()

2.2.7 SPIFFS

SPIFFS i M. SPIFFS {SzBUF1 5 A S5k .

Rz R4

* player/pipeline_spiffs_mp3

Header File

» components/audio_stream/include/spiffs_stream.h

Functions

audio_element_handle_t spiffs_stream_init (spiffs_stream_cfg t *config)

Create a handle to an Audio Element to stream data from SPIFFS to another Element or get data from other
elements written to SPIFFS, depending on the configuration the stream type, either AUDIO_STREAM_READER
or AUDIO_STREAM_WRITER.

%4 config —The configuration
j&[H] The Audio Element handle

Structures

struct spiffs_stream_cfg t

SPIFFS Stream configuration, if any entry is zero then the configuration will be set to default values.
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Public Members

audio_stream_type_t type

Stream type

intbuf_sz

Audio Element Buffer size

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool write_header

Choose to write amrnb/armwb header in spiffs whether or not (true or false, true means choose to write amrnb
header)

Macros

SPIFFS_STREAM BUF_SIZE

SPIFFS_STREAM_TASK_STACK

SPIFFS_STREAM TASK_CORE

SPIFFS_STREAM TASK_PRIO

SPIFFS_STREAM_RINGBUFFER_SIZE

SPIFFS_STREAM_CFG_DEFAULT ()
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2.2.8 TCP ZFimif

TCP % P33 (TCP client stream) i1 TCP BRI B AR % 28503 .

2 R R fi

* get-started/pipeline_tcp_client

Header File

* components/audio_stream/include/tcp_client_stream.h

Functions

audio_element_handle_t tcp_stream_init (fcp_stream_cfg_t *config)

Initialize a TCP stream to/from an audio element This function creates a TCP stream to/from an audio element de-
pending on the stream type configuration (e.g., AUDIO_STREAM_READER or AUDIO_STREAM_WRITER).
The handle of the audio element is the returned.

%% config —The configuration
Rl The audio element handle

Structures

struct tcp_stream_event_msg

TCP Stream massage configuration.
Public Members

void *source

Element handle

void *data

Data of input/output

int data_len

Data length of input/output

esp_transport_handle_t sock_£d

handle of socket

struct tcp_stream_cfg_ t

TCP Stream configuration, if any entry is zero then the configuration will be set to default values.
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Public Members

audio_stream_type_t type

Type of stream

int timeout_ms

time timeout for read/write

int port
TCP port>

char *host
TCP host>

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool ext_stack

Allocate stack on extern ram

tcp_stream_event_handle_cb event_handler

TCP stream event callback

void *event_ctx

User context

Macros

TCP_STREAM_DEFAULT_PORT

TCP stream parameters.

TCP_STREAM_TASK_STACK

TCP_STREAM_BUF_SIZE

TCP_STREAM_TASK_PRIO

TCP_STREAM TASK_CORE
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TCP_SERVER_DEFAULT_RESPONSE_LENGTH

TCP_STREAM CFG_DEFAULT ()

Type Definitions
typedef struct tcp_stream_event_msg tcp_stream_event_msg_t
TCP Stream massage configuration.

typedef esp_err_t (*tcp_stream_event_handle_cb)(icp_stream_event_msg_t *msg, fcp_stream_status_t state,
void *event_ctx)

Enumerations

enum tcp_stream_status_t

Values:

enumerator TCP_STREAM _STATE_NONE

enumerator TCP_STREAM_STATE_CONNECTED

229 RRER

PEIR TR (tone stream) $52HY tools/audio_tone/mk_audio_tone.py A= il 53R, N % #F AUDIO_STREAM_READER
A
I °

N2 R R fi

* player/pipeline_flash_tone

Header File

e components/audio_stream/include/tone_stream.h

Functions

audio_element_handle_t tone_stream_init (fone_stream_cfg_t *config)

Create an Audio Element handle to stream data from flash to another Element, only support AU-
DIO_STREAM_READER type.

%% config —The configuration
&\l The Audio Element handle
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Structures

struct tone_stream_cfg_t

TONE Stream configurations, if any entry is zero then the configuration will be set to default values.

Public Members

audio_stream_type_t type

Stream type

intbuf_sz

Audio Element Buffer size

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

const char *1abel

Label of tone stored in flash. The default value is f1lash_tone

bool extern_stack

Task stack allocate on the extern ram

bool use_delegate

Read tone partition with esp_delegate. If task stack is on extern ram, this MUST be TRUE

Macros

TONE_STREAM_BUF_SIZE

TONE_STREAM TASK_STACK

TONE_STREAM_TASK_CORE

TONE_STREAM_TASK_PRIO
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TONE_STREAM_RINGBUFFER_SIZE
TONE_STREAM_EXT_STACK

TONE_STREAM USE_DELEGATE

TONE_STREAM_CFG_DEFAULT ()

2.2.10 g\ Flash i#

#x A Flash Jii (flash-embedding stream) 3£ B tools/audio_tone/mk_embed_flash.py A= 5% i) 20 35, H X £
AUDIO_STREAM_READER Z&7l,

Rz R R fi

* player/pipeline_embed_flash_tone

Header File

» components/audio_stream/include/embed_flash_stream.h

Functions

audio_element_handle_t embed_flash_stream_init (embed_flash_stream_cfg_t *config)

Create an Audio Element handle to stream data from flash to another Element, only support AU-
DIO_STREAM_READER type.

%% config —The configuration
&[] The Audio Element handle

esp_err_t embed_flash_stream_set_context (audio_element_handle_t embed_stream, const
embed_item_info_t *context, int max_num)

Set the embed flash context.

This function mainly provides information about embed flash data

S8
* embed_stream —[in] The embed flash element handle
¢ context —[in] The embed flash context
e max_num —[in] The number of embed flash context
B
* ESP_OK
* ESP_FAIL
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Structures

struct embed_flash_stream_cfg t

Flash-embedding stream configurations, if any entry is zero then the configuration will be set to default values.

Public Members

intbuf_sz

Audio Element Buffer size

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool extern_stack

At present, task stack can only be placed on SRAM, so it should always be set to false

struct embed_item_info

Embed tone information in flash.

Public Members

const uint8_t *address

The corresponding address in flash

int size

Size of corresponding data
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Macros

EMBED_FLASH_STREAM BUF_SIZE
EMBED_FLASH_STREAM TASK_STACK
EMBED_FLASH_STREAM TASK_CORE
EMBED_FLASH_STREAM TASK_PRIO
EMBED_FLASH_STREAM RINGBUFFER_SIZE

EMBED_FLASH_STREAM_EXT_STACK

EMBED_FLASH_STREAM_CFG_DEFAULT ()

Type Definitions

typedef struct embed_item_info embed_item_info_t

Embed tone information in flash.

2211 EF AR

BE5 A IR (TTS stream) 3REL esp-sr [if) esp_tts_voice £, A& AUDIO_STREAM_READER ZRZH,

Rz R R4

o A URHI: player/pipeline_tts_stream

Header File

» components/audio_stream/include/tts_stream.h

Functions

audio_element_handle_t tts_stream_init (its_stream_cfg_t *config)

Create a handle to an Audio Element to stream data from TTS to another Element, the stream type only support
AUDIO_STREAM_READER for now.

%% config The configuration
%] The Audio Element handle
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esp_err_t tts_stream_set_strings (audio_element_handle_t el, const char *strings)

Set tts stream strings.
BH
¢ el [in] The audio element handle
* strings —[in] The string pointer
B m
* ESP_OK
» ESP_FAIL

esp_err_ttts_stream_set_speed (audio_element_handle_t el, tts_voice_speed_t speed)

Setting tts stream voice speed.
S
* el [in] The esp_audio instance
* speed —[in] Speed will be set. 0-5 is legal. 0 is the slowest speed.
B
* ESP_OK
* ESP_FAIL

esp_err_t tts_stream_get_speed (audio_element_handle_t el, tts_voice_speed_t *speed)

Get tts stream voice speed.
ZH
* el [in] The esp_audio instance

* speed —[in] Return tts stream Speed will be [0,5]

ESP_OK
* ESP_FAIL

Structures

struct tts_stream_cfg t

TTS Stream configurations, if any entry is zero then the configuration will be set to default values.

Public Members

audio_stream_type_t type
Stream type

intbuf_sz

Audio Element Buffer size
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int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio

Task priority (based on freeRTOS priority)

bool ext_stack

Allocate stack on extern ram

Macros

TTS_STREAM_BUF_SIZE

TTS_STREAM_TASK_STACK

TTS_STREAM_TASK_CORE

TTS_STREAM_TASK_PRIO

TTS_STREAM RINGBUFFER_SIZE

TTS_STREAM_CFG_DEFAULT ()

Enumerations

enum tts_voice_speed_t

Values:

enumerator TTS_VOICE_SPEED_0

enumerator TTS_VOICE_SPEED_1

enumerator TTS_VOICE_SPEED_2

enumerator TTS_VOICE_SPEED_3
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enumerator TTS_VOICE_SPEED_4
enumerator TTS_VOICE_SPEED_5

enumerator TTS_VOICE_SPEED_MAX

2.3 BRI

HHCH 22 AT DA L B9 43 R WP S 5 B S5 2

playlist/include/sdcard_scan.h F1f¥jsdcard _scan () RECAT I microSD & it &85 e, & HAE BUEER
}%;fo SRR SO R EE A P8 SO 2R3, RO R SE B ] DAL T Z R8N 0T, A NSRRI
% :

o G4t & microSD

* 714 £ DRAM

o Bk E flash g NVS 5 X

o G4k £ flash ) DATA_UNDEFINED % [X

FHME SO, i playlist_operator_handle_t AR XM AR BORSCBLBIEE . fRAF. $TED
TR VA SARICE ST R I R B ASSF ThaE . H T, ASCP SRR R Z B B Ry BRI 6E

X APLIEAE R, EHSH T 3.
2.3.1 133 microSD &

sdcard_scan () RECATIIRE E AR IS IOCHE A RO, SCRFEE SCPFAR LRI R I 5L 38
B SRJG, T [T e BRSO AR AT 2 AT I

Rz Bl

e player/pipeline_sdcard_mp3_control

e cli

Header File

» components/playlist/include/sdcard_scan.h
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Functions

esp_err_t sdecard_scan (sdcard_scan_cb_t cb, const char *path, int depth, const char *file_extension[], int
filter_num, void *user_data)

Scan files in SD card and use callback function to save files that meet filtering conditions.

$41:: example sdcard_scan(callback, “/sdcard” , 5, const char *[]{ “mp3” , “aac” }, 2, user_data); Scan 5
levels folder in sdcard and save mp3 files and aac files.

* cb The callback function
» path —The path to be scanned

* depth —The depth of file scanning // .e.g. if you only want to save files in “/test” , depth =
0. // if you want to save files in “/test/scan_test/” , depth =1

* file_extension —File extension of files that are supposed to be saved // .e.g. const char
*[]{ Lme377 s Céaacﬂ }

e filter_num —Number of filters

* user_data —The data to be used by callback function
Bl

e ESP_OK success

» ESP_FAIL failed

Type Definitions

typedef void (*sdcard_scan_cb_t)(void *user_data, char *url)

2.3.2 HFREBEHIIR
ZEZE microSD &

&R 2 0] 774 & microSD <71, It playlist_operator_handle_t A4 I AH B o8 %5k SC B A%
i RRREIRETIRE.

Rz Bl

* player/pipeline_sdcard_mp3_control

e cli
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Header File

» components/playlist/include/sdcard_list.h

Functions

esp_err_t sdecard_list_create (playlist_operator_handle_t *handle)

Create a playlist in sdcard by list id.
%% handle —[out] The playlist handle from application layer
Bl
e ESP_OK success
» ESP_FAIL failed

esp_err_t sdecard_list_show (playlist_operator_handle_t handle)
Show all the URLs in sdcard playlist.

%% handle -Playlist handle
Bl

e ESP_OK success

» ESP_FAIL failed

esp_err_t sdecard_list_next (playlist_operator_handle_t handle, int step, char **url_buff)
The following URLs in sdcard playlist.

S8

* handle —Playlist handle

* step —The offset of URL from current URL

* url_buff —[out] A second rank pointer to get a address of URL
B

e ESP_OK success

» ESP_FAIL failed

esp_err_t sdecard_list_prev (playlist_operator_handle_t handle, int step, char **url_buff)
The previous URLs in sdcard playlist.

S8

* handle Playlist handle

* step —The offset of URL from current URL

* url_buff —[out] A second rank pointer to get a address of URL
Bl

ESP_OK success
e ESP_FAIL failed
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bool sdcard_list_exist (playlist_operator_handle_t handle, const char *url)
Judge whether the url exists in sdcard playlist.

S

* handle —Playlist handle

* url —The url to be checked
Bl

* true existence

* false Non-existent

esp_err_t sdcard_list_reset (playlist_operator_handle_t handle)
Reset sdcard playlist.

%% handle —Playlist handle
B

* ESP_OK success

» ESP_FAIL failed

esp_err_t sdecard_list_current (playlist_operator_handle_t handle, char **url_buff)

Get current URL in sdcard playlist.

SH
* handle —Playlist handle

* url_buff —[out] A second rank pointer to get a address of URL

e ESP_OK success
 ESP_FAIL failed

esp_err_t sdecard_list_choose (playlist_operator_handle_t handle, int url_id, char **url_buff)

Choose a url by url id.
BH

handle —Playlist handle

url_id —The id of url in sdcard list

url_buff [out] A second rank pointer to get a address of URL
R

ESP_OK success
ESP_FAIL failed

int sdcard_list_get_url_num (playlist_operator_handle_t handle)
Get URLSs number in sdcard playlist.

%%t handle —Playlist handle
Bl
e URLs number in sdcard playlist
* ESP_FAIL Fail to get number of urls
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int sdcard_list_get_url_id (playlist_operator_handle_t handle)
Get current url id in the sdcard playlist.

%%, handle —Playlist handle

B
* Current url id in partition playlist
* ESP_FAIL Fail to get url id

esp_err_t sdecard_list_destroy (playlist_operator_handle_t handle)
Destroy sdcard playlist.

%% handle —Playlist handle
A

e ESP_OK success

» ESP_FAIL failed

esp_err_t sdecard_list_save (playlist_operator_handle_t handle, const char *url)
Save URL to sdcard playlist.

S8
* handle Playlist handle
* url -URL to be saved
&Ml
* ESP_OK success
» ESP_FAIL failed

== DRAM

WS R 174% 2 DRAM o, Il playlist_operator_handle_t AR AT R eR HOR SEBLRTT
BIRFEIIN R RE

Header File

» components/playlist/include/dram_list.h

Functions

esp_err_tdram_list_create (playlist_operator_handle_t *handle)
Create a playlist in dram.

%4 handle —[out] The playlist handle from application layer
B

¢ ESP_OK success

» ESP_FAIL failed
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esp_err_tdram_list_save (playlist_operator_handle_t handle, const char *url)
Save URL to dram playlist.

S8
* handle —Playlist handle
* url -URL to be saved
Bl
¢ ESP_OK success
» ESP_FAIL failed

esp_err_tdram_list_next (playlist_operator_handle_t handle, int step, char **url_buff)

The following URLs in dram playlist.
SH
* handle —Playlist handle
* step —The offset of URL from current URL
* url_buff [out] A second rank pointer to get a address of URL
Rl
e ESP_OK success
» ESP_FAIL failed

esp_err_tdram_list_prev (playlist_operator_handle_t handle, int step, char **url_buff)
The previous URLs in dram playlist.

SH

* handle —Playlist handle

* step —The offset of URL from current URL

* url_buff [out] A second rank pointer to get a address of URL
B

e ESP_OK success

» ESP_FAIL failed

bool dram_1list_exist (playlist_operator_handle_t handle, const char *url)

Judge whether the url exists in dram playlist.
S
* handle —Playlist handle
e url —The url to be checked
Bl
* true existence
* false Non-existent

esp_err_tdram_list_reset (playlist_operator_handle_t handle)
Reset dram playlist.

%% handle —Playlist handle
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R
e ESP_OK success
o ESP_FAIL failed

esp_err_tdram_list_current (playlist_operator_handle_t handle, char **url_buff)

The current URL in current playlist.
S8
* handle —Playlist handle
* url_buff [out] A second rank pointer to get a address of URL
Bl
¢ ESP_OK success
» ESP_FAIL failed

esp_err_tdram_list_choose (playlist_operator_handle_t handle, int url_id, char **url_buff)

Choose a url by url id.
S8
* handle —Playlist handle
e url_id -The id of url in dram list
* url_buff [out] A second rank pointer to get a address of URL
Bl
¢ ESP_OK success
» ESP_FAIL failed

intdram_list_get_url_num (playlist_operator_handle_t handle)
Get URLs number in the dram playlist.

%% handle —Playlist handle
Bl
¢ URLs number in dram playlist
* ESP_FAIL Fail to get number of urls

intdram_list_get_url_id (playlist_operator_handle_t handle)
Get current url id in the dram playlist.

%% handle —Playlist handle

R m
 Current url id in dram playlist
» ESP_FAIL Fail to get url id

esp_err_tdram_list_show (playlist_operator_handle_t handle)
Show all the URLs in the dram playlist.

%% handle —Playlist handle
B
* ESP_OK success
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» ESP_FAIL failed

esp_err_tdram_list_remove_by_url (playlist_operator_handle_t handle, const char *url)
Remove corrsponding url in dram list.

S8

* handle Playlist handle

* url —The url to be removed
Bl

* ESP_OK success

» ESP_FAIL failed

esp_err_tdram_list_remove_by_url_id (playlist_operator_handle_t handle, uint16_t url_id)

Remove url by id.
S8
* handle —Playlist handle
e url_id —The url id to be removed
Rl
e ESP_OK success
* ESP_FAIL failed

esp_err_tdram_list_destroy (playlist_operator_handle_t handle)
Destroy the dram playlist.

%% handle —Playlist handle
B

e ESP_OK success

* ESP_FAIL failed

7Ei2=E flash i NVS 94X

S F T 74 2 flash 19 NVS 731X, Jfllid playlist_operator_handle_t AAiR fAH e AR 5K
BRAT . BRI R

Header File

» components/playlist/include/flash_list.h
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Functions

esp_err_t flash_list_create (playlist_operator_handle_t *handle)

Create a playlist in nvs flash.
%4 handle —[out] Playlist handle
Bl
e ESP_OK success
» ESP_FAIL failed

esp_err_t £lash_list_save (playlist_operator_handle_t handle, const char *url)
Save URL to nvs flash list.

S8
* handle —Playlist handle
* url -URL to be saved
B
¢ ESP_OK success
» ESP_FAIL failed

esp_err_t £lash_list_show (playlist_operator_handle_t handle)
Show all the URLs in nvs flash list.

%% handle —Playlist handle
Bl

e ESP_OK success

» ESP_FAIL failed

esp_err_t £lash_list_next (playlist_operator_handle_t handle, int step, char **url_buff)
The following URLSs in nvs flash playlist.

* handle Playlist handle

e step —The offset of URL from current URL

* url_buff [out] A second rank pointer to get a address of URL
Bl

e ESP_OK success

» ESP_FAIL failed

esp_err_t £lash_list_prev (playlist_operator_handle_t handle, int step, char **url_buff)
The previous URLs in nvs flash playlist.

S8

* handle Playlist handle

* step —The offset of URL from current URL

* url_buff [out] A second rank pointer to get a address of URL
B
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¢ ESP_OK success
¢ ESP_FAIL failed

esp_err_t £lash_list_current (playlist_operator_handle_t handle, char **url_buff)
The current URL in nvs flash playlist.

S8

* handle —Playlist handle

* url_buff —[out] A second rank pointer to get a address of URL
A

e ESP_OK success

» ESP_FAIL failed

bool £lash_1list_exist (playlist_operator_handle_t handle, const char *url)
Judge whether the url exists in flash playlist.

S8

* handle Playlist handle

e url —The url to be checked
Bl

* true existence

* false Non-existent

esp_err_t flash_list_reset (playlist_operator_handle_t handle)
Reset flash playlist.

%% handle —Playlist handle
B

* ESP_OK success

» ESP_FAIL failed

esp_err_t £lash_list_choose (playlist_operator_handle_t handle, int url_id, char **url_buff)

Choose a url by url id.
BH
* handle —Playlist handle
e url_id —The id of url in flash list
* url_buff [out] A second rank pointer to get a address of URL
B
¢ ESP_OK success
» ESP_FAIL failed

int £lash_list_get_url_num (playlist_operator_handle_t handle)
Get URLSs number in the flash playlist.

%% handle —Playlist handle
B
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» URLSs number in flash playlist
» ESP_FAIL Fail to get number of urls

int flash_list_get_url_id (playlist_operator_handle_t handle)
Get current url id in the flash playlist.

%% handle —Playlist handle

B m
 Curernt url id in flash playlist
* ESP_FAIL Fail to get url id

esp_err_t £lash_1list_destroy (playlist_operator_handle_t handle)
Destroy the nvs flash playlist.

%%t handle —Playlist handle
B

* ESP_OK success

* ESP_FAIL failed

72 = flash §Y DATA_UNDEFINED 4K
& B %) 32 W] £E f% % flash () DATA_UNDEFINED 4 X ot (3£ 5 & % 4 X %) 33 b

playlist_operator_handle_t )i I AH I o6 Bk SC AR AF . /R B0 R SF T BE. %%5‘6%‘
ZRAUN 0x06 Al 0x07 (1 2 A7 RSN E] flash (73 K

A

Header File

» components/playlist/include/partition_list.h

Functions

esp_err_t partition_list_create (playlist_operator_handle_t *handle)
Create a playlist in flash partition by list id.

$&1¥: Please add 2 partitions to partition table whose subtype are 0x06 and 0x07 first

%% handle —[out] The playlist handle from application layer
B

e ESP_OK success

» ESP_FAIL failed

esp_err_t partition_list_save (playlist_operator_handle_t handle, const char *url)
Save URL to partition playlist.

ZH
* handle —Playlist handle
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* url -URL to be saved
B

¢ ESP_OK success

» ESP_FAIL failed

esp_err_t partition_list_next (playlist_operator_handle_t handle, int step, char **url_buff)
The following URLs in partition playlist.

S8

* handle —Playlist handle

* step —The offset of URL from current URL

* url_buff [out] A second rank pointer to get a address of URL
B

¢ ESP_OK success

» ESP_FAIL failed

esp_err_t partition_list_prev (playlist_operator_handle_t handle, int step, char **url_buff)
The previous URLs in partition playlist.

S8

* handle —Playlist handle

* step —The offset of URL from current URL

* url_buff [out] A second rank pointer to get a address of URL
B

¢ ESP_OK success

» ESP_FAIL failed

bool partition_list_exist (playlist_operator_handle_t handle, const char *url)

Judge whether the url exists in partition playlist.
S8
* handle —Playlist handle
* url —The url to be checked
Bl
* true existence
* false Non-existent

esp_err_tpartition_list_reset (playlist_operator_handle_t handle)

Reset partition playlist.
%% handle —Playlist handle
R m
» ESP_OK success
» ESP_FAIL failed
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esp_err_tpartition_1list_current (playlist_operator_handle_t handle, char **url_buff)
Get current URL in the partition playlist.

BH

* handle —Playlist handle

* url_buff [out] A second rank pointer to get a address of URL
B m

e ESP_OK success

» ESP_FAIL failed

esp_err_t partition_1list_choose (playlist_operator_handle_t handle, int url_id, char **url_buft)

Choose a url by url id.
SH
* handle —Playlist handle
* url_id The id of url in partition list
* url_buff [out] A second rank pointer to get a address of URL
B
e ESP_OK success
» ESP_FAIL failed

int partition_list_get_url_num (playlist_operator_handle_t handle)
Get URLs number in the partition playlist.

%% handle —Playlist handle
Bl
e URLs number in partition playlist
* ESP_FAIL Fail to get number of urls

int partition_1list_get_url_id (playlist_operator_handle_t handle)

Get curernt url id in the partition playlist.
%%, handle —Playlist handle
R M
 Current url id in partition playlist
» ESP_FAIL Fail to get url id

esp_err_t partition_1list_show (playlist_operator_handle_t handle)
Show all the URLSs in the partition playlist.

%% handle —Playlist handle
B

* ESP_OK success

» ESP_FAIL failed
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esp_err_t partition_1list_destroy (playlist_operator_handle_t handle)
Destroy the partition playlist.

%%, handle —Playlist handle
B

* ESP_OK success

» ESP_FAIL failed

2.3.3 1T ESTEeE
RO AT I TAT I AR, A BRSNS playlist_handle_t A,

Header File

e components/playlist/include/playlist.h

Functions

playlist_handle_t playlist_create (void)
Create a playlist manager handle.
Bl
* playlist handle success
* NULL failed

esp_err_t playlist_add (playlist_handle_t handle, playlist_operator_handle_t list_handle, uint8_t list_id)
Create a playlist manager and add playlist handle to it.

#41:: The partition playlist can only be added once, or it will be overwrited by the newest partiiton playlist

$41¥: Different lists must use different IDs, because even if they are in different handles, list_id is the only
indicator that distinguishes them.

ZH
* handle —Playlist manager handle
* list_handle —The playlist handle to be added
* list_id —The playlist id to be registered

B

ESP_OK success
e ESP_FAIL failed
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esp_err_t playlist_checkout_by_id (playlist_handle_t handle, uint8_t id)
Playlist checkout by list id.

S8
* handle —Playlist handle
* id —Specified list id
Bl
¢ ESP_OK success
» ESP_FAIL failed

int playlist_get_1list_num (playlist_handle_t handle)
Get number of playlists in the handle.

%%t handle —Playlist handle
Bl
* success Number of playlists in handle
e failed -1
playlist_type_t playlist_get_current_list_type (playlist_handle_t handle)
Get current playlist type.
%%, handle —Playlist handle
&Ml
* success Type of current playlist
* failed -1
int playlist_get_current_list_id (playlist_handle_t handle)
Get current playlist id.
%%, handle —Playlist handle
A
* success Current playlist id
* failed -1
esp_err_t playlist_get_current_list_url (playlist_handle_t handle, char **url_buff)
Get current URL in current playlist.

BH

* handle —Playlist handle

* url_buff [out] A second rank pointer to get a address of URL
B M

e ESP_OK success

» ESP_FAIL failed

int playlist_get_current_list_url_num (playlist_handle_t handle)
Get number of URLSs in current playlist.

%% handle —Playlist handle
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1& 1] Number of URLS in current playlsit

int playlist_get_current_list_url_id (playlist_handle_t handle)

Get current url id in current playlist.
%% handle —Playlist handle
iR\ Current url’ s id in current playlsit

esp_err_t playlist_save (playlist_handle_t handle, const char *url)

Save a URL to the current playlist.
S8
* handle —Playlist handle
* url ~The URL to be saved ot sdcard
Bl
¢ ESP_OK success
» ESP_FAIL failed

esp_err_t playlist_next (playlist_handle_t handle, int step, char **url_buff)
Next URI in current playlist.

S8

* handle —Playlist handle

* step —Next steps from current position

* url_buff [out] A second rank pointer to get a address of URL
Bl

¢ ESP_OK success

» ESP_FAIL failed

esp_err_t playlist_prev (playlist_handle_t handle, int step, char **url_buff)
Previous URL in current playlist.

S8

* handle —Playlist handle

* step —Previous steps from current position

* url_buff [out] A second rank pointer to get a address of URL
Bl

» ESP_OK success

» ESP_FAIL failed

esp_err_t playlist_choose (playlist_handle_t handle, int url_id, char **url_buff)
Choose a url by url id.

B8
* handle —Playlist handle
e url_id -The id of url in current list

* url_buff —[out] A second rank pointer to get a address of URL
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R
e ESP_OK success
o ESP_FAIL failed

esp_err_t playlist_show (playlist_handle_t handle)
Show URLS: in current playlist.

%% handle —Playlist handle
B

* ESP_OK success

e ESP_FAIL failed

esp_err_t playlist_reset (playlist_handle_t handle)

Reset current playlist.
%% handle —Playlist handle
&l
¢ ESP_OK success
» ESP_FAIL failed

esp_err_t playlist_remove_by_url (playlist_handle_t handle, const char *url)

Remove corresponding url.
S8
* handle —Playlist handle
* url —The url to be removed
Bl
e ESP_OK success
» ESP_FAIL failed

esp_err_t playlist_remove_by_ url_id (playlist_handle_t handle, uint16_t url_id)

Remove url by url id.
S8
* handle —Playlist handle
* url_id —The id of url to be removed
Bl
¢ ESP_OK success
» ESP_FAIL failed

bool playlist_exist (playlist_handle_t handle, const char *url)
Judge whether the url exists in current playlist.

B8

* handle —Playlist handle

* url —The url to be checked
Bl
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* true existence
¢ false Non-existent

esp_err_t playlist_destroy (playlist_handle_t handle)
Destroy all playlists in the handle.

%% handle —Playlist handle
B

e ESP_OK success

» ESP_FAIL failed

Structures

struct playlist_operation_t

All types of Playlists’ operation.

Public Members

esp_err_t (*show)(void *playlist)
Show all the URLS in playlist

esp_err_t (*save)(void *playlist, const char *url)
Save URLs to playlist

esp_err_t (*next)(void *playlist, int step, char **url_buff)

Get next URL in playlist

esp_err_t (*prev)(void *playlist, int step, char **url_buff)

Get previous URL in playlist

esp_err_t (*reset)(void *playlist)

Reset the playlist

esp_err_t (*choose)(void *playlist, int url_id, char **url_buff)
Get url by url id

esp_err_t (*eurrent)(void *playlist, char **url_buff)

Get current URL in playlist

esp_err_t (*destroy)(void *playlist)
Destroy playlist

bool (*exist)(void *playlist, const char *url)

Judge whether the url exists
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int (*get_url_num)(void *playlist)
Get number of URLS in current playlist

int (*get_url_id)(void *playlist)

Get current url id in playlist

playlist_type_t type
Type of playlist

esp_err_t (*remove_by_url)(void *playlist, const char *url)

Remove the corresponding url

esp_err_t (*remove_by_id)(void *playlist, uint16_t url_id)

Remove url by id

struct playlist_operator_t

Information of playlist manager node.

Public Members

void *playlist
Specific playlist’ s pointer

esp_err_t (*get_operation)(playlist_operation_t *operation)

Function pointer to get playlists’ handle

Type Definitions

typedef playlist_operator_t *playlist_operator_handle_t

typedef struct playlist_handle *playlist_handle_t

Enumerations

enum playlist_type_t
Type of playlist.

Values:

enumerator PLAYLIST_UNKNOWN
Unknown type
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enumerator PLAYLIST_SDCARD
Playlist in sdcard

enumerator PLAYLIST_FLASH

Playlist in nvs

enumerator PLAYLIST_DRAM

Playlist in ram

enumerator PLAYLIST_PARTITION

Playlist in partition

2.4 Codecs

2.4.1 AAC Decoder

Decode an audio data stream provided in AAC format.
API Reference
Header File

» components/esp-adf-libs/esp_codec/include/codec/aac_decoder.h

Functions

audio_element_handle_t aac_decoder_init (aac_decoder_cfg_t *config)

Create an Audio Element handle to decode incoming AAC data.
%% config —The configuration
j&IA] The audio element handle

Structures

struct aac_decoder_cfg_t

AAC Decoder configuration.

120

Chapter 2. API Reference


https://github.com/ssh://git@gitlab.espressif.cn:27227/adf/esp-adf-libs/blob/f1b8cdb/esp_codec/include/codec/aac_decoder.h

ADF &4 R ZIESRF M, X7 latest

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

bool plus_enable
Dynamically enable HE-AAC (v1 v2) decoding

Macros

AAC_DECODER_TASK_STACK_SIZE

AAC_DECODER_TASK_CORE

AAC_DECODER_TASK_PRIO

AAC_DECODER_RINGBUFFER_SIZE

DEFAULT_ AAC_DECODER_CONFIG ()

2.4.2 AMR Decoder and Encoder

Decode and encode an audio data stream from / to AMR format. Encoders cover both AMR-NB and AMR-WB formats.

Application Examples

Implementation of this API is demonstrated in the following examples:
e player/pipeline_play_sdcard_music

* recorder/pipeline_wav_amr_sdcard
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API Reference - Decoder

Header File

» components/esp-adf-libs/esp_codec/include/codec/amr_decoder.h

Functions

audio_element_handle_t amr_decoder_init (amr_decoder_cfg_t *config)
Create an Audio Element handle to decode incoming AMR data.

%% config —The configuration
j&[\ The audio element handle

Structures

struct amr_decoder_cfg_t

AMR Decoder configuration.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

Macros

AMR_DECODER_TASK_STACK_SIZE

AMR_DECODER_TASK_CORE

AMR_DECODER_TASK_PRIO
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AMR_DECODER_RINGBUFFER_SIZE

DEFAULT_ AMR_DECODER_CONFIG ()

API Reference - AMR-NB Encoder

Header File

¢ components/esp-adf-libs/esp_codec/include/codec/amrnb_encoder.h

Functions

esp_err_t amrnb_encoder_set_bitrate (audio_element_handle_t self, amrnb_encoder_bitrate_t
bitrate_mode)

Set AMRNB encoder bitrate.
S8
* self —Audio element handle
* bitrate_mode —Bitrate choose, value from amrnb_encoder_bitrate_t
B
ESP_OK ESP_FAIL

audio_element_handle_t amrnb_encoder_init (amrnb_encoder_cfg_t *config)

Create an Audio Element handle to encode incoming AMRNB data.
%% config —The configuration
i& [\ The audio element handle

Structures

struct amrnb_encoder_cfg_t
AMRNB Encoder configurations.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)
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int task_prio
Task priority (based on freeRTOS priority)

amrnb_encoder_bitrate_t bitrate_mode

AMRNB Encoder bitrate choose

bool contain_amrnb_header

Choose to contain amrnb header in amrnb encoder whether or not (true or false, true means choose to contain
amrnb header)

bool stack_in_ext

Try to allocate stack in external memory

Macros

AMRNB_ENCODER_TASK_STACK

AMRNB_ENCODER_TASK_CORE

AMRNB_ENCODER_TASK_PRIO

AMRNB_ENCODER_RINGBUFFER_SIZE

DEFAULT_ AMRNB_ENCODER_CONFIG ()

Enumerations

enum amrnb_encoder_bitrate_t
Enum of AMRNB Encoder bitrate choose.

Values:

enumerator AMRNB_ENC_BITRATE_UNKNOW

Invalid mode

enumerator AMRNB_ENC_BITRATE_MR475

enumerator AMRNB_ENC_BITRATE_MRS515

enumerator AMRNB_ENC_BITRATE_MR59

enumerator AMRNB_ENC_BITRATE_MR67
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enumerator AMRNB_ENC_BITRATE_MR74

enumerator AMRNB_ENC_BITRATE_MR795

enumerator AMRNB_ENC_BITRATE_MR102

enumerator AMRNB_ENC_BITRATE_MR122

enumerator AMRNB_ENC_BITRATE_MRDTX

enumerator AMRNB_ENC_BITRATE_N_MODES

API Reference - AMR-WB Encoder

Header File

» components/esp-adf-libs/esp_codec/include/codec/amrwb_encoder.h

Functions

esp_err_t amrwb_encoder_set_bitrate (audio_element_handle_t self, amrwb_encoder_bitrate_t
bitrate_mode)

Set AMRWB encoder bitrate.
S8
e self —Audio element handle
* bitrate_mode —Bitrate choose, value from amrwb_encoder_bitrate_t
B
ESP_OK ESP_FAIL

audio_element_handle_t amrwb_encoder_init (amrwb_encoder_cfg_t *config)

Create an Audio Element handle to encode incoming amrwb data.
%% config —The configuration
iz Al The audio element handle

Structures

struct amrwb_encoder_cfg_t
AMRWB Encoder configurations.
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Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

amrwb_encoder_bitrate_t bitrate_mode
AMRWRB Encoder bitrate choose

bool contain_amrwb_header

Choose to contain amrwb header in amrwb encoder whether or not (true or false, true means choose to contain
amrwb header)

bool stack_in_ext

Try to allocate stack in external memory

Macros

AMRWB_ENCODER_TASK_STACK

AMRWB_ENCODER_TASK_CORE

AMRWB_ENCODER_TASK_PRIO

AMRWB_ENCODER_RINGBUFFER_SIZE

DEFAULT_ AMRWB_ENCODER_CONFIG ()

Enumerations

enum amrwb_encoder_bitrate_t
Enum of AMRWRB Encoder bitrate choose.

Values:
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enumerator AMRWB_ENC_BITRATE_MDNONE

Invalid mode

enumerator AMRWB_ENC_BITRATE_MD66
6.60kbps

enumerator AMRWB_ENC_BITRATE_MD885
8.85kbps

enumerator AMRWB_ENC_BITRATE_MD1265
12.65kbps

enumerator AMRWB_ENC_BITRATE_MD1425
14.25kbps

enumerator AMRWB_ENC_BITRATE_MD1585
15.85bps

enumerator AMRWB_ENC_BITRATE_MD1825
18.25bps

enumerator AMRWB_ENC_BITRATE_MD1985
19.85kbps

enumerator AMRWB_ENC_BITRATE_MD2305
23.05kbps

enumerator AMRWB_ENC_BITRATE_MD2385
23.85kbps>

enumerator AMRWB_ENC_BITRATE_N_MODES

Invalid mode

2.4.3 FLAC Decoder

Decode an audio data stream provided in FLAC format.
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API Reference

Header File

» components/esp-adf-libs/esp_codec/include/codec/flac_decoder.h

Functions

audio_element_handle_t £lac_decoder_init (flac_decoder cfg_t *config)
Create an Audio Element handle to decode incoming FLAC data.

%% config —The configuration
j&[\ The audio element handle

Structures

struct flac_decoder_cfg_t

FLAC Decoder configuration.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

Macros

FLAC_DECODER_TASK_STACK_SIZE

FLAC_DECODER_TASK_CORE

FLAC_DECODER_TASK_PRIO

128

Chapter 2. API Reference


https://github.com/ssh://git@gitlab.espressif.cn:27227/adf/esp-adf-libs/blob/f1b8cdb/esp_codec/include/codec/flac_decoder.h

ADF E45R AF ZEZRF M, A7 latest

FLAC_DECODER_RINGBUFFER_SIZE

DEFAULT_FLAC_DECODER_CONFIG ()

2.4.4 MP3 Decoder

Decode an audio data stream provided in MP3 format.

Application Examples

Implementation of this API is demonstrated in the following examples:
* get-started/play_mp3_control
* player/pipeline_play_sdcard_music

* player/pipeline_play_mp3_with_dac_or_pwm

API Reference

Header File

» components/esp-adf-libs/esp_codec/include/codec/mp3_decoder.h

Functions

audio_element_handle_t mp3_decoder_init (mp3_decoder_cfg_t *config)
Create an Audio Element handle to decode incoming MP3 data.

%% config —The configuration
j&[\] The audio element handle

const esp_id3_info_t *mp3_decoder_get_id3_info (audio_element_handle_t self)

Get ID3 information.
%% self —The audio element handle

R A] esp_id3_info_t: success NULL: ID3 is not exist or memory aloocation failed.

Structures

struct mp3_decoder_cfg_t
Mp3 Decoder configuration.
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Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

bool id3_parse_enable
True: parse ID3. False: Don’ t parse ID3

Macros

MP3_DECODER_TASK_STACK_SIZE

MP3_DECODER_TASK_CORE

MP3_DECODER_TASK_PRIO

MP3_DECODER_RINGBUFFER_SIZE

DEFAULT_MP3_DECODER_CONFIG ()

2.4.5 OGG Decoder

Decode an audio data stream provided in OGG format.

API Reference

Header File

» components/esp-adf-libs/esp_codec/include/codec/ogg_decoder.h
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Functions

audio_element_handle_t ogg_decoder_init (ogg_decoder_cfg_t *config)

Create an Audio Element handle to decode incoming OGG data.
%% config —The configuration
j&A] The audio element handle

Structures

struct ogg_decoder_cfg_t
OGG Decoder configuration.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

Macros

OGG_DECODER_TASK_STACK_SIZE

OGG_DECODER_TASK_CORE

OGG_DECODER_TASK_PRIO

OGG_DECODER_RINGBUFFER_SIZE

DEFAULT_OGG_DECODER_CONFIG ()
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2.4.6 OPUS Decoder

Decode an audio data stream provided in OPUS format.

API Reference

Header File

» components/esp-adf-libs/esp_codec/include/codec/opus_decoder.h

Functions

audio_element_handle_t decoder_opus_init (opus_decoder_cfg_t *config)

Create an Audio Element handle to decode incoming OPUS data.
%% config —The configuration
j&[A] The audio element handle

Structures

struct opus_decoder_cfg_t

OPUS Decoder configuration.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

CPU core number (0 or 1) where decoder task in running

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory
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Macros

OPUS_DECODER_TASK_STACK_SIZE

OPUS_DECODER_TASK_CORE

OPUS_DECODER_TASK_PRIO

OPUS_DECODER_RINGBUFFER_SIZE

DEFAULT_OPUS_DECODER_CONFIG ()

2.4.7 WAV Decoder and Encoder

Decode and encode an audio data stream from / to WAV format.

Application Examples

Implementation of this API is demonstrated in the following examples:
* player/pipeline_play_sdcard_music

* recorder/pipeline_wav_amr_sdcard
API Reference - Decoder
Header File

» components/esp-adf-libs/esp_codec/include/codec/wav_decoder.h

Functions

audio_element_handle_t wav_decoder_init (wav_decoder_cfg_t *config)

Create an Audio Element handle to decode incoming WAV data.
%4 config —The configuration
&8 The audio element handle

Structures

struct wav_decoder_cfg_t

brief WAV Decoder configurations

2.4. Codecs

133


https://github.com/espressif/esp-adf/tree/1bc914b/examples/player/pipeline_play_sdcard_music
https://github.com/espressif/esp-adf/tree/1bc914b/examples/recorder/pipeline_wav_amr_sdcard
https://github.com/ssh://git@gitlab.espressif.cn:27227/adf/esp-adf-libs/blob/f1b8cdb/esp_codec/include/codec/wav_decoder.h

ADF E40 i FAFF R HEZ2F 11, & 1 latest

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

Macros

WAV_DECODER_TASK_STACK

WAV_DECODER_TASK_CORE

WAV_DECODER_TASK_PRIO

WAV_DECODER_RINGBUFFER_SIZE

DEFAULT_ WAV_DECODER_CONFIG ()

API Reference - Encoder

Header File

» components/esp-adf-libs/esp_codec/include/codec/wav_encoder.h

Functions

audio_element_handle_t wav_encoder_init (wav_encoder_cfg_t *config)

Create a handle to an Audio Element to encode incoming data using WAV format.

%% config —The configuration
&Il The audio element handle
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Structures

struct wav_encoder_cfg_t

WAV Encoder configurations.

Public Members

int out_rb_size

Size of output ringbuffer

int task_stack

Task stack size

int task_core

Task running in core (0 or 1)

int task_prio
Task priority (based on freeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory

Macros

WAV_ENCODER_TASK_STACK
WAV_ENCODER_TASK_CORE
WAV_ENCODER_TASK_PRIO

WAV_ENCODER_RINGBUFFER_SIZE

DEFAULT_ WAV_ENCODER_CONFIG ()

2.5 Audio Processing

There are couple of options implemented in the ESP-ADF to modify contents of an audio stream:

* Combine contents of two audio streams using Downmix

* Apply ten band Equalizer

¢ Change audio sampling frequency and convert between single and two channel with Resample Filter

* Modify pitch and speed of the stream using Sonic

Please refer to description of respective APIs below.
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2.5.1 Downmix

This API is intended for mixing of two audio files (streams), defined as the base audio file and the newcome audio file,

into one output audio file.

The newcome audio file will be downmixed into the base audio file with individual gains applied to each file.

Easa Fil
Read MP3 125
Base decoder stream
MP3file
Hewoame File

Read
Mewcome
MP3file

MP3 125
decoder stream

Do iz

F

3

| 4: Tllustration of Downmixing Process

Codec
chip

The number of channel(s) of the output audio file will be the same with that of the base audio file. The number of
channel(s) of the newcome audio file will also be changed to the same with the base audio file, if it is different from that

of the base audio file.

The downmix process has 3 states:

¢ Bypass Downmixing —Only the base audio file will be processed;

¢ Switch on Downmixing —The base audio file and the target audio file will first enter the transition period, during
which the gains of these two files will be changed from the original level to the target level; then enter the stable

period, sharing a same target gain;

» Switch off Downmixing —The base audio file and the target audio file will first enter the transition period, during
which the gains of these two files will be changed back to their original levels; then enter the stable period, with
their original gains, respectively. After that, the downmix process enters the bypass state.

Note that, the sample rates of the base audio file and the newcome audio file must be the same, otherwise an error occurs.

Application Example

Implementation of this API is demonstrated in advanced_examples/downmix_pipeline example.

API Reference

Header File

» components/esp-adf-libs/esp_codec/include/codec/downmix.h
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Functions

void downmix_set_input_rb_timeout (audio_element _handle_t self, int ticks_to_wait, int index)
Sets the downmix timeout.
SH
* self —Audio element handle
* ticks_to_wait —Input ringbuffer timeout
* index —The index of multi input ringbuffer

void downmix_set_input_rb (audio_element _handle_t self, ringbuf _handle_t rb, int index )

Sets the downmix input ringbuffer. refer to ringbuf.h
BH
* self —Audio element handle
* rb —Handle of ringbuffer
* index —The index of multi input ringbuffer.

esp_err_t downmix_set_output_type (audio_element_handle_t self, esp_downmix_output_type_t
output_type)

Set channel mode of output data. Only supported mono and dual.
BH
* self —Audio element handle
* output_type -Down-mixer output type.
R
¢ ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t downmix_set_work_mode (audio_element_handle_t self, esp_downmix_work_mode_t mode)

Sets BYPASS, ON or OFF status of down-mixer.
S
* self —Audio element handle
* mode —Down-mixer work mode.
Bl
e ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t downmix_set_out_ctx_info (audio_element_handle_t self, esp_downmix_out_ctx_type_t out_ctx)

Passes content of per channel output stream by down-mixer.
S8
e self —Audio element handle
* out_ctx —Content of output stream.
B
e ESP_OK on success
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* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t downmix_set_source_stream_info (audio_element_handle_t self, int rate, int ch, int index)

Sets the sample rate and the number of channels of input stream to be processed.
BH
* self —Audio element handle
* rate —Sample rate of the input stream
¢ ch —Channel number of the input stream. Only supported mono and dual.

* index —The index of input stream. The index must be in [0, SOURCE_NUM_MAX - 1]
range.

P[]
¢ ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t downmix_set_gain_info (audio_element_handle_t self, float *gain, int index)

Sets the audio gain to be processed.
SH
* self —Audio element handle

* gain —The gain array of downmix which the array size is 2 and the gain data range is [-100,
100], unit: dB.

* index —The index of input stream. The index must be in [0, SOURCE_NUM_MAX - 1]
range.

py |
¢ ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t downmix_set_transit_time_info (audio_element_handle_t self, int transit_time, int index)

Sets the audio transit_time to be processed.
S8
* self —Audio element handle
e transit_time —The reset value of transit_time

* index —The index of input stream. The index must be in [0, SOURCE_NUM_MAX - 1]
range

peq |
e ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t source_info_init (audio_element_handle_t self, esp_downmix_input_info_t *source_info)

Initializes information of the source streams for downmixing.
* self —Audio element handle

* source_info —The information array of source streams
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R
¢ ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

audio_element_handle_t downmix_init (downmix_cfg_t *config)

Initializes the Audio Element handle for downmixing.
%% config —the configuration
j&IA] The audio element handler

Structures

struct downmix_cfg_t

Downmix configuration.

Public Members

esp_downmix_info_t downmix_info

Downmix information

int max_sample

The number of samples per downmix processing

int out_rb_size

Size of ring buffer

int task_stack

Size of task stack

int task_core

Task running in core -

int task_prio
Task priority (based on the FreeRTOS priority)

bool stack_in_ext

Try to allocate stack in external memory
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Macros

DOWNMIX_TASK_STACK
DOWNMIX_TASK_CORE
DOWNMIX_TASK_PRIO
DOWNMIX_RINGBUFFER_SIZE
DM_BUF_SIZE

DEFAULT_ DOWNMIX_ CONFIG ()

2.5.2 Equalizer

Provided in this API equalizer supports:
¢ fixed number of ten (10) bands;
* four sample rates: 11025 Hz, 22050 Hz, 44100 Hz and 48000 Hz.

The center frequencies of bands are shown in table below.

Band Index | 0 1 2 3 4 5 6 7 8 9
Frequency 31Hz | 62Hz | 125Hz | 250Hz | 500Hz | 1kHz | 2kHz | 4kHz | 8 kHz | 16 kHz

Default gain of each band is -13 dB. To set the gains of all bands use structure equalizer cfg. To set the gain of
individual band use function equalizer set_gain_info ().

Application Example

Implementation of this API is demonstrated in the audio_processing/pipeline_equalizer example.

API Reference

Header File

* components/esp-adf-libs/esp_codec/include/codec/equalizer.h
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Functions

esp_err_t equalizer_set_info (audio_element_handle_t self, int rate, int ch)

Set the audio sample rate and the number of channels to be processed by the equalizer.
S
* self —Audio element handle
* rate —Audio sample rate
* ch —Audio channel
Bl
* ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t equalizer_set_gain_info (audio_element_handle_t self, int index, int value_gain, bool

is_channels_gain_equal)
Set the audio gain to be processed by the equalizer.
SH
* self —Audio element handle

» index —The position of center frequencies of equalizer. If channel is mono, the index range
is [0, 9]; If channel is stereo and is_channels_gain_equal is true, the index range is
[0, 9]; If channel is stereo and is_channels_gain_equal is false, the index range is [0,
19];

* value_gain —The value of audio gain which in index

* is_channels_gain_equal -If audio channel is stereo, the audio gain values of two
channels are equal when is_channels_gain_equal is true, otherwise it means un-
equal.

R
¢ ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

audio_element_handle_t equalizer_init (equalizer_cfg_t *config)

Create an Audio Element handle that equalizes incoming data.
%% config —The configuration
&0l The audio element handler

Structures

struct equalizer_ cfg

Equalizer Configuration.

+ &#8212;+ I MONO | +
~&#8212;+ | Only Left channel/Only Right channel | +
—&#8212;+ IbandOlband1Iband2/band3Iband4|band5|band6lband7Iband8|band9l +
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&#8212+ 1010101010101 01O01O01O0T1 +

—&#8212;+
+ —&#8212;+
—&#8212;+ DUAL | + —&#8212;+

&#8212;+ | Left channel | Right channel | +

&H#8212;+ —
&#8212;+ IbandOlband 1Iband2|band3Iband4|band5Iband6l/band7Iband8Iband9IbandOlband 1 Iband2lband3Iband4/bandSIband6lband 7t
+ —&#8212;+ —
&#8212;+10101010101010101010101010101010101010101+
~&#8212;+ —&#8212;+

3) Different sample rates support different EQ frequency bands. 11025: {31, 62, 125, 250, 500, 1000, 2000, 3000,
4000, 5500} 22050: {31, 62, 125, 250, 500, 1000, 2000, 4000, 8000, 11000} 44100/48000: {31, 62, 125, 250,
500, 1000, 2000, 4000, 8000, 16000}

#7¥E: 1) This figure indicate the default eq gain of every band in current equalizer. 2) Every channel have 10
band to set.

Public Members

int samplerate
Audio sample rate. Supported samplerate: 11025, 22050, 44100, 48000, unit: Hz

int channel

Number of audio channels. Supported channel: mono, stereo

int *set_gain

Equalizer gain

int out_rb_size

Size of output ring buffer

int task_stack

Task stack size

int task_core

Task running in core--

int task_prio
Task priority

bool stack_in_ext

Try to allocate stack in external memory
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Macros

EQUALIZER_TASK_ STACK

EQUALIZER_TASK_ CORE

EQUALIZER_TASK_ PRIO

EQUALIZER_RINGBUFFER_SIZE

DEFAULT_EQUALIZER_CONFIG ()

Type Definitions

typedef struct equalizer_cfg equalizer_cfg_t

Equalizer Configuration.

+ —&#8212;+  MONO | +

—&#8212;+ | Only Left channel/Only Right channel | +

—&#8212;+ IbandOlband1Iband2/band3Iband4|band5|band6l/band7Iband8|band9l +
&#8212+ 101 010101010101 O0101O01 +
&#8212;+

+ —&#8212;+

—&#8212;+ DUAL + —&#8212;+
&#8212;+ | Left channel | Right channel | +
&#8212;+

&#8212;+ IbandOlband 1Iband2lband3Iband4/band5SIband6l/band7Iband8Iband9IbandOlband 1 Iband2lband3Iband4/band5Iband6l/band7It

+

&#8212:+10101010101010101010101010101010101010101+

~&#8212;+

—&#8212;+ _

&#8212;+

3) Different sample rates support different EQ frequency bands. 11025: {31, 62, 125, 250, 500, 1000, 2000, 3000,
4000, 5500} 22050: {31, 62, 125, 250, 500, 1000, 2000, 4000, 8000, 11000} 44100/48000: {31, 62, 125, 250,

500, 1000, 2000, 4000, 8000, 16000}

P

band to set.

1) This figure indicate the default eq gain of every band in current equalizer. 2) Every channel have 10
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2.5.3 Resample Filter

The Resample Filter is an Audio Element designed to downsample or upsample the incoming data stream as well as to
convert the data between stereo and mono.

Application Example

Implementation of this API is demonstrated in the following examples:
e audio_processing/pipeline_resample
e audio_processing/pipeline_spiffs_amr_resample

e get-started/play_mp3_control

API Reference

Header File

* components/esp-adf-libs/esp_codec/include/codec/filter_resample.h

Functions

esp_err_t rsp_filter_set_src_info (audio_element_handle_t self, int src_rate, int src_ch)

Set the source audio sample rate and the number of channels to be processed by the resample. If need change bits
or not ensure source data infomation, please use rsp_filter_change_src_info to instead this function.

S8

* self —Audio element handle

* src_rate —The sample rate of stream data

* src_ch —The number channels of stream data
Bl

e ESP_OK on success

* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t rsp_filter_change_src_info (audio_element_handle_t self, int src_rate, int src_ch, int src_bit)

Set the source audio sample rate, the number of channels and bits per sample to be processed by the resample.
* self —Audio element handle
* src_rate —The sample rate of stream data
* src_ch —The number channels of stream data
* src_bit —The bit per sample of stream data

Bl

* ESP_OK on success
e ESP_ERR_INVALID_ARG invalid arguments
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audio_element_handle_t rsp_£filter_init (rsp_filter_cfg t *config)

Create an Audio Element handle to resample incoming data.

Depending on configuration, there are upsampling, downsampling, as well as
converting data between mono and dual.

- If the esp_resample_mode_t is "RESAMPLE_DECODE_MODE', “src_rate’ and 'src_
—~ch® will be fetched from "audio_element_getinfo’ .
- If the esp_resample_mode_t is "~RESAMPLE_ENCODE_MODE", “src_rate’, “src_ch’,.

— dest_rate’ and “dest_ch® must be configured.

%% config —The configuration
#&[n] The audio element handler

Structures

struct rsp_filter_cfg_ t

Resample Filter Configuration.

Public Members

int src_rate

The sampling rate of the source PCM file (in Hz)

int src_ch
The number of channel(s) of the source PCM file (Mono=1, Dual=2)

int dest_rate

The sampling rate of the destination PCM file (in Hz)

int dest_bits
The bit for sample of the destination PCM data. Currently, supported bit width :16 bits.

int dest_ch
The number of channel(s) of the destination PCM file (Mono=1, Dual=2)

int src_bits
The bit for sample of the source PCM data. Currently, supported bit width :8bits 16 bits 24bits 32bits.

esp_resample_mode_t mode

The resampling mode (the encoding mode or the decoding mode). For decoding mode, input PCM length is
constant; for encoding mode, output PCM length is constant.
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intmax_indata_bytes

The maximum buffer size of the input PCM (in bytes)

int out_len_bytes

The buffer length of the output stream data. This parameter must be configured in encoding mode.

esp_resample_type_t type
The resampling type (Automatic, Upsampling and Downsampling)

int complexity

Indicates the complexity of the resampling. This parameter is only valid when a FIR filter is used. Range:[1,
5]; 1 indicates the lowest complexity, which means the accuracy is the lowest and the speed is the fastest;
Meanwhile, 5 indicates the highest complexity, which means the accuracy is the highest and the speed is the
slowest.If user set complexity less than 1, complexity can be set 1. If user set complexity more
than 5, complexity can be set 5.

int down_ch_idx

Indicates the channel that is selected (the right channel or the left channel). This parameter is only valid when
the complexity parameter is set to 0 and the number of channel(s) of the input file has changed from dual to
mono.

esp_rsp_prefer_type_t prefer_flag
The select flag about lesser CPU usage or lower INRAM usage, refer to esp_resample.h

int out_rb_size

Output ringbuffer size

int task_stack

Task stack size

int task_core

Task running on core

int task_prio
Task priority

bool stack_in_ext

Try to allocate stack in external memory
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Macros

RSP_FILTER_BUFFER_BYTE

RSP_FILTER_TASK_STACK

RSP_FILTER_TASK_CORE

RSP_FILTER_TASK_PRIO

RSP_FILTER_RINGBUFFER_SIZE

DEFAULT_RESAMPLE_FILTER_CONFIG ()

2.5.4 Sonic

The Sonic component acts as a multidimensional filter that lets you adjust audio parameters of a WAV stream. This
functionality may be useful to e.g. increase playback speed of an audio recording by a user selectable rate.

The following parameters can be adjusted:
* speed
e pitch
* interpolation type

The adjustments of the first two parameters are represented by float values that provide the rate of adjustment. For
example, to increase the speed of an audio sample by 2 times, call sonic_set_pitch_and_speed_info (el,
1.0, 2.0). Tokeep the speed as itis, call sonic_set_pitch_and_speed_info(el, 1.0, 1.0).

For the interpolation type you may select either faster but less accurate linear interpolation, or slower but more accurate
FIR interpolation.

Application Example

Implementation of this API is demonstrated in audio_processing/pipeline_sonic example.

API Reference

Header File

* components/esp-adf-libs/esp_codec/include/codec/audio_sonic.h
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Functions

esp_err_t sonic_set_info (audio_element_handle_t self, int rate, int ch)

Sets the audio sample rate and the number of channels to be processed by the sonic.
S
* self —Audio element handle
* rate —The sample rate of stream data
e ch —The channel numbers of stream data
Bl
* ESP_OK on success
* ESP_ERR_INVALID_ARG invalid arguments

esp_err_t sonic_set_pitch_and_speed_info (audio_element_handle_t self, float pitch, float speed)

Sets the audio pitch and speed to be processed by the sonic.
S
* self —Audio element handle
* pitch —Scale factor of pitch of audio file. 0 means the original pitch. The range is [0.2 4.0].

* speed —Scale factor of speed of audio file. 0 means the original speed. The range is [0.1
8.0].

¢ ESP_OK on success
e ESP_ERR_INVALID_ARG invalid arguments

audio_element_handle_t sonic_init (sonic_cfg_t *config)

Creates an Audio Element handle for sonic.
%% config —The sonic configuration

Rl The audio element handler

Structures

struct sonic_info_t

Information on audio file and configuration parameters required by sonic to process the file.

Public Members

int samplerate

Audio file sample rate (in Hz)

int channel
Number of audio file channels (Mono=1, Dual=2)
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int resample_linear_interpolate

Flag of using simple linear interpolation. 1 indicates using simple linear interpolation. O indicates not using
simple linear interpolation.

float pitch

Scale factor of pitch of audio file. If the value of ‘pitch’ is 0.3, the pitch of audio file processed by sonic
islower than the original. If the value of ‘pitch’ is 1.3, the pitch of audio file processed by sonic is 30%
higher than the original.

float speed

Scale factor of speed of audio file. If the value of ‘speed’ is 0.3, the speed of audio file processed by sonic
is 70% slower than the original. If the value of ‘speed’ is 1.3, the speed of audio file processed by sonic is
30% faster than the original.

struct sonic_cfg_t

Sonic configuration.

Public Members

sonic_info_t sonic_info

Information of sonic

int out_rb_size

Size of output ring buffer

int task_stack

Task stack size

int task_core

Task running in core

int task_prio
Task priority

bool stack_in_ext

Try to allocate stack in external memory
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Macros

SONIC_SET_VALUE_FOR_INITIALIZATION
SONIC_TASK_STACK

SONIC_TASK_CORE

SONIC_TASK_PRIO

SONIC_RINGBUFFER_SIZE

DEFAULT_SONIC_CONFIG ()

2.6 BR55
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b, mg APT IR AT DALE P i) B SE R T 7 i

W2 AE RIS AT 30k

2.6.1 BEFHRS

Wi F le45 (Bluetooth service) %[ ] T 5k A A #4732 B, SCRELA R P
« S MYE (Hands-Free Profile, HFP): 3 i S 4 i A5 U AR 42 ] AL DA S — 38 TR i i 2 42
o EEII4 K HESE (Advanced Audio Distribution Profile, A2DP): i i W S 143 il 22 AR 251

© T AR P HI TS (Audio Video Remote Control Profile, AVRCP): 5 A2DP [aliHif, Tt fE 4 il
Bl P R G P R

Rz R R

PATR 7Bl 7R T 1% APLRYSEEL T 5K
* player/pipeline_bt_sink
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Header File

» components/bluetooth_service/include/bluetooth_service.h

Functions

esp_err_t bluetooth_service_start (bluetooth_service_cfg_t *config)

Initialize and start the Bluetooth service. This function can only be called for one time, and
bluetooth_service_destroy must be called after use.

%4 config —The configuration
B

* ESP_OK

e ESP_FAIL

audio_element_handle_t bluetooth_service_create_stream()

Create Bluetooth stream, it is valid when Bluetooth service has started. The returned audio stream compatible with
existing audio streams and can be used with the Audio Pipeline.

jJ&[n] The Audio Element handle

esp_periph_handle_t bluetooth_service_create_periph ()

Create Bluetooth peripheral, it is valid when Bluetooth service has started. The returned bluetooth peripheral
compatible with existing peripherals and can be used with the ESP Peripherals.

j&[H] The Peripheral handle

esp_err_t periph_bluetooth_play (esp_periph_handle_t periph)
Send the AVRC passthrough command (PLAY) to the Bluetooth device.

%% periph —[in] The periph
Bl

* ESP_OK

* ESP_FAIL

esp_err_t periph_bluetooth_pause (esp_periph_handle_t periph)
Send the AVRC passthrough command (PAUSE) to the Bluetooth device.

%% periph —[in] The periph
Bl

* ESP_OK

* ESP_FAIL

esp_err_t periph_bluetooth_stop (esp_periph_handle_t periph)
Send the AVRC passthrough command (STOP) to the Bluetooth device.

%% periph —[in] The periph
Bl

 ESP_OK

* ESP_FAIL
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esp_err_t periph_bluetooth_next (esp_periph_handle_t periph)
Send the AVRC passthrough command (NEXT) to the Bluetooth device.

%% periph —[in] The periph
A

« ESP_OK

* ESP_FAIL

esp_err_t periph_bluetooth_prev (esp_periph_handle_t periph)
Send the AVRC passthrough command (PREV) to the Bluetooth device.

%% periph —[in] The periph
A

 ESP_OK

» ESP_FAIL

esp_err_t periph_bluetooth_rewind (esp_periph_handle_t periph)
Send the AVRC passthrough command (REWIND) to the Bluetooth device.

%4 periph —[in] The periph
B

* ESP_OK

e ESP_FAIL

esp_err_t periph_bluetooth_fast_forward (esp_periph_handle_t periph)
Send the AVRC passthrough command (FAST FORWARD) to the Bluetooth device.

%4 periph —[in] The periph
Bl

* ESP_OK

* ESP_FAIL

esp_err_t periph_bluetooth_discover (esp_periph_handle_t periph)

Start device discovery.
%4 periph —[in] The periph
Bl
e ESP_OK : Succeed
* ESP_ERR_INVALID_STATE: if bluetooth stack is not yet enabled
* ESP_ERR_INVALID_ARG: if invalid parameters are provided
* ESP_FAIL: others

esp_err_t periph_bluetooth_cancel_discover (esp_periph_handle_t periph)
Cancel device discovery.

%% periph —[in] The periph
B
e ESP_OK : Succeed
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» ESP_ERR_INVALID_STATE: if bluetooth stack is not yet enabled
e ESP_FAIL: others

esp_err_t periph_bluetooth_connect (esp_periph_handle_t periph, bluetooth_addr_t remote_bda)
Connect remote Device.

ZH
* periph —[in] The periph
e remote_bda —[in] remote Bluetooth device address

B

ESP_OK : Succeed
» ESP_ERR_INVALID_STATE: if bluetooth stack is not yet enabled
e ESP_FAIL: others

esp_err_tbluetooth_service_destroy ()

Destroy and cleanup bluetooth service, this function must be called after destroying the Blue-
toth Stream and Bluetooth Peripheral created by bluetooth_service_create_stream and
bluetooth_service_create_periph

gml
- ESP_OK
« ESP_FAIL

int periph_bluetooth_get_a2dp_sample_rate ()
Get a2dp sample rate.

B M

* sample rate

Structures

struct bluetooth_service_user_cb_t

brief Bluetooth service user callback

Public Members

esp_a2d_cb_tuser_a2d_cb
callback for a2dp

esp_a2d_sink_data_cb_t user_a2d_sink_data_cb
callback for a2dp sink data

esp_a2d_source_data_cb_t user_a2d_source_data_cb

callback for a2dp source data
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esp_avrc_ct_cb_tuser_avrc_ct_cb

callback for avrc ct

struct bluetooth_service_cfg_t

brief Bluetooth service configuration

Public Members

const char *device_name

Bluetooth local device name

const char *remote_name

Bluetooth remote device name

bluetooth_service_mode_t mode

Bluetooth working mode

bluetooth_service_user_cb_t user_callback

Bluetooth user callback

Macros

ESP_A2DP_SAMPLE_RATE

BLUETOOTH_ADDR_LEN
brief Bluetooth address length

Type Definitions

typedef uint8_t bluetooth_addr_t[BLUETOOTH_ADDR_LEN]

brief Bluetooth device address

Enumerations

enum bluetooth_service_mode_t

brief Bluetooth service working mode

Values:

enumerator BLUETOOTH_A2DP_SINK
A2DP Bluetooth sink audio, ESP32 will receive audio data from other bluetooth devices
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enumerator BLUETOOTH_A2DP_SOURCE
A2DP Bluetooth source audio, ESP32 can send audio data to other bluetooth devices

Header File

* components/bluetooth_service/include/bt_keycontrol.h

Header File

» components/bluetooth_service/include/hfp_stream.h

Header File

» components/bluetooth_service/include/a2dp_stream.h

2.6.2 i NIRRARSS

iy A5 IR 4% (input key service) K GPIO % A FF Wl ADC #2458 Th RE AR AR b8 1 . 3508
B s e S WL input_key _user_id_t,
R AR B

PATF R Bilfrs 7% APLISE .
¢ checks/check_board_buttons
* player/pipeline_sdcard_mp3_control

e protocols/voip

Header File

e components/input_key_service/include/input_key_service.h

Functions

periph_service_handle_t input_key_service_create (input_key_service_cfg_t *input_key_config)

Initialize and start the input key service.
%% input_key_config —Configuration of input key service
j&[a] NULL failed others input key service handle
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periph_service_state_t get _input_key_service_state (periph_service_handle_t input_handle)

Get the state of input key service.

%%, input_handle —The handle of input key service

jR&a] state of input key service

esp_err_t input_key_service_add_key (periph_service_handle_t input_key_handle, input_key_service_info_t

Add input key’ s information to service list.

¥

e input_key_handle —handle of service
* input_key_info —inputkey’ s information
* add_key_num —number of keys

&[n] ESP_OK success ESP_FAIL failed

Structures

struct input_key_service_info_t

input key’ s infomation

Public Members

esp_periph_id_t type
ID of peripherals

intuser_id

The key’ s user id

intact_id

The key’ s action id

struct input_key_service_cfg_t

input key’ s configuration

Public Members

periph_service_config_t based_cfg

Peripheral service configuration

esp_periph_set_handle_t handle
Peripheral set handle

*input_key_info, int add_key_num)
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Macros

INPUT_KEY_ SERVICE_TASK_STACK_SIZE

INPUT_KEY_ SERVICE_TASK_PRIORITY

INPUT_KEY_SERVICE_TASK_ON_CORE

INPUT_KEY_SERVICE_DEFAULT_CONFIG ()

Enumerations

enum input_key_ service_action_id_t
input key action id

Values:

enumerator INPUT_KEY_SERVICE_ACTION_UNKNOWN

unknown action id

enumerator INPUT_KEY_SERVICE_ACTION_CLICK

click action id

enumerator INPUT_KEY_SERVICE_ACTION_CLICK_RELEASE

click release action id

enumerator INPUT_KEY_SERVICE_ACTION_PRESS

long press action id

enumerator INPUT_KEY_SERVICE_ACTION_PRESS_RELEASE

long press release id

Header File

» components/input_key_service/include/input_key_com_user_id.h

Enumerations

enum input_key user_id_t
input key user user-defined id

Values:
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enumerator INPUT_KEY_USER_ID_UNKNOWN

unknown user id

enumerator INPUT_KEY_USER_ID_REC

user id for recording

enumerator INPUT_KEY_USER_ID_SET

user id for settings

enumerator INPUT_KEY_USER_ID_PLAY

user id for playing

enumerator INPUT_KEY_USER_ID_MODE

user id for mode

enumerator INPUT_KEY_USER_ID_VOLDOWN

user id for volume down

enumerator INPUT_KEY_USER_ID_VOLUP

user id for volume up

enumerator INPUT_KEY_USER_ID_MUTE

user id for mute

enumerator INPUT_KEY_USER_ID_CAPTURE

user id for capture photo

enumerator INPUT_KEY_USER_ID_MSG

user id for message

enumerator INPUT_KEY_USER_ID_BATTERY_ CHARGING
user id for battery charging

enumerator INPUT_KEY_USER_ID_WAKEUP
user id for GPIO wakeup

enumerator INPUT_KEY USER_ID_COLOR

user id for color

enumerator INPUT_KEY_USER_ID_MAX
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2.6.3 Wi-Fi Service

Wi-Fi ¢35 (Wi-Fi service) 21t 1 [\ 28 g BAN M 28 PR TN AE . il ELIM 2% S F SmartConfig, BluFi il AirKiss.

Rz R R4
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e dueros

Header File

e components/wifi_service/include/wifi_service.h

Functions

periph_service_handle_t wifi_service_create (wifi_service_config_t *config)
esp_err_twifi_service_destroy (periph_service_handle_t handle)

esp_err_twifi_service_register_setting_handle (periph_service_handle_t handle,
esp_wifi_setting_handle_t setting, int *out_index)

esp_err_twifi_service_setting_ start (periph_service_handle_t handle, int index)
esp_err_twifi_service_update_sta_info (periph_service_handle_t handle, wifi_config_t *wifi_conf)
esp_err_twifi_service_setting_stop (periph_service_handle_t handle, int index)
esp_err_twifi_service_connect (periph_service_handle_t handle)
esp_err_twifi_service_disconnect (periph_service_handle_t handle)
esp_err_twifi_service_set_sta_info (periph_service_handle_t handle, wifi_config_t *info)
periph_service_state_t wifi_service_state_get (periph_service_handle_t handle)

wifi_service_disconnect_reason_t wifi_service_disconnect_reason_get (periph_service_handle_t
handle)

esp_err_twifi_service_erase_ssid_manager_info (periph_service_handle_t handle)

esp_err_twifi_service_get_last_ssid_c£g (periph_service_handle_t handle, wifi_config_t *wifi_cfg)
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Structures

struct wifi_service_config_t

WiFi service configurations.

Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

bool extern_stack

Task stack allocate on the extern ram

periph_service_cb evt_cb

Service callback function

void *ecb_ctx

Callback context

char *user_data

User data

int setting_timeout_s

Timeout of setting WiFi

intmax_retry time

Maximum times of reconnection

int max_prov_retry_time

Maximum times of reconnection after wifi provision

uint§_t max_ssid_num

Maximum ssid that can be stored
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Macros

WIFI_SERVICE_DEFAULT_CONFIG ()

Enumerations

enumwifi_service_event_t

WiFi STA service status.

Values:

enumerator WIFI_SERV_EVENT UNKNOWN

enumerator WIFI__SERV_EVENT_ CONNECTING

enumerator WIFI__SERV_EVENT_CONNECTED

enumerator WIFI__SERV_EVENT_DISCONNECTED

enumerator WIFI_SERV_EVENT_SETTING_TIMEOUT

enumerator WIFI_SERV_EVENT_ SETTING_FAILED

enumerator WIFI_SERV_EVENT SETTING_FINISHED

enum wifi_service_disconnect_reason_t

WiFi STA disconnection reasons.

Values:

enumerator WIFI_SERV_STA_UNKNOWN

enumerator WIFI_SERV_STA_COM_ERROR

enumerator WIFI_SERV_STA AUTH_ERROR

enumerator WIFI_SERV_STA_ AP_NOT_FOUND

enumerator WIFI_SERV_STA_BY_USER

enumerator WIFI_SERV_STA_SET_INFO
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Header File

* components/wifi_service/include/esp_wifi_setting.h

Functions

esp_wifi_setting_handle_t esp_wifi_setting create (const char *tag)
brief Create wifi setting handle instance

%% tag -Tag of the wifi setting handle
Bl

* NULL, Fail

¢ Others, Success

esp_err_tesp_wifi_setting destroy (esp_wifi_setting_handle_t handle)
brief Destroy wifi setting handle instance

%%t handle —The wifi setting handle instance
R M

* ESP_OK

» ESP_FAIL

esp_err_tesp_wifi_setting register_function (esp_wifi_setting_handle_t handle, wifi_setting_func
start, wifi_setting_func stop, wifi_setting_teardown_ func
teardown)

Register the wifi setting execute functions.

BH
* handle —The wifi setting handle instance
* start —The start wifi setting
» stop —The stop
* teardown —The destroy

B
» ESP_OK
» ESP_FAIL

esp_err_tesp_wifi_setting register_notify_handle (esp_wifi_setting_handle_t handle, void
*on_handle)

Register the notify execute handle.
S8
* handle —The peripheral handle
* on_handle —The notify execute handle
Bl
* ESP_OK
* ESP_FAIL
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esp_err_tesp_wifi_setting_info_notify (esp_wifi_setting_handle_t handle, wifi_config_t *info)
Call this to notify the wifi_config_t toon_handle

S8
* handle —The wifi setting handle instance
e info-Thewifi_config_t
Bl
* ESP_OK
* ESP_FAIL

esp_err_tesp_wifi_setting set_data (esp_wifi_setting_handle_t handle, void *data)
Set the user data.

£41:: Make sure the dat a lifetime is sufficient, this function does not copy all data, it only stores the data pointer

S8
* handle —[in] The wifi setting handle instance
* data —The user data
B
* ESP_OK
» ESP_FAIL

void *esp_wifi_setting_get_data (esp_wifi_setting_handle_t handle)
Get the user data stored on handle

%% handle —[in] The wifi setting handle instance
BRI user data pointer

esp_err_tesp_wifi_setting start (esp_wifi_setting_handle_t handle)

Call this to execute start function of wifi setting instance.
%% handle —The wifi setting handle instance
R M
* ESP_OK
» ESP_FAIL

esp_err_tesp_wifi_setting_stop (esp_wifi_setting_handle_t handle)

Call this to execute stop function of wifi setting instance.
%%, handle —The wifi setting handle instance
B

» ESP_OK
» ESP_FAIL
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esp_err_tesp_wifi_setting_ teardown (esp_wifi_setting_handle_t handle, wifi_config_t *info)

Call this to execute teardown function of wifi setting instance.

S8
* handle —The wifi setting handle instance
e info-Thewifi_config_t
Bl
* ESP_OK
* ESP_FAIL

Type Definitions

typedef struct esp_wifi_setting *esp_wifi_setting_handle_t

typedef esp_err_t (*wifi_setting_ func)(esp_wifi_setting_handle_t handle)

typedef esp_err_t (*wifi_setting_teardown_func)(esp_wifi_setting handle_t handle, wifi_config_t *info)

Header File

* components/wifi_service/include/smart_config.h

Functions

esp_wifi_setting_handle_t smart_config_create (smart_config_info_t *info)

brief Create smartconfig setting handle instance
%% info —Configuration of the smartconfig
Bl
* NULL, Fail

¢ Others, Success

Structures

struct smart_config_info_t

esp smartconfig configuration
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Public Members

smartconfig_type_t type
Type of smartconfig

Macros

SMART_CONFIG_INFO_DEFAULT ()

Header File

» components/wifi_service/include/blufi_config.h

Functions

esp_wifi_setting_handle_t blufi_config_create (void *info)

Create blufi setting handle instance.
%4 info —[in] A pointer to void
B
* NULL, Fail
¢ Others, Success

esp_err_tblufi_set_sta_connected_£flag (esp_wifi_setting_handle_t handle, bool flag)
Set flag to judge whether the station has connected to the AP.

2H
* handle —[in] Wifi setting handle

» flag —[in] bool type of station connection state

e NULL, Fail
¢ Others, Success

esp_err_tblufi_set_customized_data (esp_wifi_setting_handle_t handle, char *data, int data_len)
Set customized data to be sent after configurate wifi successfully.

ZH
* handle —[in] Wifi setting handle
¢ data [in] Customized data

* data_1len —[in] Customized data length

» ESP_FAIL, Fail
ESP_OK, Success
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esp_err_tblufi_send_customized_data (esp_wifi_setting_handle_t handle)

Send customized data that be set before.
%% handle —[in] Wifi setting handle
B
» ESP_FAIL, Fail
e ESP_OK, Success

Header File

» components/wifi_service/include/airkiss_config.h

Functions

esp_wifi_setting_handle_t airkiss_config_create (airkiss_config_info_t *info)

brief Create airkiss setting handle instance
%% info —Configuration of the airkiss
Bl
* NULL, Fail

¢ Others, Success

Structures

struct airkiss_lan_pack_param_t

airkiss lan data pack

Public Members

void *appid
APP identifer data

void *deviceid

Device identifer data

struct airkiss_config_info_t

airkiss configurations
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Public Members

airkiss_lan_pack_param_t 1lan_pack

User lan pack parameter

bool ssdp_notify enable
Notify enable flag

char *aes_key

Airkiss aes key data

Macros

AIRKISS_CONFIG_INFO_DEFAULT ()

Header File

» components/wifi_service/include/wifi_ssid_manager.h

Functions

wifi_ssid_manager_handle_t wifi_ssid_manager_create (uint8_t max_ssid_num)

esp_err_twifi_ssid_manager_get_latest_config (wifi_ssid_manager_handle_t handle, wifi_config_t
*config)

esp_err_twifi_ssid_manager_save (wifi_ssid_manager_handle_t handle, const char *ssid, const char *pwd)

esp_err_twifi_ssid_manager_get_best_config (wifi_ssid_manager_handle_t handle, wifi_config_t
*config)

intwifi_ssid_manager_get_ssid_num (wifi_ssid_manager_handle_t handle)
esp_err_twifi_ssid_manager_list_show (wifi_ssid_manager_handle_t handle)
esp_err_twifi_ssid_manager_erase_all (wifi_ssid_manager_handle_t handle)

esp_err_twifi_ssid_manager_destroy (wifi_ssid_manager_handle_t handle)

Type Definitions

typedef struct wifi_ssid_manager *wifi_ssid_manager_ handle_t
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2.6.4 OTA [R%
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* ota

Header File

¢ components/ota_service/include/ota_service.h

Functions

periph_service_handle_t ota_service_create (ota_service_config_t *config)

Create the OTA service instance.
%4 config —configuration of the OTA service
B
* NULL: Failed

¢ Others: Success

esp_err_t ota_service_set_upgrade_param (periph_service_handle_t handle, ota_upgrade_ops_t *list, int

list_len)

Configure the upgrade parameter This function is not thread safe.

This function will set the parameter table to ota service, and the ota service will upgrade the partitions defined in

the table one by one,

B

* handle —[in] pointer to ‘periph_service_handle_t’ structure

e list —[in] pointer to ‘ora_upgrade_ops_t’ structure
* list_1len [in] length of the ‘list’
]|

ESP_OK: Success
» Others: Failed
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Structures

struct ota_service_config_t

The OTA service configuration.

Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

periph_service_cb evt_cb

Service callback function

void *ecb_ctx
Callback context

struct ota_node_attr_t
The OTA node attributions.

Public Members

esp_partition_type_t type
Partition type

char *label

Partition label

char *uri
The upgrade URL

char *cert_pem

SSL server certification, PEM format as string, if the client requires to verify server

struct ota_upgrade_ops_t

The upgrade operation.
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Public Members

ofa_node_attr_t node
The OTA node

ota_service_err_reason_t (*prepare)(void **handle, ota_node_attr_t *node)

Functions ready for upgrade

ota_service_err_reason_t (*need_upgrade)(void *handle, ota_node_attr_t *node)

Detect whether an upgrade is required

ota_service_err_reason_t (*execute_upgrade)(void *handle, ota_node_attr_t *node)

For execute upgrade

ota_service_err_reason_t (*£inished_check)(void *handle, ofa_node_attr_t *node,
ota_service_err_reason_t result)

Check result of upgrade

bool reboot_£flag

Reboot or not after upgrade

bool break_after_fail

Abort upgrade when got failed

struct ota_result_t
The result of the OTA upgrade.

Public Members

uint8_t id
The result ID

ota_service_err_reason_t result

The error reason

Macros

OTA_SERVICE_ERR_REASON_BASE

OTA_SERVICE_DEFAULT_CONFIG ()
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Enumerations

enum ota_service_event_type_t

The OTA service event type.

Values:

enumerator OTA_SERV_EVENT_TYPE_RESULT

enumerator OTA_SERV_EVENT_TYPE_FINISH

enum ota_service_err_reason_t

The OTA service error reasons.

Values:

enumerator OTA_SERV_ERR_REASON_UNKNOWN

enumerator OTA_SERV_ERR_REASON_SUCCESS

enumerator OTA_SERV_ERR_REASON_NULL_POINTER

enumerator OTA_SERV_ERR_REASON_URL_PARSE_FAIL

enumerator OTA_SERV_ERR_REASON_ERROR_VERSION

enumerator OTA_SERV_ERR_REASON_NO_HIGHER_VERSION

enumerator OTA_SERV_ERR_REASON_ERROR_MAGIC_WORD

enumerator OTA_SERV_ERR_REASON_ERROR_PROJECT_NAME

enumerator OTA_SERV_ERR_REASON_FILE_NOT_FOUND

enumerator OTA_SERV_ERR_REASON_PARTITION NOT_FOUND

enumerator OTA_SERV_ERR_REASON_PARTITION WT FAIL

enumerator OTA_SERV_ERR_REASON_PARTITION_RD_FAIL

enumerator OTA_SERV_ERR_REASON_STREAM INIT_ FAIL

enumerator OTA_SERV_ERR_REASON_STREAM RD_FAIL

enumerator OTA_SERV_ERR_REASON_GET_NEW_APP_DESC_FAIL
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Header File

e components/ota_service/include/ota_proc_default.h

Functions

void ota_app_get_default_proc (ofa_upgrade_ops_t *ops)
get the default process of app partition upgrade

%4 ops —[in] pointer to ot a_upgrade_ops_t structure

void ota_data_get_default_proc (ofa_upgrade_ops_t *ops)
get the default process of data partition upgrade

%%, ops —[in] pointer to ota_upgrade_ops_t structure

ota_service_err_reason_t ota_data_image_stream_read (void *handle, char *buf, int wanted_size)

read from the stream of upgrading

S8
* handle —[in] pointer to upgrade handle
* buf —[in] pointer to receive buffer
» wanted_size [in] bytes to read

&)
* OTA_SERV_ERR_REASON_SUCCESS: Success
* Others: Failed

ota_service_err_reason_t ota_data_partition_write (void *handle, char *buf, int size)

write to the data partition under upgrading

BH
* handle —[in] pointer to upgrade handle
* buf —[in] pointer to data buffer
* size —[in] bytes to write

Bl
* OTA_SERV_ERR_REASON_SUCCESS: Success
¢ Others: Failed

void ota_data_partition_erase_mark (void *handle)

Indicates that the ota partition has been erased By default, this part of flash will be erased during ota. If the behavior
of erasing is called in applition, this API needs to be called.

%% handle —[in] pointer to upgrade handle

int ota_get_version_number (char *version)
Convert string of version to integer The version should be (V0.0.0 - V255.255.255)

%% version —[in] pointer to the string of version
B
* -1: Failed
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¢ Others: version number

Header File

» components/ota_service/include/esp_fs_ota.h

Functions

esp_err_t esp_£s_ota (esp_fs_ota_config_t *ota_config)
Upgrade the firmware from filesystem.

5 7:  This API handles the entire OTA operation, so if this API is being used then no other APIs from
esp_fs_ota component should be called. If more information and control is needed during the FS OTA pro-
cess, then one can use esp__fs_ota_begin and subsequent APIs. If this API returns successfully, esp_restart()
must be called to boot from the new firmware image.

%% ota_config —[in] pointer to esp_fs_ota_config_r structure.
Bl
* ESP_OK: OTA data updated, next reboot will use specified partition.
» ESP_FAIL: For generic failure.
e ESP_ERR_INVALID_ARG: Invalid argument
* ESP_ERR_OTA_VALIDATE_FAILED: Invalid app image
* ESP_ERR_NO_MEM: Cannot allocate memory for OTA operation.
* ESP_ERR_FLASH_OP_TIMEOUT or ESP_ERR_FLASH_OP_FAIL: Flash write failed.

* For other return codes, refer OTA documentation in esp-idf’ s app_update component.

esp_err_t esp_£s_ota_begin (esp_fs_ota_config_t *ota_config, esp_fs_ota_handle_t *handle)
Start FS OTA Firmware upgrade.

This function initializes ESP FS OTA context and open the firmware file. This function must be invoked first.
If this function returns successfully, then esp_fs_ota_perform should be called to continue with the OTA
process and there should be a call to esp_fs_ota_finish on completion of OTA operation or on failure in
subsequent operations.

S8
* ota_config [in] pointer to esp_fs_ota_config_t structure

* handle [out] pointer to an allocated data of type esp_fs_ota_handle_t which will
be initialised in this function

B
* ESP_OK: FS OTA Firmware upgrade context initialised and file opened successful
» ESP_FAIL: For generic failure.

ESP_ERR_INVALID_ARG: Invalid argument (missing/incorrect config, etc.)
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* For other return codes, refer documentation in app_update component and esp_http_client
component in esp-idf.

esp_err_t esp_fs_ota_perform (esp_fs_ota_handle_t fs_ota_handle)
Read image data from file stream and write it to OTA partition.

This function reads image data from file stream and writes it to OTA partition. This function must be called only if
esp_fs_ota_begin() returns successfully. This function must be called in a loop since it returns after every file read
operation thus giving you the flexibility to stop OTA operation midway.

%4 £s_ota_handle —[in] pointer to esp_fs_ota_handle_t structure
peq |
* ESP_ERR_FS_OTA_IN_PROGRESS: OTA update is in progress, call this API again to con-
tinue.

* ESP_OK: OTA update was successful

* ESP_FAIL: OTA update failed

* ESP_ERR_INVALID_ARG: Invalid argument

* ESP_ERR_OTA_VALIDATE_FAILED: Invalid app image

* ESP_ERR_NO_MEM: Cannot allocate memory for OTA operation.

» ESP_ERR_FLASH_OP_TIMEOUT or ESP_ERR_FLASH_OP_FAIL: Flash write failed.
* For other return codes, refer OTA documentation in esp-idf’ s app_update component.

esp_err_t esp_fs_ota_finish (esp_fs_ota_handle_t fs_ota_handle)

Clean-up FS OTA Firmware upgrade and close the file stream.

This function closes the file stream and frees the ESP FS OTA context. This function switches the boot partition
to the OTA partition containing the new firmware image.

41z If this API returns successfully, esp_restart() must be called to boot from the new firmware image

%4 £s_ota_handle —[in] pointer to esp_fs_ota_handle_t structure
Bl

* ESP_OK: Clean-up successful

e ESP_ERR_INVALID_STATE
ESP_ERR_INVALID_ARG: Invalid argument
ESP_ERR_OTA_VALIDATE_FAILED: Invalid app image

esp_err_t esp_fs_ota_get_img_desc (esp_fs_ota_handle_t fs_ota_handle, esp_app_desc_t *new_app_info)

Reads app description from image header. The app description provides information like the “Firmware version”
of the image.

#&1#: This API can be called only after esp_fs_ota_begin() and before esp_fs_ota_perform(). Calling this API
is not mandatory.

S
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» fs_ota_handle [in] pointer to esp_fs_ota_handle_t structure

* new_app_info [out] pointer to an allocated esp_app_desc_t structure
Bl

* ESP_ERR_INVALID_ARG: Invalid arguments

* ESP_FAIL: Failed to read image descriptor

ESP_OK: Successfully read image descriptor

int esp_fs_ota_get_image_len_read (esp_fs_ota_handle_t fs_ota_handle)

Structures

struct esp_£fs_ota_config t
ESP FS OTA configuration.

Public Members

const char *path
file path

const int buffer_size
Size of buffer

Macros

ESP_ERR_FS_OTA_BASE

ESP_ERR_FS_OTA_IN_PROGRESS

Type Definitions

typedef void *esp_fs_ota_handle_t

2.6.5 DuerOS R

DuerOS k%5 (DuerOS service) 223 T DuerOS 15 S A2 H.o
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¢ dueros

Header File

» components/dueros_service/include/dueros_service.h

Functions

audio_service_handle_t dueros_service_create ()

Create the dueros service.
A
e NULL, Fail
¢ Others, Success

service_state_t dueros_service_state_get ()

Get dueros service state.
Al The state of service

esp_err_t dueros_voice_upload (audio_service_handle_t handle, void *buf, int len)

Upload voice to backend server.
S8
* handle —dueros service handle
* buf —Data buffer
* len —Size of buffer
&[] ESP_OK ESP_FAIL

esp_err_t dueros_voice_cancel (audio_service_handle_t handle)

Cancel the current session.
¥ handle —dueros service handle
&Il ESP_OK ESP_FAIL

esp_err_t dueros_start_wifi_cfqg (audio_service_handle_t handle, duer_wifi_cfg_t *cfg)
Start the wifi configure process.

S8
* handle —Dueros service handle
» cfg —Configuration

i&[n ESP_OK ESP_FAIL
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esp_err_t dueros_stop_wifi_cfg (audio_service_handle_t handle)

Stop the wifi configure process.
%% handle —Dueros service handle
i&Ia] ESP_OK ESP_FAIL

esp_err_t dueros_wifi_status_report (audio_service_handle_t handle, dueros_wifi_st_t *st)
Report the wifi status to dipb.

S
* handle —Dueros service handle
¢ st —WiFi status and error code

iz [a] ESP_OK ESP_FAIL

Structures

struct dueros_wifi_st_t

Status of WiFi connection.
Public Members

int status

Please refer to: enum duer_dipb_client_status_e

int err

Please refer to: enum duer _wifi_connect_error_code_e

2.6.6 ERIRS
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Header File

» components/display_service/include/display_service.h

Functions

display_service_handle_t display_service_create (display_service_config_t *cfg)
esp_err_tdisplay_service_set_pattern (void *handle, int disp_pattern, int value)

esp_err_t display_destroy (display_service_handle_t handle)

Structures

struct display_service_config t

Display service configurations.

Public Members

periph_service_config_t based_cfg

Peripheral service configuration

void *instance

Sub-instance

Type Definitions

typedef struct display_service_impl *display_service_handle_t

Enumerations

enum display_pattern_t

Values:

enumerator DISPLAY_ PATTERN_UNKNOWN

enumerator DISPLAY_ PATTERN_ WIFI_SETTING

enumerator DISPLAY_PATTERN_WIFI_CONNECTTING

enumerator DISPLAY_ PATTERN_WIFI_CONNECTED
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enumerator DISPLAY_ PATTERN_WIFI_DISCONNECTED

enumerator DISPLAY_ PATTERN_WIFI_SETTING_FINISHED

enumerator DISPLAY_PATTERN_BT_CONNECTTING

enumerator DISPLAY_PATTERN_BT_CONNECTED

enumerator DISPLAY PATTERN_BT_DISCONNECTED

enumerator DISPLAY_ PATTERN_RECORDING_START

enumerator DISPLAY_PATTERN_RECORDING_STOP

enumerator DISPLAY_PATTERN_RECOGNITION_START

enumerator DISPLAY_PATTERN_RECOGNITION_STOP

enumerator DISPLAY_ PATTERN_WAKEUP_ON

enumerator DISPLAY_ PATTERN_WAKEUP_FINISHED

enumerator DISPLAY_PATTERN_MUSIC_ON

enumerator DISPLAY_PATTERN_MUSIC_FINISHED

enumerator DISPLAY PATTERN_VOLUME

enumerator DISPLAY PATTERN_MUTE_ON

enumerator DISPLAY_PATTERN_MUTE_OFF

enumerator DISPLAY_ PATTERN_TURN_ON

enumerator DISPLAY PATTERN_TURN_OFF

enumerator DISPLAY_PATTERN_BATTERY_ LOW

enumerator DISPLAY_PATTERN_BATTERY_ CHARGING

enumerator DISPLAY_PATTERN_BATTERY_FULL

2.6. RS 179



ADF E4R AFF A HESRF M, &7 latest

enumerator DISPLAY_ PATTERN_POWERON_INIT

enumerator DISPLAY_PATTERN _WIFI_NO_CFG

enumerator DISPLAY PATTERN_SPEECH_BEGIN

enumerator DISPLAY_PATTERN_SPEECH_OVER

enumerator DISPLAY PATTERN_MAX

Header File

e components/display_service/led_bar/include/led_bar_aw2013.h

Functions

void aw2013_led_bar_task (void *parameters)
esp_periph_handle_t 1led_bar_aw2013_init (void)
Initialize led bar instance.
A
e NULL Error
* others Success

esp_err_t led_bar_aw2013_pattern (void *handle, int pat, int value)
Set led bar display pattern.

BH
* handle —led bar instance
» pat —display pattern
* value —value of pattern
B
* ESP_OK
» ESP_FAIL

esp_err_t led_bar_aw2013_set_blink_time (void *handle, uint8_t time, int period)

Set blinking period and times.
S8
* handle —led bar instance
* time —times of blink
* period —period of blink
B
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* ESP_OK
* ESP_FAIL
void 1ed_bar_aw2013_deinit (esp_periph_handle_t handle)

Destroy esp_periph_handle_t instance.

%% handle -led bar instance

Header File

e components/display_service/led_bar/include/led_bar_is31x.h

Functions

esp_periph_handle_t led_bar_is31x_init ()
Initialize esp_periph_handle_t instance.

pq |
e NULL, Fail
¢ Others, Success

esp_err_t led_bar_is31x_pattern (void *handle, int pat, int value)
Set led bar display pattern.

S8
* handle —led bar instance
» pat —display pattern
* value —value of pattern

&l
» ESP_OK
» ESP_FAIL

void led_bar_is31x_deinit (esp_periph_handle_t handle)

Destroy esp_periph_handle_t instance.

%% handle —led bar instance

Header File

e components/display_service/led_bar/include/led_bar_ws2812.h
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Functions

led_bar_ws2812_handle_t led_bar_ws2812_init (gpio_num_t gpio_num, int led_num)
Initialize led_bar_ws2812_handle_t instance.

SH
e gpio_num —The GPIO number of ws2812
* led_num —The number of all ws2812
B
e led_bar_ws2812 handle t

esp_err_t led_bar_ws2812_pattern (void *handle, int pat, int value)
Set ws2812 pattern.

ZH
¢ handle —ws2812 indicator instance
* pat —display pattern

* value —value of pattern

¢ ESP_OK, success
¢ Others, fail

esp_err_t led_bar_ws2812_deinit (led_bar_ws2812_handle_t handle)
Destroy led_bar_ws2812_handle_t instance.

%% handle —ws2812 indicator instance
Bl
Bl

* ESP_OK, success

¢ Others, fail

Type Definitions

typedef struct led_bar_ws2812_impl *1led_bar_ws2812_handle_t

Header File

» components/display_service/led_indicator/include/led_indicator.h
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Functions

led_indicator_handle_t 1ed_indicator_init (gpio_num_t num)

Initialize led_indicator_handle_t instance.
%% num —led gpio number
Bl
* NULL, Fail
¢ Others, Success

esp_err_t led_indicator_pattern (void *handle, int pat, int value)
Set led indicator display pattern.

S8
* handle —led indicator instance
* pat —display pattern
* value —value of pattern
Bl
 ESP_OK
ESP_FAIL

void 1led_indicator_deinit (led_indicator_handle_t handle)
Destroy led_indicator_handle_t instance.

¥ handle -led indicator instance

Type Definitions

typedef struct led_indicator_impl *1ed_indicator_handle_t

2.6.7 AR SS
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Header File

* components/battery_service/include/battery_service.h

Functions

periph_service_handle_t battery_service_create (battery_service_config_t *config)

Create the battery service instance.
%% config —configuration of the battery service
B
* NULL: Failed
* Others: Success

esp_err_tbattery_service_vol_report_switch (periph_service_handle_t handle, bool on_off)

Start or stop the battery voltage report.
Y
* handle [in] pointer to ‘periph_service_handle_t’ structure
* on_off [in] ‘true’ tostart, ‘false’ to stop
Rl
* ESP_OK: Success
e ESP_ERR_INVALID_ARG: handle is NULL

esp_err_tbattery_service_set_vol_report_£freq (periph_service_handle_t handle, int freq)

Set voltage report freqency.
SH
* handle —{in] pointer to ‘periph_service_handle_t’ structure
» freq -[in] voltage report fregency

B

ESP_OK: Success
e ESP_ERR_INVALID_ARG: handle is NULL

Structures

struct battery_service_config t

Battery service configure.

184 Chapter 2. API Reference


https://github.com/espressif/esp-adf/blob/1bc914b/components/battery_service/include/battery_service.h

ADF &4 R ZIESRF M, X7 latest

Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

bool extern_stack

Task stack allocate on the extern ram

periph_service_cb evt_cb

Service callback function

void *cb_ctx

Callback context

vol_monitor_handle_t wvol_monitor

Battery monitor

void *charger_monitor

Charger monitor. Not supported yet

Macros

BATTERY_SERVICE_DEFAULT_CONFIG ()

Enumerations

enum battery_service_event_t

Battery service event.

Values:

enumerator BAT_SERV_EVENT_ UNKNOWN

enumerator BAT_SERV_EVENT_VOL_REPORT

enumerator BAT_SERV_EVENT_BAT FULL

enumerator BAT_SERV_EVENT BAT_LOW
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enumerator BAT_SERV_EVENT_CHARGING_BEGIN

enumerator BAT_SERV_EVENT CHARGING_STOP

Header File

* components/battery_service/monitors/include/voltage_monitor.h

Functions

vol_monitor_handle_t vol_monitor_create (vol_monitor_param_t *config)

Create the voltage monitor instance.
%% config —[in] pointer to vol_monitor_param_t’ structure
&l
e NULL: Failed
¢ Others: Success

esp_err_t vol_monitor_destroy (vol_monitor_handle_t handle)

Destroy the voltage monitor.
%% handle —[in] pointer to ‘vol_monitor_handle_t’ structure
Bl
e ESP_OK: Success
* Others: Failed

esp_err_t vol_monitor_set_event_cb (vol_monitor_handle_t handle, vol_monitor_event_cb event_cb, void
*user_ctx)

Set the event callback.

S8
* handle —[in] pointer to ‘vol_monitor_handle_t’ structure
* event_cb [in] callback used to handle the events of voltage monitor
* user_ctx —[in] user’ s data

&I

e ESP_OK: Success
¢ Others: Failed

esp_err_tvol_monitor_start_freq report (vol _monitor_handle_t handle)

Start the voltage report with the configured frequency.
%% handle [in] pointer to vol_monitor_handle_t’ structure
Bl
e ESP_OK: Success
* Others: Failed
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esp_err_t vol_monitor_stop_freq report (vol_monitor_handle_t handle)

Stop the voltage frequency report.
%% handle —[in] pointer to ‘vol_monitor_handle_t’ structure
A
* ESP_OK: Success
* Others: Failed

esp_err_t vol_monitor_set_report_£freq (vol_monitor_handle_t handle, int freq)

Set the voltage report frequency.
BH
* handle —[in] pointer to ‘vol_monitor_handle_t’ structure
» freq —[in] voltage report fregency

B M

ESP_OK: Success
e Others: Failed

Structures

struct vol_monitor_param_t

Battery adc configure.

Public Members

bool (*init)(void*)
Voltage read init

bool (*deinit)(void*)
Voltage read deinit

int (*vol_get)(void*)

Voltage read interface

void *user_data

Parameters for callbacks

int read_freq

Voltage read frequency, unit: s

int report_freq

Voltage report frequency, voltage will be report with a interval calculate by (read_freq* report_freq)

2.6. RS 187



ADF E40 i FAFF R HEZ2F 11, & 1 latest

int vol_full_threshold
Voltage threshold to report, unit: mV

int vol_low_threshold
Voltage threshold to report, unit: mV

Type Definitions
typedef void *vol_monitor_handle_t
voltage monitor handle

typedef void (*vol_monitor_event_cb)(int msg_id, void *data, void *user_ctx)
callback define

Enumerations

enum vol_monitor_event_t

Battery adc configure.

Values:

enumerator VOL_MONITOR_EVENT_FREQ REPORT
enumerator VOL_MONITOR_EVENT_BAT_ FULL

enumerator VOL_MONITOR_EVENT BAT_LOW
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Header File

» components/coredump_upload_service/include/coredump_upload_service.h

Functions

bool coredump_need_upload ()

This function will check the reset code and determine whether to upload the coredump.
Bl
* true: last reboot is a abnormal reset.
* false

esp_err_t coredump_upload (periph_service_handle_t handle, char *url)

Upload the core dump image to the url. This function will block the current task until the upload process finished.

S8
* handle —[in] the ‘periph_service_handle_t’
e url —[in] server addr
B
« ESP_OK
* ESP_FAIL

periph_service_handle_t coredump_upload_service_create (coredump_upload_service_config_t *config)

Create the core dump upload service instance.
%%t config —configuration of the OTA service
Bl
* NULL: Failed

¢ Others: Success

Structures

struct coredump_upload_service_config_t

coredump service configuration parameters

Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)
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int task_core

Service task running in core (0 or 1)

periph_service_cb evt_cb

Service callback function

void *cb_ctx

Callback context

bool (*do_post)(char *url, uint8_t *data, size_t len)

POST interface, users can override this to customize the http client. if left NULL, the service will use the
default one

Macros

COREDUMP_UPLOAD_SERVICE_DEFAULT_CONFIG ()

2.6.9 Header File

» components/esp_dispatcher/include/periph_service.h

2.6.10 Functions

periph_service_handle_t periph_service_create (periph_service_config_t *config)

brief Create peripheral service instance
%% config —[in] Configuration of the peripheral service instance
B
» NULL, Fail
¢ Others, Success

esp_err_t periph_service_destroy (periph_service_handle_t handle)

brief Destroy peripheral service instance
%4 handle —[in] The peripheral service instance
B
* ESP_OK
* ESP_FAIL
e ESP_ERR_INVALID_ARG

esp_err_t periph_service_start (periph_service_handle_t handle)

brief Start the specific peripheral service
%% handle —[in] The peripheral service instance
izl
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* ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t periph_service_stop (periph_service_handle_t handle)

brief Stop the specific peripheral service
%% handle —[in] The peripheral service instance
Bl
* ESP_OK
* ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t periph_service_set_callback (periph_service_handle_t handle, periph_service_cb cb, void *ctx)

brief Set the specific peripheral service callback function
BH
* handle [in] The peripheral service instance
* cb —[in] A pointer to service_callback
e ctx —[in] A pointer to user context
B
» ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t periph_service_callback (periph_service_handle_t handle, periph_service_event t *evt)

brief Called peripheral service by configurations
B8
* handle [in] The peripheral service instance
* evt —[in] A pointer to periph_service_event_t
Bl
* ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t periph_service_set_data (periph_service_handle_t handle, void *data)

brief Set user data to specific peripheral service instance
S8
* handle [in] The peripheral service instance

* data [in] A pointer to user data

B

ESP_OK
* ESP_FAIL
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» ESP_ERR_INVALID_ARG

void *periph_service_get_data (periph_service_handle_t handle)

brief Get user data by specific peripheral service instance
%% handle -[in] The peripheral service instance
JR&IA] A pointer to user data

esp_err_t periph_service_ioctl (periph_service_handle_t handle, void *ioctl_handle, int cmd, int value)

brief In/out control by peripheral service instance

S8
* handle —[in] The peripheral service instance
e ioctl_handle —[in] Sub-instance handle
¢ cmd —[in] Command of value
¢ value —[in] Data of the command

&l
* ESP_OK
* ESP_FAIL
* ESP_ERR_INVALID_ARG

2.6.11 Structures

struct periph_service_event_t

Peripheral service event informations.

Public Members

int type
Type of event

void *source

Event source

void *data

Event data

int len

Length of data

struct periph_service_config_t

Peripheral service configurations.
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Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

TaskFunction_t task_func

Service task function

bool extern_stack

Task stack allocate on the extern ram

periph_service_ctrl service_start

Start function

periph_service_ctrl service_stop

Stop function

periph_service_ctrl service_destroy

Destroy function

periph_service_io service_ioctl

In out control function

char *service_name

Name of peripheral service

void *user_data

User data

2.6.12 Type Definitions

typedef struct periph_service_impl *periph_service_handle_t
typedef esp_err_t (*periph_service_ctrl)(periph_service_handle_t handle)

typedef esp_err_t (*periph_service_io)(void *ioctl_handle, int cmd, int value)

typedef esp_err_t (*periph_service_cb)(periph_service_handle_t handle, periph_service_event_t *evt, void *ctx)
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2.6.13 Enumerations

enum periph_service_state_t

Peripheral service state.

Values:

enumerator PERIPH_SERVICE_STATE_UNKNOWN

enumerator PERIPH_SERVICE_STATE_IDLE

enumerator PERIPH_SERVICE_STATE_RUNNING

enumerator PERIPH_SERVICE_STATE_STOPPED

2.6.14 Header File

» components/esp_dispatcher/include/audio_service.h

2.6.15 Functions

audio_service_handle_t audio_service_create (audio_service_config_t *config)

brief Create audio service instance
%4 config —[in] Configuration of the audio service instance
B
* NULL, Fail
¢ Others, Success

esp_err_t audio_service_destroy (audio_service_handle_t handle)

brief Destroy audio service instance
%% handle [in] The audio service instance
B
* ESP_OK
» ESP_FAIL
» ESP_ERR_INVALID_ARG

esp_err_t audio_service_start (audio_service_handle_t handle)

brief Start the specific audio service
%% handle —[in] The audio service instance
B
* ESP_OK
* ESP_FAIL
* ESP_ERR_INVALID_ARG
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esp_err_t audio_service_stop (audio_service_handle_t handle)

brief Stop the specific audio service
%% handle —[in] The audio service instance
A
» ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t audio_service_set_callback (audio_service_handle_t handle, service_callback cb, void *ctx)

brief Set the specific audio service callback function.
S8
e handle —[in] The audio service instance
* cb —[in] A pointer to service_callback
e ctx —[in] A pointer to user context
Bl
* ESP_OK
* ESP_FAIL
e ESP_ERR_INVALID_ARG

esp_err_t audio_service_callback (audio_service_handle_t handle, service_event t *evt)

brief Called audio service by configurations
S
* handle [in] The audio service instance
* evt —[in] A pointer to service_event t
B
* ESP_OK
» ESP_FAIL
e ESP_ERR_INVALID_ARG

esp_err_t audio_service_connect (audio_service_handle_t handle)

brief Connect the specific audio service
¥ handle [in] The audio service instance
B
* ESP_OK
* ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t audio_service_disconnect (audio_service_handle_t handle)

brief Disconnect the specific audio service
%% handle —[in] The audio service instance

B
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* ESP_OK
» ESP_FAIL
* ESP_ERR_INVALID_ARG

esp_err_t audio_service_set_data (audio_service_handle_t handle, void *data)

brief Set user data to specific audio service instance
S8
¢ handle —[in] The audio service instance
* data —[in] A pointer to user data
Bl
* ESP_OK
* ESP_FAIL
* ESP_ERR_INVALID_ARG

void *audio_service_get_data (audio_service_handle_t handle)

brief Get user data by specific audio service instance
¥ handle —[in] The audio service instance

&[] A pointer to user data

2.6.16 Structures

struct service_event_t

Audio service event informations.

Public Members

int type
Type of event

void *source

Event source

void *data

Event data

int len

Length of data

struct audio_service_config_t

Audio service configurations.
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Public Members

int task_stack

>0 Service task stack; =0 with out task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

TaskFunction_t task_func

A pointer to TaskFunction_t for service task function

service_ctrl service_start

Start function

service_ctrl service_stop

Stop function

service_ctrl service_connect

Connect function

service_ctrl service_disconnect

Disconnect function

service_ctrl service_destroy

Destroy function

const char *service_name

Name of audio service

void *user_data

User context

2.6.17 Type Definitions

typedef struct audio_service_impl *audio_service_handle_t
typedef esp_err_t (*service_ctrl)(audio_service_handle_t handle)

typedef esp_err_t (*service_callback)(audio_service_handle_t handle, service_event t *evt, void *ctx)
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2.6.18 Enumerations

enum service_state_t

Audio service state.

Values:

enumerator SERVICE_STATE__UNKNOWN
enumerator SERVICE_STATE_IDLE
enumerator SERVICE_STATE_CONNECTING
enumerator SERVICE_STATE_CONNECTED
enumerator SERVICE_STATE_RUNNING

enumerator SERVICE_STATE_STOPPED

2.7 Speech Recognition

ESP-ADF offers a comprehensive range of speech recognition processing functions, such as front-end speech processing,
TTS, voice wake-up, and command word recognition. ESP-ADF’ s Element-based audio recorder integrates speech
recognition and audio signal processing into an event-driven High-level API. This approach enables users to maintain
flexibility in their configurations while making it easier to use.

2.7.1 Voice Activity Detection

Voice activity detection (VAD) is a technique used in speech processing to detect the presence (or absence) of human
speech. Detection of somebody speaking may be used to activate some processes, e.g. automatically switch on voice
recording. It may be also used to deactivate processes, e.g. stop coding and transmission of silence packets to save on
computation and network bandwidth.

Provided in this section API implements VAD functionality together with couple of options to configure sensitivity of
speech detection, set sample rate or duration of audio samples.

Application Example

Implementation of the voice activity detection API is demonstrated in speech_recognition/vad example.
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API Reference

For the latest API reference please refer to Espressif Speech recognition repository.

2.7.2 WakeNet Interface

Setting up the speech recognition application to detect a wakeup word may be done using series of Audio Elements linked
into a pipeline shown below.

Mic Codec 125 it RAW Speech
chip stream frer stream recognition

¥ 5: Sample Speech Recognition Pipeline

Configuration and use of particular elements is demonstrated in several examples linked to elsewhere in this documen-
tation. What may need clarification is use of the Filter and the RAW stream. The filter is used to adjust the sample
rate of the I2S stream to match the sample rate of the speech recognition model. The RAW stream is the way to feed the
audio input to the model.

The above introduction is the primary guidance. ESP-ADF offers users a more flexible and convenient module, namely
the audio recorder, which is strongly recommended for use.

API Reference

For the latest speech recognition API reference, please refer to ESP-SR Speech Recognition Framework.

2.7.3 Audio Recorder

The Audio Recorder API is a set of functions to facilitate voice recording. It combines two important functions, namely
Audio Front End (AFE) and audio encoding. This allows users to customize AFE’ s Voice Activity Detection (VAD),
Automatic Gain Control (AGC), and Acoustic Echo Cancellation (AEC) settings. The encoding function is used by users
to establish the encoding audio element, which supports various formats such as AAC, AMR-NB, AMR-WB, ADPCM,
WAV, OPUS, and G711. The audio_rec_evt_t event makes it easy for users to interact with the Audio Recorder software.

The data path of the Audio recorder is presented in the diagram below.

Mic
.—p 125 | Resample RAW
stream element stream
Resample
Multibet [ ® F S Encoder
element element

AFE
| 6: Audio recorder data path

h J

Walkehet

¥
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The area represented by the parallelogram is configurable by the user according to their needs, such as sampling frequency,
whether to encode, and encoding format.

Application Example

The speech_recognition/wwe/ example demonstrates how to initialize the speech recognition model, determine the num-
ber of samples and the sample rate of voice data to feed to the model, detect the wake-up word and command words, and
encode voice to specific audio format.

API Reference

Header File

e components/audio_recorder/include/audio_recorder.h

Functions

audio_rec_handle_t audio_recorder_create (audio_rec_cfg t *cfg)

Initialize and start up audio recorder.
%4 c£fqg —Configuration of audio recorder
&8l NULL failed Others audio recorder handle

esp_err_t audio_recorder_trigger_start (audio_rec_handle_t handle)

Start recording by force.

251 If there need to read from recorder without wake word detected or read from recorder while the wake word
detection is disabled, this interface can be use to force start the recorder process.

¥ handle —Audio recorder handle
&Il ESP_OK ESP_FAIL

esp_err_t audio_recorder_trigger_stop (audio_rec_handle_t handle)

Stop recording by force.

& 1 No matter the recorder process is triggered by wake word detected or triggered by
audio_recorder_trigger_start, this function can be used to force stop the recorder. And if the VAD
detection is disabeled, this must be invoked to stop recording after audio_recorder_trigger_start.

%% handle —Audio recorder handle
iBI ESP_OK ESP_FAIL

esp_err_t audio_recorder_wakenet_enable (audio_rec_handle_t handle, bool enable)

Enable or suspend wake word detection.

¢ handle —Audio recorder handle
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* enable —true: enable wake word detection false: disable wake word detection
&Ml ESP_OK ESP_FAIL

esp_err_t audio_recorder_multinet_enable (audio_rec_handle_t handle, bool enable)

Enable or suspend speech command recognition.
¥
* handle —Audio recorder handle

* enable —true: enable speech command recognition false: disable speech command recogni-
tion

&l ESP_OK ESP_FAIL

esp_err_t audio_recorder_vad_check_enable (audio_rec_handle_t handle, bool enable)

Enable or suspend voice duration check.
S8
* handle —Audio recorder handle
* enable —true: enable voice duration check false: disable voice duration check
& ESP_OK ESP_FAIL

int audio_recorder_data_read (audio_rec_handle_t handle, void *buffer, int length, TickType_t ticks)

Read data from audio recorder.
S8
* handle —Audio recorder handle
* buffer —Buffer to save data
e length —Size of buffer
* ticks —Timeout for reading
& IH] Length of data actually read ESP_ERR_INVALID_ARG

esp_err_t audio_recorder_destroy (audio_rec_handle_t handle)

Destroy audio recorder and recycle all resource.
¥ handle —Audio recorder handle
&[] ESP_OK ESP_FAIL

bool audio_recorder_get_wakeup_state (audio_rec_handle_t handle)

Get the wake up state of audio recorder.
%%t handle —Audio recorder handle
&IA| true false
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Structures

struct audio_rec_evt_t

Recorder event.

Public Types

enum [anonymous]

Audio recorder event type.

Values:

enumerator AUDIO_REC_WAKEUP_START
Wakeup start

enumerator AUDIO_REC_WAKEUP_END
Wakeup stop

enumerator AUDIO_REC_VAD_START
Vad start

enumerator AUDIO_REC_VAD_END
Vad stop

enumerator AUDIO_REC_COMMAND_DECT

Form 0 is the id of the voice commands detected by Multinet

Public Members

enum audio_rec_evt_t::[anonymous] type
Audio recorder event type.

Event type

void *event_data

Event data: For AUDIO_REC_WAKEUP_START, event data is recorder_sr_wakeup_result_t
For AUDIO_REC_COMMAND_DECT or higher, event data is recorder_sr_mn_result_t For other
events, event data is NULL

size_tdata_len

Length of event data

struct audio_rec_cfg_ t

Audio recorder configuration.
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Public Members

int pinned_core

Audio recorder task pinned to core

int task_prio

Audio recorder task priority

int task_size

Audio recorder task stack size

rec_event_cb_t event_cb

Event callback function, event type as audio_rec_evt_t shown above

void *user_data

Pointer to user data (optional)

recorder_data_read_t read

Data callback function used feed data to audio recorder

void *sr_handle
SR handle

recorder_sr_iface_t *sr_iface

SR interface

int wakeup_time

Unit:ms. The duration that the wakeup state remains when VAD is not triggered

int vad_start

Unit:ms. Consecutive speech frame will be judged to vad start

int vad_off
Unit:ms. When the silence time exceeds this value, it is determined as AUDIO_REC_VAD_END state

int wakeup_end

Unit:ms. When the silence time after AUDIO_REC_VAD_END state exceeds this value, it is determined as
AUDIO_REC_WAKEUP_END

void *encoder_handle

Encoder handle

recorder_encoder_iface_t *encoder_iface

Encoder interface
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Macros

AUDIO_REC_DEF_TASK_SZ

Stack size of recorder task

AUDIO_REC_DEF_TASK_PRIO

Priority of recoder task

AUDIO_REC_DEF_TASK_CORE

Pinned to core

AUDIO_REC_DEF_WAKEUP_TM

Default wake up time (ms)

AUDIO_REC_DEF_WAKEEND_TM

Duration after vad off (ms)

AUDIO_REC_VAD_START SPEECH_MS

Consecutive speech frame will be judged to vad start (ms)

AUDIO_REC_DEF_VAD_OFF_TM

Default vad off time (ms)

AUDIO_RECORDER_DEFAULT_CFG ()

Type Definitions

typedef esp_err_t (*rec_event_cb_t)(audio_rec_evt_t *event, void *user_data)

Event Notification.

typedef struct __audio_recorder *faudio_rec_handle_t

Audio recorder handle.

Header File

e components/audio_recorder/include/recorder_sr.h
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Functions

recorder_sr_handle_t recorder_sr_create (recorder_sr_cfg_t *cfg, recorder_sr_iface_t **iface)

Initialize sr processor, and the sr is disabled as default.
SH
» cfg —Configuration of sr
* iface —User interface provide by recorder sr
&1 NULL failed Others SR handle

esp_err_t recorder_sr_destroy (recorder_sr_handle_t handle)

Destroy SR processor and recycle all resource.
%%, handle SR processor handle
i&[Al ESP_OK ESP_FAIL

esp_err_t recorder_sr_reset_speech_cmd (recorder_sr_handle_t handle, char *command_str, char
*err_phrase_id)

Reset the speech commands.
S8
* handle SR processor handle
* command_str —String of the commands. more details on #2reset—-api-on-the-fly
* err_phrase_id —error string output

A ESP_OK ESP_FAIL

Structures

struct recorder_sr_cfg_t

SR processor configuration.

P51 Since the detection of command words requires a clear starting point, the moment the wake word is detected
is taken as the default start of detection. Therefore, if the wake word detection is disabled, the detection will use the
vad_state detected by esp—sr as the start of detection. However, due to the fluctuation of this vad_state,
the effectiveness of command word detection will be limited.

Public Members

afe_config_t afe_cfg
Configuration of AFE

int8_t input_order[DAT_CH_MAX]
Channel order of the input data
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boolmultinet_init

Enable of speech command recognition

int feed_task_core
Core id of feed task

int feed_task_prio
Priority of feed task

int feed_task_stack
Stack size of feed task

int fetch_task_core
Core id of fetch task

int fetch_task_prio
Priority of fetch task

int fetch_task_stack
Stack size of fetch task

int rb_size

Ringbuffer size of recorder sr

char *partition_label

Partition label which stored the model data

char *mn_language

Command language for multinet to load

char *wn_wakeword

Wake Word for WakeNet to load. This is useful when multiple Wake Words are selected in sdkconfig. Setting
this to NULL will use the first found model.

Macros

FEED_TASK_STACK_SZ

FETCH_TASK_STACK_SZ

FEED_TASK_PRIO

FETCH_TASK_PRIO
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FEED_TASK_PINNED_CORE

FETCH_TASK_PINNED_CORE

SR_OUTPUT_RB_SIZE
INPUT _ORDER_DEFAULT ()

DEFAULT_RECORDER_SR_CFG ()

Type Definitions

typedef void *recorder_sr_handle_t

SR processor handle.

Header File

» components/audio_recorder/include/recorder_encoder.h

Functions

recorder_encoder_handle_t recorder_encoder_create (recorder_encoder_cfg_t *cfg,
recorder_encoder_iface_t **iface)

Initialize encoder processor, and the encoder is disabled as default.
S8
» cfg —Configuration of encoder
* iface —User interface provide by recorder encoder
&l NULL failed Others encoder handle

esp_err_t recorder_encoder_destroy (recorder_encoder_handle_t handle)

Destroy encoder processor and recycle all resource.
%%t handle —Encoder processor handle
&[] ESP_OK ESP_FAIL

Structures

struct recorder_encoder_cfg_t

recorder encoder configuration parameters
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Public Members

audio_element_handle_t resample

Handle of resample

audio_element_handle_t encoder

Handle of encoder

Type Definitions

typedef void *recorder_encoder_handle_t

encoder handle

2.8 Peripherals

There are several peripherals available in the ESP-ADF, ranging from buttons and LEDs to SD Card or Wi-Fi. The pe-
ripherals are implemented using common API that is then expanded with peripheral specific functionality. The following
description covers common functionality.

2.8.1 ESP Peripherals

This library simplifies the management of peripherals, by pooling and monitoring in a single task, adding basic functions
to send and receive events. And it also provides APIs to easily integrate new peripherals.

£ 1E: Note that if you do not intend to integrate new peripherals into esp_peripherals, you are only interested in
simple api esp_periph_init, esp_periph_start, esp_periph_stop and esp_periph_destroy. If
you want to integrate new peripherals, please refer to Periph Button source code

Examples

Please refer to player/pipeline_http_mp3/main/play_http_mp3_example.c.

API Reference

Header File

» components/esp_peripherals/include/esp_peripherals.h
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Functions

esp_periph_set_handle_t esp_periph_set_init (esp_periph_config_t *config)
Initialize esp_peripheral sets, create empty peripherals list. Call this function before starting any peripherals
(with esp_periph_start). This call will initialize the data needed for esp_peripherals to work, but does
not actually create the task. The event_handle is optional if you want to receive events from this call-
back function. The esp_peripherals task will send all events out to event_iface, can be listen by event_iface by
esp_periph_get_event_iface. The user_context will sent esp_periph_event_handle_t
as *context parameter.

%% config —[in] The configurations
7& 0] The peripheral sets instance

esp_err_t esp_periph_set_destroy (esp_periph_set_handle_t periph_set_handle)

This function will stop and kill the monitor task, calling all destroy callback functions of the peripheral (so you do
not need to destroy the peripheral object manually). It will also remove all memory allocated to the peripherals list,
so you need to call the esp_periph_set_init function again if you want to use it.

%%, periph_set_handle —The esp_periph_set_handle_t instance
Bl

* ESP_OK

* ESP_FAIL

esp_err_t esp_periph_set_stop_all (esp_periph_set_handle_t periph_set_handle)

Stop monitoring all peripherals, the peripheral state is still kept. This funciton only temporary disables the periph-
eral.

%% periph_set_handle —The esp_periph_set_handle_t instance

A
* ESP_OK
» ESP_FAIL

esp_periph_handle_t esp_periph_set_get_by_id (esp_periph_set_handle_t periph_set_handle, int periph_id)
Get the peripheral handle by Peripheral ID.

S8

* periph_set_handle —The esp_periph_set_handle_t instance

* periph_id —[in] as esp_periph_id t, or any ID you wuse when -calling
esp_periph_create

&M The esp_periph_handle_t

audio_event_iface_handle_t esp_periph_set_get_event_iface (esp_periph_set_handle_t
periph_set_handle)

Return the event_iface used by this esp_peripherals.
%4 periph_set_handle —The esp_periph_set_handle_t instance
J&[n] The audio event iface handle

esp_err_t esp_periph_set_register_callback (esp_periph_set_handle_t periph_set_handle,
esp_periph_event_handle_t cb, void *user_context)

Register peripheral sets event callback function.
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S8
* periph_set_handle —The esp_periph_set_handle_t instance
* cb —The event handle callback function
* user_context —The user context pointer
&Ml
* ESP_OK
* ESP_FAIL

QueueHandle_t esp_periph_set_get_queue (esp_periph_set_handle_t periph_set_handle)

Peripheral is using event_iface to control the event, all events are send out to event_iface queue. This function will
be useful in case we want to read events directly from the event_iface queue.

%% periph_set_handle -The esp_periph_set_handle_t instance
& Ia] The queue handle

esp_err_t esp_periph_set_list_init (esp_periph_set_handle_t periph_set_handle)
Call this function to initialize all the listed peripherals.

2412 Work with no task peripheral set only

%4 periph_set_handle —The esp_periph_set_handle_t instance
B

* ESP_OK

* ESP_FAIL

esp_err_t esp_periph_set_list_run (esp_periph_set_handle_t periph_set_handle, audio_event_iface_msg_t
msg)

Call this function to run all the listed peripherals.

2412 Work with no task peripheral set only

S
* periph_set_handle —The esp_periph_set_handle_t instance
* msg —The audio_event_iface_msg_t handle message

B

ESP_OK
* ESP_FAIL

esp_err_t esp_periph_set_list_destroy (esp_periph_set_handle_t periph_set_handle)
Call this function to destroy all the listed peripherals.

#1#: Work with no task peripheral set only
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%% periph_set_handle —The esp_periph_set_handle_t instance
A
» ESP_OK
* ESP_FAIL
esp_err_t esp_periph_remove_from_set (esp_periph_set_handle_t periph_set_handle, esp_periph_handle_t
periph)
Call this function to remove periph from periph_set.
S8
* periph_set_handle —The esp_periph_set_handle_t instance
* periph —The esp_periph_handle_t instance
Bl
* ESP_OK
* ESP_FAIL

esp_err_t esp_periph_alloc_periph_id (esp_periph_set_handle_t periph_set_handle, int *periph_id)
Allocated a peripheral ID from the periph_set.

512 This function can apply for a peripheral ID to realize a customized peripheral module. The requested
peripheral ID will not be included in esp_periph_id_t

S8
* periph_set_handle —[in] The esp_periph_set_handle_t instance
* periph_id —[out] The peripheral identifier

Bl
* ESP_OK
* ESP_FAIL

esp_err_t esp_periph_set_change_waiting_time (esp_periph_set_handle_t periph_set_handle, int
time_ms)
Call this function to change periph_set waiting time.

S
* periph_set_handle —The esp_periph_set_handle_t instance
* time_ms —The waiting time

A
* ESP_OK
* ESP_FAIL

esp_periph_handle_t esp_periph_create (int periph_id, const char *tag)
Call this function to initialize a new peripheral.

S
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* periph_id —[in] The periph identifier
* tag —[in] The tag name, we named it easy to get in debug logs
j& 1] The peripheral handle

esp_err_t esp_periph_set_function (esp_periph_handle_t periph, esp_periph_func init, esp_periph_run_func
run, esp_periph_func destroy)

Each peripheral has a cycle of sequential operations from initialization, execution of commands to destroying the
peripheral. These operations are represented by functions passed as call parameters to this function.

S8

* periph —[in] The periph

e init —[in] The initialize

e run —[in] The run

* destroy —[in] The destroy
A

* ESP_OK

» ESP_FAIL

esp_err_t esp_periph_start (esp_periph_set_handle_t periph_set_handle, esp_periph_handle_t periph)
Add the peripheral to peripherals list, enable and start monitor task (if task stack size > 0)

#&1¥: This peripheral must be first created by calling esp_periph_create

BH
* periph_set_handle —[in] The esp_periph_set_handle_t instance
» periph —[in] The peripheral instance

B
¢ ESP_OK on success

ESP_FAIL when any errors

esp_err_t esp_periph_stop (esp_periph_handle_t periph)

Stop monitoring the peripheral, the peripheral state is still kept. This funciton only temporary disables the periph-
eral.

%% periph —[in] The periph
Bl

 ESP_OK

» ESP_FAIL

esp_err_t esp_periph_send_cmd (esp_periph_handle_t periph, int cmd, void *data, int data_len)

When this function is called, the command is passed to the event_iface command queue, and the
esp_periph_run_func of this peripheral will be executed in the main peripheral task. This function can
be called from any task, basically it only sends a queue to the main peripheral task.

ZH
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» periph —[in] The periph

¢ cmd —[in] The command

* data The data

* data_1len —[in] The data length
&Ml

* ESP_OK

» ESP_FAIL

esp_err_t esp_periph_send_cmd_from_isr (esp_periph_handle_t periph, int cmd, void *data, int data_len)

Similar to esp_periph_send_cmd, but it can be called in the hardware interrupt handle.
S
* periph —[in] The periph

cmd —[in] The command

* data The data

data_len —[in] The data length
B

* ESP_ OK

» ESP_FAIL

esp_err_t esp_periph_send_event (esp_periph_handle_t periph, int event_id, void *data, int data_len)

In addition to sending an event via event_iface, this function will dispatch the event_handle callback if the
event_handle callback is provided at esp_periph_init

S8

» periph —[in] The peripheral

e event_id —{in] The event identifier

* data The data

* data_len —[in] The data length
Bl

* ESP_OK

» ESP_FAIL

esp_err_t esp_periph_start_timer (esp_periph_handle_t periph, TickType_t interval_tick, fimer_callback
callback)

Each peripheral can initialize a timer, which is by default NULL. When this function is called, the timer for the
peripheral is created and it invokes the callback function every interval tick.

i

* You do not need to stop or destroy the timer, when the esp_periph_destroy function is called, it will
stop and destroy all

¢ This timer using FreeRTOS Timer, with autoreload = true
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SH
* periph —[in] The peripheral
e interval_tick —[in] The interval tick

* callback —[in] The callback
P[]

ESP_OK
» ESP_FAIL

esp_err_t esp_periph_stop_timer (esp_periph_handle_t periph)
Stop peripheral timer.

%% periph —[in] The peripheral
Bl

 ESP_OK

* ESP_FAIL

esp_err_t esp_periph_set_data (esp_periph_handle_t periph, void *data)
Set the user data.

$411:: Make sure the dat a lifetime is sufficient, this function does not copy all data, it only stores the data pointer

SH
* periph —[in] The peripheral
* data -The data
B
* ESP_OK
* ESP_FAIL

void *esp_periph_get_data (esp_periph_handle_t periph)
Get the user data stored in the peripheral.

%% periph -[in] The peripheral
j& 0] Peripheral data pointer

esp_periph_state_t esp_periph_get_state (esp_periph_handle_t periph)
Get the current state of peripheral.

%4 periph —[in] The handle of peripheral
j& 1] The peripharal working state

esp_periph_id_t esp_periph_get_id (esp_periph_handle_t periph)
Get Peripheral identifier.

%% periph —[in] The peripheral
j& 8] The peripheral identifier
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esp_err_t esp_periph_set_id (esp_periph_handle_t periph, esp_periph_id_t periph_id)
Set Peripheral identifier.

BH

* periph —[in] The peripheral

* periph_id —[in] The peripheral identifier
Bl

* ESP_OK

» ESP_FAIL

esp_err_t esp_periph_init (esp_periph_handle_t periph)
Call this to execute init function of peripheral instance.

%%t periph —The peripheral handle
B M

* ESP_OK

* ESP_FAIL

esp_err_t esp_periph_run (esp_periph_handle_t periph)

Call this to execute run function of peripheral instance.
%% periph —The peripheral handle
R
* ESP_OK
» ESP_FAIL
esp_err_t esp_periph_destroy (esp_periph_handle_t periph)

Call this to execute dest roy function of peripheral instance.
%% periph —The peripheral handle
&
» ESP_OK
» ESP_FAIL

esp_err_t esp_periph_register_on_events (esp_periph_handle_t periph, esp_periph_event t *evts)

Rigster peripheral on event handle.
BH
* periph —The peripheral handle
» evts —The esp_periph_event_t handle
B M
* ESP_OK
ESP_FAIL
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Structures

struct esp_periph_config t

Common peripherals configurations.

Public Members

int task_stack

>0 Service task stack size; =0 without task created

int task_prio
Service task priority (based on freeRTOS priority)

int task_core

Service task running in core (0 or 1)

bool extern_stack

Service task stack allocate on extern ram

struct esp_periph_event

peripheral events

Public Members

void *user_ctx

peripheral context data

esp_periph_event_handle_t cb

peripheral callback function

audio_event_iface_handle_t iface

peripheral event

Macros

DEFAULT_ESP_PERIPH_STACK_SIZE

DEFAULT_ESP_PERIPH_TASK_PRIO

DEFAULT_ESP_PERIPH_TASK CORE

DEFAULT_ESP_PERIPH_SET_CONFIG ()
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periph_tick_get

Type Definitions

typedef struct esp_periph_sets *esp_periph_set_handle_t

typedef struct esp_periph *esp_periph_handle_t

typedef esp_err_t (*esp_periph_func)(esp_periph_handle_t periph)

typedef esp_err_t (*esp_periph_run_func)(esp_periph_handle_t periph, audio_event_iface_msg_t *msg)

typedef esp_err_t (*esp_periph_event_handle_t)(audio_event_iface_msg_t *event, void *context)

typedef void (*timer_callback)(xTimerHandle tmr)

typedef struct esp_periph_event esp_periph_event_t

peripheral events

Enumerations

enum esp_periph_id_t
Peripheral Identify, this must be unique for each peripheral added to the peripherals list.

Values:

enumerator PERIPH_ID_BUTTON

enumerator PERIPH_ID_TOUCH

enumerator PERIPH_ID_SDCARD

enumerator PERIPH_ID_WIFI

enumerator PERIPH_ID_FLASH

enumerator PERIPH_ID_AUXIN

enumerator PERIPH_ID_ADC

enumerator PERIPH_ID_CONSOLE
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enumerator PERIPH_ID_BLUETOOTH

enumerator PERIPH_ID_LED

enumerator PERIPH_ID_SPIFFS

enumerator PERIPH_ID_ADC_BTN

enumerator PERIPH_ID_IS31FL3216

enumerator PERIPH_ID_GPIO_ISR

enumerator PERIPH_ID_WS2812

enumerator PERIPH_ID_AW2013

enumerator PERIPH_ID_LCD

enumerator PERIPH_ID_CUSTOM_BASE

enum esp_periph_state_t

Peripheral working state.

Values:

enumerator PERIPH_STATE_NULL

enumerator PERIPH_STATE_INIT

enumerator PERIPH_STATE_RUNNING

enumerator PERIPH_STATE_PAUSE

enumerator PERIPH_STATE_STOPPING

enumerator PERIPH_STATE_ERROR

enumerator PERIPH_STATE_STATUS_MAX

The peripheral specific functionality is available by calling dedicated functions described below. Some peripherals are
available on both ESP32-LyraT and ESP32-LyraTD-MSC development boards, some on a specific board only. The fol-
lowing table provides all implemented peripherals broken down by development board.
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2.8.2 Wi-Fi Peripheral

The Wi-Fi Peripheral is used to configure Wi-Fi connections, provide APIs to control Wi-Fi connection configuration,
as well as monitor the status of Wi-Fi networks.

Application Example

Implementation of this API is demonstrated in player/pipeline_http_mp3 example.
API Reference
Header File
¢ components/esp_peripherals/include/periph_wifi.h
Functions

esp_periph_handle_t periph_wifi_init (periph_wifi_cfg_t *config)
Create the wifi peripheral handle for esp_peripherals.

£41:: The handle was created by this function automatically destroy when esp_periph_destroy is called

%% config —The configuration
j&[a] The esp peripheral handle

esp_err_t periph_wifi_wait_for_connected (esp_periph_handle_t periph, TickType_t tick_to_wait)

This function will block current thread (in tick_to_wait tick) and wait until ESP32 connected to the Wi-Fi
network, and got ip.

S

* periph —[in] The periph

e tick_to_wait —[in] The tick to wait
Bl

* ESP_OK

* ESP_FAIL

periph_wifi_state_t periph_wifi_is_connected (esp_periph_handle_t periph)
Check the Wi-Fi connection status.

%%, periph —[in] The periph
&l Wi-Fi network status

esp_err_tesp_wifi_set_listen_interval (esp_periph_handle_t periph, int interval)

Set Wi-Fi listen interval for ESP32 station to receive beacon.

BH
* periph —[in] The wifi periph
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e interval —[in] listen interval. units: AP beacon intervals(see Benlnt, default: 100ms)
B

* ESP_OK

» ESP_FAIL

esp_err_t periph_wifi_config_start (esp_periph_handle_t periph, periph_wifi_config_mode_t mode)

Start Wi-Fi network setup in mode
BH
* periph —[in] The periph
¢ mode —[in] The mode
R M
* ESP_OK
» ESP_FAIL

esp_err_t periph_wifi_config_wait_done (esp_periph_handle_t periph, TickType_t tick_to_wait)
Wait for Wi-Fi setup done.

S
* periph —[in] The periph
e tick_to_wait —[in] The tick to wait

B

ESP_OK
» ESP_FAIL

Structures

struct periph_wpa2_enterprise_cfg_t
The WPA?2 enterprise peripheral configuration.

Public Members

bool diasble_wpa2_e

Disable wpa?2 enterprise

int eap_method
TLS: 0, PEAP: 1, TTLS: 2

char *ca_pem_start

binary wpa2 ca pem start

char *ca_pem_end

binary wpa2 ca pem end
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char *wpa2_e_cert_start

binary wpa?2 cert start

char *wpa2_e_cert_end

binary wpa?2 cert end

char *wpa2_e_key_start
binary wpa?2 key start

char *wpa2_e_key_end
binary wpa2 key end

const char *eap_id

Identity in phase 1 of EAP procedure

const char *eap_username
Username for EAP method (PEAP and TTLS)

const char *eap_password
Password for EAP method (PEAP and TTLS)

struct periph_wifi_cfg_t
The Wi-Fi peripheral configuration.

Public Members

bool disable_auto_reconnect

Disable Wi-Fi auto reconnect

int reconnect_timeout_ms

The reconnect timeout after disconnected from Wi-Fi network

wifi_config_twifi_config

Wifi configure

periph_wpa?2_enterprise_cfg_t wpa2_e_cfg

wpa?2 enterprise config
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Enumerations

enum periph_wifi_state_t

Peripheral Wi-Fi event id.

Values:

enumerator PERIPH_WIFI_UNCHANGE

enumerator PERIPH_WIFI_CONNECTING

enumerator PERIPH_WIFI_CONNECTED

enumerator PERIPH_WIFI_DISCONNECTED

enumerator PERIPH_WIFI_SETTING

enumerator PERIPH_WIFI_CONFIG_DONE

enumerator PERIPH_WIFI_CONFIG_ERROR

enumerator PERIPH_WIFI_ERROR

enum periph_wifi_config_mode_t

Wi-Fi setup mode type.

Values:

enumerator WIFI_CONFIG_ESPTOUCH
Using smartconfig with ESPTOUCH protocol

enumerator WIFI_CONFIG_AIRKISS
Using smartconfig with AIRKISS protocol

enumerator WIFI_CONFIG_ESPTOUCH_AIRKISS
Using smartconfig with ESPTOUCH_AIRKISS protocol

enumerator WIFI_CONFIG_WPS
Using WPS (not support)

enumerator WIFI_CONFIG_BLUEFI
Using BLUEFI

enumerator WIFI_CONFIG_WEB
Using HTTP Server (not support)
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2.8.3 SD Card Peripheral

If your board has a SD card connected, use this API to initialize, mount and unmount the card, see functions
periph_sdcard_init (),periph_sdcard_mount () and periph_sdcard_unmount (). The data read-
ing / writing is implemented in a separate API described in FutFys 7.

Application Examples

Implementation of this API is demonstrated in couple of examples:
* player/pipeline_play_sdcard_music
* player/pipeline_sdcard_mp3_control
* recorder/pipeline_recording_to_sdcard
* recorder/pipeline_wav_amr_sdcard

API Reference

Header File

» components/esp_peripherals/include/periph_sdcard.h

Functions

esp_periph_handle_t periph_sdcard_init (periph_sdcard_cfg_t *sdcard_config)
Create the sdcard peripheral handle for esp_peripherals.

£41:: The handle was created by this function automatically destroy when esp_periph_destroy is called

%% sdcard_config -The sdcard configuration
&[0l The esp peripheral handle

bool periph_sdcard_is_mounted (esp_periph_handle_t periph)

Check the sdcard is mounted or not.
%% periph —[in] The periph
&k SDCARD mounted state

Structures

struct periph_sdcard_cfg_t
The SD Card Peripheral configuration.
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Public Members

int card_detect_pin

Card detect gpio number

const char *root

Base path for vfs

periph_sdcard_mode_t mode

card mode

Enumerations

enum periph_sdcard_event_id_t
Peripheral sdcard event id.

Values:

enumerator SDCARD_STATUS__UNKNOWN

No event

enumerator SDCARD_STATUS_CARD_DETECT_CHANGE

Detect changes in the card_detect pin

enumerator SDCARD_STATUS_MOUNTED
SDCARD mounted successfully

enumerator SDCARD_STATUS_UNMOUNTED
SDCARD unmounted successfully

enumerator SDCARD_STATUS_MOUNT_ERROR
SDCARD mount error

enumerator SDCARD_STATUS_UNMOUNT_ERROR
SDCARD unmount error

enum periph_sdcard_mode_t
SD card mode, SPI, 1-line SD mode, 4-line SD mode.

Values:

enumerator SD_MODE_SPI
sd_card SPI

enumerator SD_MODE_1_LINE
sd_card 1-line SD mode
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enumerator SD_MODE_4_LINE
sd_card 4-line SD mode

enumerator SD_MODE_8_LINE
sd_card 8-line SD mode

enumerator SD_MODE_MAX

2.8.4 Spiffs Peripheral

Use this API to initialize, mount and unmount spiffs partition, see functions periph spiffs_init (),
periph_spiffs_mount () and periph_spiffs_unmount (). The data reading / writing is implemented in a
separate API described in SPIFFS 7.

Application Example

Implementation of this API is demonstrated in audio_processing/pipeline_spiffs_amr_resample example.

APl Reference

Header File

» components/esp_peripherals/include/periph_spifts.h

Functions

esp_periph_handle_t periph_spiffs_init (periph_spiffs_cfe_t *spiffs_config)
Create the spiffs peripheral handle for esp_peripherals.

£57¥: The handle created by this function will be automatically destroyed when esp_periph_destroy is
called

%% spiffs_config The spiffs configuration
& I0] The esp peripheral handle
bool periph_spiffs_is_mounted (esp_periph_handle_t periph)
Check if the SPIFFS is mounted or not.
%%, periph —[in] The periph
j&Ia] SPIFFS mounted state
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Structures

struct periph_spiffs_cfg t
The SPIFFS Peripheral configuration.

Public Members

const char *root

Base path for vfs

const char *partition_label

Optional, label of SPIFFS partition to use. If set to NULL, first partition with subtype=spiffs will be used.

size_ tmax_files

Maximum number of files that could be open at the same time.

bool format_if mount_failed

If true, it will format the file system if it fails to mount.

Enumerations

enum periph_spiffs_event_id_t
Peripheral spiffs event id.

Values:

enumerator SPIFFS__STATUS_UNKNOWN

No event

enumerator SPIFFS_STATUS_MOUNTED
SPIFFS mounted successfully

enumerator SPIFFS_STATUS_UNMOUNTED
SPIFFS unmounted successfully

enumerator SPIFFS_STATUS_MOUNT_ERROR
SPIFFS mount error

enumerator SPIFFS_STATUS_UNMOUNT_ERROR

SPIFFS unmount error
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2.8.5 Console Peripheral

Console Peripheral is used to control the Audio application from the terminal screen. It provides 2 ways do execute
command, one sends an event to esp_peripherals (for a command without parameters), another calls a callback function

(need parameters). If there is a callback function, no event will be sent.

Please make sure that the lifetime of periph console cmd_t must be ensured during console operation,

periph_console_init () only reference, does not make a copy.

Code example

Please refer to cli/main/console_example.c.

API Reference

Header File

e components/esp_peripherals/include/periph_console.h

Functions

esp_periph_handle_t periph_console_init (periph_console_cfg_t *config)

Initialize Console Peripheral.
%% config —The configuration
&M The esp peripheral handle

Structures

struct periph_console_cmd_t

Command structure.

Public Members

const char *cmd
Name of command, must be unique
int id
Command ID will be sent together when the command is matched

const char *help

Explanation of the command

console_cmd_callback_t £une

Function callback for the command

2.8. Peripherals
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struct periph_console_cfg_t

Console Peripheral configuration.

Public Members

int command_num

Total number of commands

const periph_console_cmd_t *commands

Pointer to array of commands

int task_stack

Console task stack, using default if the value is zero

int task_prio

Console task priority (based on freeRTOS priority), using default if the value is zero

intbuffer_size

Size of console input buffer

const char *prompt_string
Console prompt string, using default CONSOLE_PROMPT_STRING if the pointer is NULL

Macros

CONSOLE_DEFAULT_TASK_PRIO

CONSOLE_DEFAULT_TASK_STACK

CONSOLE_DEFAULT_BUFFER_SIZE

CONSOLE_DEFAULT_PROMPT_STRING

Type Definitions

typedef esp_err_t (*console_cmd_callback_t)(esp_periph_handle_t periph, int arge, char *argv([])
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2.8.6 Touch Peripheral

Initialize ESP32 touchpad peripheral and retrieve information from the touch sensors.

Application Example

Implementation of this API is demonstrated in get-started/play_mp3_control example.
API Reference
Header File

» components/esp_peripherals/include/periph_touch.h

Functions

esp_periph_handle_t periph_touch_init (periph_touch_cfg_t *config)
Create the touch peripheral handle for esp_peripherals.

£41:: The handle was created by this function automatically destroy when esp_periph_destroy is called

%% config —The configuration
&1l The esp peripheral handle

Structures

struct periph_touch_cfg_t

The Touch peripheral configuration.

Public Members

int touch_mask
Touch pad mask using for this Touch peripheral, ex: TOUCH_PAD_SELO | TOUCH_PAD_SEL1

int tap_threshold_percent

Tap threshold percent, Tap event will be determined if the percentage value is less than the non-touch value

int long_tap_time_ms

Long tap duration in milliseconds, default is 2000ms, PERIPH_TOUCH_LONG_TAP will be occurred if
TAP and time hold longer than this value
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Enumerations

enum esp_touch_pad_sel_t

Touch pad selection.

Values:

enumerator TOUCH_PAD_SELO

enumerator TOUCH_PAD_SEL1

enumerator TOUCH_PAD_SEL2

enumerator TOUCH_PAD_SEL3

enumerator TOUCH_PAD_SEL4

enumerator TOUCH_PAD_SELS

enumerator TOUCH_PAD_SEL®6

enumerator TOUCH_PAD_SEL7

enumerator TOUCH_PAD_SELS8

enumerator TOUCH_PAD_SEL9

enum periph_touch_event_id_t
Peripheral touch event id.

Values:

enumerator PERIPH_TOUCH_UNCHANGE

No event

enumerator PERIPH_TOUCH_TAP
When touch pad is tapped

enumerator PERIPH_TOUCH_RELEASE
When touch pad is released after tap

enumerator PERIPH_TOUCH_LONG_TAP
When touch pad is tapped and held after 1long_tap_time_ms time

enumerator PERIPH_TOUCH_LONG_RELEASE
When touch pad is released after long tap
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2.8.7 Button Peripheral

To control application flow you may use buttons connected and read through the ESP32 GPIOs. This API provides
functions to initialize specific GPIOs and obtain information on button events such as when it has been pressed, when
released, when pressed for a long time and released after long press. To get information on a particular event, establish a
callback function with button_dev_add_tap_cb () orbutton_dev_add_press_cb ().

Application Example

Implementation of this API is demonstrated in cloud_services/google_translate_device example.
API Reference
Header File

» components/esp_peripherals/include/periph_button.h

Functions

esp_periph_handle_t periph_button_init (periph_button_cfg_t *but_cfg)
Create the button peripheral handle for esp_peripherals.

£41:: The handle was created by this function automatically destroy when esp_periph_destroy is called

%4 but_c£fg —The but configuration
j& 1] The esp peripheral handle

Structures

struct periph_button_cfg_t

The Button peripheral configuration.

Public Members

uint64_t gpio_mask
GPIO Mask using for this Button peripheral, it is BIT(GPIO_NUM), ex: GPIO_SEL_36 | GPIO_SEL_36

int long_press_time_ms

Long press duration in milliseconds, default is 2000ms
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Enumerations

enum periph_button_event_id_t
Peripheral button event id.

Values:

enumerator PERIPH_BUTTON_UNCHANGE

No event

enumerator PERIPH_BUTTON_PRESSED
When button is pressed

enumerator PERIPH_BUTTON_RELEASE

When button is released

enumerator PERIPH_BUTTON_LONG_PRESSED

When button is pressed and kept for more than long_press_time_ms

enumerator PERIPH_BUTTON_LONG_RELEASE
When button is released and event PERIPH_BUTTON_LONG_PRESSED happened

2.8.8 LED Peripheral

Blink or fade a LED connected to a GPIO with configurable On and Off times.

Application Examples

Implementation of this API is demonstrated in couple of examples:
* /cloud_services/google_translate_device

¢ /dueros

API Reference

Header File

e components/esp_peripherals/include/periph_led.h
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Functions

esp_periph_handle_t periph_led_init (periph_led_cfg_t *config)
Create the LED peripheral handle for esp_peripherals.

#41:: The handle was created by this function automatically destroy when esp_periph_destroy is called

%% config —The configuration
7R [1] The esp peripheral handle

esp_err_t periph_led_blink (esp_periph_handle_t periph, int gpio_num, int time_on_ms, int time_off _ms, bool
fade, int loop, periph_led_idle_level_t level)

Bink LED Peripheral, this function will automatically configure the gpio_num to control the LED, with
time_on_ms as the time (in milliseconds) switch from OFF to ON (or ON if fade is disabled), and
time_off_ms as the time (in milliseconds) switch from ON to OFF (or OFF if fade is disabled). When switch-
ing from ON -> OFF and vice versa, the loop decreases once, and will turn off the effect when the loop is 0. With
a loop value less than 0, the LED effect will loop endlessly. PERIPH_LED_BLINK_FINISH events will be sent
at each end of loop.

S8
* periph —[in] The LED periph
* gpio_num —[in] The gpio number
* time_on_ms —[in] The time on milliseconds
* time_off_ms [in] The time off milliseconds
» fade —[in] Fading enabled
* loop —[in] Loop
¢ level —[in] idle level
Bl
» ESP_OK
» ESP_FAIL

esp_err_t periph_led_stop (esp_periph_handle_t periph, int gpio_num)
Stop Blink the LED.

BH

» periph —[in] The periph

* gpio_num -[in] The gpio number
R M

* ESP_OK
ESP_FAIL
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Structures

struct periph_led_cfg_t
The LED peripheral configuration.

Public Members
ledc_mode_t 1ed_speed_mode
LEDC speed speed_mode, high-speed mode or low-speed mode

ledc_timer_bit_t led_duty_resolution

LEDC channel duty resolution

ledc_timer_t 1led_timer_ num

Select the timer source of channel (0 - 3)

uint32_t led_freq hz
LEDC timer frequency (Hz)

int gpio_num

Optional, < 0 invalid gpio number

Enumerations

enum periph_led_event_id_t
Peripheral LED event id.

Values:

enumerator PERIPH_LED_UNCHANGE

No event

enumerator PERIPH_LED_BLINK_FINISH
When LED blink is finished

enum periph_led_idle_level_t
Peripheral LED idle output level.

Values:

enumerator PERIPH_LED_IDLE_LEVEL_LOW

Low level output

enumerator PERIPH_LED_IDLE_LEVEL_HIGH
High level output
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2.8.9 ADC Button Peripheral

Read status of buttons connected to an ADC input using a resistor ladder. Configuration provides for more than a singe
ADC input to read several sets of buttons. For an example hardware implementation please refer to schematic of ESP32-
LyraTD-MSC V2.2 Upper Board (PDF).

Application Examples

Implementation of this API is demonstrated in the following example:

¢ checks/check_board_buttons
API Reference
Header File

e components/esp_peripherals/include/periph_adc_button.h

Functions

esp_periph_handle_t periph_adec_button_init (periph_adc_button_cfg_t *btn_cfg)
Create the button peripheral handle for esp_peripherals.

£41:: The handle created by this function is automatically destroyed when esp_periph_destroy is called.

%4 btn_c£fg —The button configuration.
j& 1] The esp peripheral handle.

Structures

struct periph_adc_button_cfg_t
The configuration of ADC Button.

Public Members

adc_arr_t *arr

An array with configuration of buttons

intarr_size

The array size

adc_btn_task_cfg ttask_cfg

Adc button task configuration
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Macros

ADC_BUTTON_STACK_SIZE
ADC_BUTTON_TASK_PRIORITY

ADC_BUTTON_TASK_CORE_ID
PERIPH_ADC_BUTTON_DEFAULT_ CONFIG ()

ADC_DEFAULT_ARR ()

ESP32 ADCI channels and GPIO table ADC1_CHANNEL_O - GPIO36 ADC1_CHANNEL_1 - GPIO37
ADC1_CHANNEL_2 - GPIO38 ADCI_CHANNEL_3 - GPIO39 ADCI_CHANNEL 4 - GPIO32
ADCI_CHANNEL_S - GPIO33 ADC1_CHANNEL_6 - GPI034 ADC1_CHANNEL_7 - GPIO35

Enumerations

enum periph_adc_button_event_id_t

Values:

enumerator PERIPH_ADC_BUTTON_IDLE

enumerator PERIPH_ADC_BUTTON_PRESSED
enumerator PERIPH_ADC_BUTTON_RELEASE
enumerator PERIPH_ADC_BUTTON_LONG_PRESSED

enumerator PERIPH_ADC_BUTTON_LONG_RELEASE

2.8.10 LED Controller Peripheral

This peripheral is applicable to IS31FI3216 chip that is a light LED controller with an audio modulation
mode. It can store data of 8 Frames with internal RAM to play small animations automatically.  You
can also use it to control a number of LEDs connected to GPIOs. If you want to use the IS31FI3216,
see functions periph 1s31f13216_1init (), periph_1s31f13216_set_blink_pattern(),
periph_1s31f13216_set_duty (), periph_1s31f13216_set_state().
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Application Examples

Implementation of this API is demonstrated in checks/check_display_led example.

API Reference

Header File

» components/esp_peripherals/include/periph_is31f13216.h

Functions

esp_periph_handle_t periph_is31£13216_init (periph_is31f13216_cfg_t *is31f13216_config)
Initializate the is31f13216.

%4 is31£13216_config-—
Bl

e ESP_OK Success

» ESP_FAIL Fail

esp_err_t periph_is31£13216_set_state (esp_periph_handle_t periph, periph_is31f13216_state_t state)
Set the state of all the channels.

S8
e periph —The is31f13216 handle
» state —The state of all channels
B
* ESP_OK Success
» ESP_FAIL Fail

esp_err_t periph_is31£13216_set_blink_pattern (esp_periph_handle_t periph, uint16_t blink_pattern)
Set the current enable channels.

BH

* periph —The is31f13216 handle

* blink_pattern —The bit pattern of enabled channels
B M

¢ ESP_OK Success

* ESP_FAIL Fail

esp_err_t periph_is31£13216_set_duty (esp_periph_handle_t periph, uint8_t index, uint8_t value)
Set the duty of the channel.

S
e periph —The is31f13216 handle

¢ index —The channel number
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* value —The value of the channel’ s duty to be set
B

* ESP_OK Success

» ESP_FAIL Fail

esp_err_t periph_is31£13216_set_duty_step (esp_periph_handle_t periph, uint8_t step)
Set the duty step of flash.

S8
e periph —The is31f13216 handle
» step —The step of flash
Bl
¢ ESP_OK Success
* ESP_FAIL Fail

esp_err_t periph_is31£13216_set_interval (esp_periph_handle_t periph, uint16_t interval_ms)
Set the internval time.

S8
* periph —The is31f13216 handle
* interval_ms —Time of interval

B

ESP_OK Success
¢ ESP_FAIL Fail

esp_err_t periph_is31£13216_set_shift_mode (esp_periph_handle_t periph, periph_is31_shift_mode_t
mode)

Set the shift mode.
S8
e periph —The is31f13216 handle
* mode —Mode of periph_is31_shift_mode_t
Bl
e ESP_OK Success
» ESP_FAIL Fail

esp_err_t periph_is31£13216_set_light_on_num (esp_periph_handle_t periph, uint16_t light_on_num,
uint16_t max_light_num)

Set the light on numbers.
S8
* periph —The is31f13216 handle
e light_on_num —Enabled led number

* max_light_num -Maximum led number

B
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* ESP_OK Success
¢ ESP_FAIL Fail

esp_err_t periph_is31£13216_set_act_time (esp_periph_handle_t periph, uint16_t act_ms)
Set the action time.

S
e periph —The is31f13216 handle
* act_ms —Action time, unit is millisecond, 0 is infinite

B

ESP_OK Success
ESP_FAIL Fail

Structures

struct periph_is31£13216_cfg_t
The configuration of is31f13216.

Public Members

uint32_t duty[IS31FL3216_CH_NUM]
An array of the is31f13216° s duty

uintl6_t is31£13216_pattern

Current enable channel

periph_is31f13216_state_t state
The state of all the channels

Macros

IS31FL3216_CH_NUM

BLUE_LED_MAX_NUM
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Enumerations

enum periph_is31£13216_state_t

Values:

enumerator IS31FL3216_STATE_UNKNOWN

enumerator IS31FL3216_STATE_OFF

enumerator IS31FL3216_STATE_ON

enumerator IS31FL3216_STATE_FLASH

enumerator IS31FL3216_STATE_BY_AUDIO

enumerator IS31FL3216_STATE_SHIFT

enum periph_is31_shift_mode_t

Values:

enumerator PERIPH_IS31_SHIFT_MODE_UNKNOWN

enumerator PERIPH_IS31_SHIFT_MODE_ACC

accumulation mode

enumerator PERIPH_IS31_SHIFT_MODE_SINGLE

Name of Peripheral | ESP32-LyraT | ESP32-LyraTD-MSC

Wi-Fi

SD Card

Spiffs

Console

SNNSNS

Touch

Button

NN NSNSNSNS

LED

ADC Button

NS

LED Controller
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2.9 Abstraction Layer

2.9.1 Ring Buffer

Ringbuffer is designed in addition to use as a data buffer, also used to connect Audio Elements. Each Element that requests
data from the Ringbuffer will block the task until the data is available. Or block the task when writing data and the Buffer
is full. Of course, we can stop this block at any time.

File Ring MP3 Ring 125

Reader buffer Decoder buffer Writer

&l 7: Ring Buffer used in Audio Pipeline

Application Example

In most of ESP-ADF examples connecting of Elements with Ringbuffers is done “behind the scenes” by a function
audio_pipeline_1link (). To see this operation exposed check player/pipeline_sdcard_mp3_control example.

API Reference

Header File

» components/audio_pipeline/include/ringbuf.h

Functions

ringbuf _handle_t rb_create (int block_size, int n_blocks)

Create ringbuffer with total size = block_size * n_blocks.
S
* block_size —[in] Size of each block
e n_blocks —[in] Number of blocks
iR H] ringbuf_handle_t

esp_err_t rb_destroy (ringbuf_handle_t 1b)
Cleanup and free all memory created by ringbuf _handle_t.

%%; rb —[in] The Ringbuffer handle
Bl

« ESP_OK

» ESP_FAIL
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esp_err_t rb_abort (ringbuf_handle_t tb)

Abort waiting until there is space for reading or writing of the ringbuffer.
%% rb —[in] The Ringbuffer handle
A
» ESP_OK
» ESP_FAIL

esp_err_t rb_reset (ringbuf_handle_t tb)

Reset ringbuffer, clear all values as initial state.
%% rb [in] The Ringbuffer handle
A
* ESP_OK
» ESP_FAIL

esp_err_t rb_reset_is_done_write (ringbuf_handle_t tb)

Reset is_done_write flag.
%% rb [in] The Ringbuffer handle
&I
* ESP_OK
» ESP_FAIL

int rb_bytes_available (ringbuf_handle_t tb)
Get total bytes available of Ringbuffer.

%%, rb —[in] The Ringbuffer handle
J&\] total bytes available

int rb_bytes_filled (ringbuf_handle_t 1b)
Get the number of bytes that have filled the ringbufter.

%% rb —[in] The Ringbuffer handle
j&[a] The number of bytes that have filled the ringbuffer

int rb_get_size (ringbuf _handle_t rb)
Get total size of Ringbuffer (in bytes)

%4 rb —[in] The Ringbuffer handle
1R[] total size of Ringbuffer

int rb_read (ringbuf_handle_t 1b, char *buf, int len, TickType_t ticks_to_wait)

Read from Ringbuffer to bu f with len and wait t ick_to_wait ticks until enough bytes to read if the ringbuffer
bytes available is less than len. If buf argument provided is NULL, then ringbuffer do pseudo reads by simply
advancing pointers.

B8
* rb —[in] The Ringbuffer handle
* buf —The buffer pointer to read out data

* len —[in] The length request
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e ticks_to_wait —[in] The ticks to wait

j& ] Number of bytes read

int rb_write (ringbuf_handle_t b, char *buf, int len, TickType_t ticks_to_wait)

Write to Ringbuffer from buf with 1en and wait tick_to_wait ticks until enough space to write if the ring-

buffer space available is less than 1en
S8
* rb —[in] The Ringbuffer handle
* buf —The buffer
* len —[in] The length
e ticks_to_wait —{in] The ticks to wait
&M Number of bytes written

esp_err_t rb_done_write (ringbuf_handle_t 1b)
Set status of writing to ringbuffer is done.

%4 rb —[in] The Ringbuffer handle
Bl

* ESP_OK

* ESP_FAIL

esp_err_t rb_unblock_reader (ringbuf_handle_t rb)
Unblock from rb_read.

%24 rb —[in] The Ringbuffer handle
B

« ESP_OK

* ESP_FAIL

esp_err_t rb_set_reader_holder (ringbuf_handle_t tb, void *holder)
Set the owner of the ‘rb_read’ .

SH

* rb —[in] The Ringbuffer handle

* holder —[in] The owner of the ‘rb_read’
B

* ESP_OK

* ESP_FAIL

esp_err_t rb_get_reader_holder (ringbuf _handle_t rb, void **holder)

Get the owner of the ‘rb_read’ .
SH
* rb —[in] The Ringbuffer handle
* holder —[out] The owner of the ‘rb_read’

B
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* ESP_OK
» ESP_FAIL

esp_err_t rb_set_writer_ holder (ringbuf_handle_t rb, void *holder)

Set the owner of the ‘rb_write’ .
S8
* rb —[in] The Ringbuffer handle
* holder —[in] The owner of the ‘rb_write’
B
» ESP_OK
» ESP_FAIL

esp_err_t rb_get_writer_holder (ringbuf_handle_t rb, void **holder)
Get the owner of the ‘rb_write’ .

S8

* rb —[in] The Ringbuffer handle

* holder —[out] The owner of the ‘rb_write’
B

* ESP_OK

» ESP_FAIL

Macros

RB_OK

RB_FAIL

RB_DONE

RB_ABORT

RB_TIMEOUT

Type Definitions

typedef struct ringbuf *ringbuf_handle_t
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2.9.2 Audio HAL

Abstraction layer for audio board hardware, serves as an interface between the user application and the hardware driver
for specific audio board like ESP32 LyraT.

The API provides data structures to configure sampling rates of ADC and DAC signal conversion, data bit widths, 12C
stream parameters, and selection of signal channels connected to ADC and DAC. It also contains several specific functions
to e.g. initialize the audio board, audio_hal_init (), control the volume, audio_hal_get_volume () and
audio_hal_set_volume ().

API Reference
Header File

¢ components/audio_hal/include/audio_hal.h

Functions

audio_hal_handle_t audio_hal_init (audio_hal_codec_config_t *audio_hal_conf, audio_hal_func_t
*audio_hal_func)

Initialize media codec driver.

$41:: If selected codec has already been installed, it” 1l return the audio_hal handle.

BH
* audio_hal_conf —Configure structure audio_hal_config_t
* audio_hal_func —Structure containing functions used to operate audio the codec chip

Rl int, 0&#8212;success, others&#8212;fail

esp_err_t audio_hal_deinit (audio_hal_handle_t audio_hal)
Uninitialize media codec driver.

%4 audio_hal —reference function pointer for selected audio codec
&l int, 0&#8212;success, others&#8212;fail

esp_err_t audio_hal_ctrl_codec (audio_hal_handle_t audio_hal, audio_hal_codec_mode_t mode,
audio_hal_ctrl_t audio_hal_ctrl)

Start/stop codec driver.
S8
* audio_hal —reference function pointer for selected audio codec

* mode -select media hal codec mode either encode/decode/or both to start from au-
dio_hal codec_mode_t

* audio_hal_ctrl —select start stop state for specific mode

RIA] int, 0&#8212;success, others&#8212;fail
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esp_err_t audio_hal_codec_iface_config (audio_hal_handle_t audio_hal, audio_hal_codec_mode_t mode,
audio_hal_codec_i2s_iface_t *iface)

Set codec 128 interface samples rate & bit width and format either 12S or PCM/DSP.
S8
* audio_hal —reference function pointer for selected audio codec

* mode -select media hal codec mode either encode/decode/or both to start from au-
dio_hal _codec_mode t

* iface —12S sample rate (ex: 16000, 44100), I2S bit width (16, 24, 32),12s format (I2S, PCM,
DSP).

$Ey |
¢ 0 Success
e -1 Error

esp_err_t audio_hal_set_mute (audio_hal_handle_t audio_hal, bool mute)
Set voice mute. Enables or disables DAC mute of a codec.

$&1k: audio_hal_get_volume will still give a non-zero number in mute state. It will be set to that number
when speaker is unmuted.

BH
* audio_hal -reference function pointer for selected audio codec
* mute —true/false. If true speaker will be muted and if false speaker will be unmuted.

RIA] int, 0&#8212;success, others&#8212;fail

esp_err_t audio_hal_set_volume (audio_hal_handle_t audio_hal, int volume)

Set voice volume.

412 if volume is 0, mute is enabled,range is 0-100.

BH
* audio_hal -reference function pointer for selected audio codec
* volume —value of volume in percent(%)

RIA] int, 0&#8212;success, others&#8212;fail

esp_err_t audio_hal_get_volume (audio_hal_handle_t audio_hal, int *volume)

get voice volume.

41:: if volume is 0, mute is enabled, range is 0-100.

S

* audio_hal —reference function pointer for selected audio codec
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* volume —value of volume in percent returned(%)

B[] int, 0&#8212;success, others&#8212;fail

esp_err_t audio_hal_enable_pa (audio_hal_handle_t audio_hal, bool enable)
Enables or disables PA.

SH
* audio_hal —reference function pointer for selected audio codec
* enable —true/false.

J& ] int, 0&#8212;success, others&#8212;fail

Structures

struct audio_hal_codec_i2s_iface_t

12s interface configuration for audio codec chip.

Public Members

audio_hal_iface_mode_t mode

audio codec chip mode

audio_hal_iface_format_t fmt

12S interface format

audio_hal_iface_samples_t samples

12S interface samples per second

audio_hal_iface_bits_tbits

i2s interface number of bits per sample

struct audio_hal_codec_config t

Configure media hal for initialization of audio codec chip.

Public Members

audio_hal_adc_input_t ade_input

set adc channel

audio_hal_dac_output_t dac_output

set dac channel

audio_hal_codec_mode_t codec_mode

select codec mode: adc, dac or both
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audio_hal_codec_i2s_iface_t i2s_iface

set I12S interface configuration

struct audio_hal

Configuration of functions and variables used to operate audio codec chip.

Public Members

esp_err_t (*faudio_codec_initialize)(audio_hal_codec_config_t *codec_cfg)
initialize codec

esp_err_t (*faudio_codec_deinitialize)(void)

deinitialize codec

esp_err_t (*audio_codec_ctrl)(audio_hal_codec_mode_t mode, audio_hal_ctrl_t ctrl_state)

control codec mode and state

esp_err_t (*faudio_codec_config_iface)(audio_hal_codec_mode_t mode, audio_hal_codec_i2s_iface_t
*iface)

configure i2s interface

esp_err_t (*faudio_codec_set_mute)(bool mute)

set codec mute

esp_err_t (*faudio_codec_set_volume)(int volume)

set codec volume

esp_err_t (*faudio_codec_get_volume)(int *volume)

get codec volume

esp_err_t (*faudio_codec_enable_pa)(bool enable)

enable pa

xSemaphoreHandle audio_hal_lock

semaphore of codec

void *handle

handle of audio codec
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Macros

AUDIO_HAL_VOL_DEFAULT

Type Definitions

typedef struct audio_hal *faudio_hal_handle_t

typedef struct audio_hal audio_hal_func_t

Configuration of functions and variables used to operate audio codec chip.

Enumerations

enum audio_hal_codec_mode_t

Select media hal codec mode.

Values:

enumerator AUDIO_HAL_CODEC_MODE_ENCODE

select adc

enumerator AUDIO_HAL_CODEC_MODE_DECODE

select dac

enumerator AUDIO_HAL_CODEC_MODE_BOTH

select both adc and dac

enumerator AUDIO_HAL_CODEC_MODE_LINE_IN

set adc channel

enum audio_hal_adc_input_t
Select adc channel for input mic signal.

Values:

enumerator AUDIO_HAL_ADC_INPUT LINE1l

mic input to adc channel 1

enumerator AUDIO_HAL_ADC_INPUT LINE2

mic input to adc channel 2

enumerator AUDIO_HAL_ADC_INPUT ALL

mic input to both channels of adc
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enumerator AUDIO_HAL_ADC_INPUT_DIFFERENCE

mic input to adc difference channel

enum audio_hal_dac_output_t

Select channel for dac output.

Values:

enumerator AUDIO_HAL_DAC_OUTPUT_LINE1l

dac output signal to channel 1

enumerator AUDIO_HAL_DAC_OUTPUT_LINE2

dac output signal to channel 2

enumerator AUDIO_HAL_DAC_OUTPUT_ALL

dac output signal to both channels

enum audio_hal_ctrl_t

Select operating mode i.e. start or stop for audio codec chip.

Values:

enumerator AUDIO_HAL_CTRL_STOP

set stop mode

enumerator AUDIO_HAL_CTRL_START

set start mode

enum audio_hal_iface_mode_t

Select I2S interface operating mode i.e. master or slave for audio codec chip.

Values:

enumerator AUDIO_HAL_MODE_SLAVE

set slave mode

enumerator AUDIO_HAL_MODE_MASTER

set master mode

enum audio_hal_iface_samples_t

Select 128 interface samples per second.

Values:

enumerator AUDIO_HAL_O08K_SAMPLES

set to 8k samples per second
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enumerator AUDIO_HAL_11K_SAMPLES
set to 11.025k samples per second

enumerator AUDIO_HAL_16K_SAMPLES

set to 16k samples in per second

enumerator AUDIO_HAL_22K_SAMPLES
set to 22.050k samples per second

enumerator AUDIO_HAL_24K_SAMPLES

set to 24k samples in per second

enumerator AUDIO_HAL_32K_SAMPLES

set to 32k samples in per second

enumerator AUDIO_HAL_44K_SAMPLES

set to 44.1k samples per second

enumerator AUDIO_HAL_48K_SAMPLES

set to 48k samples per second

enum audio_hal_iface_bits_t
Select 12S interface number of bits per sample.

Values:

enumerator AUDIO_HAIL_ BIT LENGTH_16BITS
set 16 bits per sample

enumerator AUDIO_HAIL_ BIT LENGTH_24BITS
set 24 bits per sample

enumerator AUDIO_HAIL_ BIT LENGTH_32BITS
set 32 bits per sample

enum audio_hal_iface_format_t

Select 128 interface format for audio codec chip.

Values:

enumerator AUDIO_HAL_I2S_NORMAL

set normal I12S format

enumerator AUDIO_HAL_I2S_LEFT

set all left format
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enumerator AUDIO_HAL_I2S_RIGHT

set all right format

enumerator AUDIO_HAL_I2S_DSP

set dsp/pcm format

2.9.3 ES8388 Driver

Driver for ES8388 codec chip used in ESP32 LyraT audio board.

API Reference

Header File

» components/audio_hal/driver/es8388/es8388.h

Functions

esp_err_t es8388_init (audio_hal_codec_config t *cfg)
Initialize ES8388 codec chip.

%% c£fqg —configuration of ES8388
Bl

 ESP_OK

* ESP_FAIL

esp_err_t es8388_deinit (void)
Deinitialize ES8388 codec chip.

gml
« ESP_OK
« ESP_FAIL

esp_err_t es8388_config_fmt (es_module_t mod, es_i2s_fmt_t cfg)
Configure ES8388 12S format.

S8
* mod —set ADC or DAC or both
* cfg —-ES8388 I2S format

B

ESP_OK
* ESP_FAIL
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esp_err_t es8388_i2s_config_clock (es_i2s_clock_t cfg)
Configure 12s clock in MSATER mode.

%48 cfqg —set bits clock and WS clock
A

 ESP_OK

* ESP_FAIL

esp_err_t es8388_set_bits_per_ sample (es_module_t mode, es_bits_length_t bit_per_sample)
Configure ES8388 data sample bits.

S8

* mode —set ADC or DAC or both

* bit_per_sample —bit number of per sample
B

* ESP_OK

* ESP_FAIL

esp_err_t es8388_start (es_module_t mode)
Start ES8388 codec chip.

2 ¥ mode —set ADC or DAC or both
&Ml

 ESP_OK

* ESP_FAIL

esp_err_t es8388_stop (es_module_t mode)
Stop ES8388 codec chip.

2% mode —set ADC or DAC or both
A

 ESP_OK

* ESP_FAIL

esp_err_t es8388_set_voice_volume (int volume)

Set voice volume.
%% volume —voice volume (0~100)
B
* ESP_OK
» ESP_FAIL

esp_err_t es8388_get_voice_volume (int *volume)

Get voice volume.
%% *volume —[out] voice volume (0~100)
B
 ESP_OK
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» ESP_FAIL

esp_err_t es8388_set_voice_mute (bool enable)

Configure ES8388 DAC mute or not. Basically you can use this function to mute the output or unmute.

%% enable —enable(1) or disable(0)
Bl

e ESP_FAIL Parameter error

e ESP_OK Success

esp_err_t es8388_get_voice_mute (void)
Get ES8388 DAC mute status.

$Ey |
e ESP_FAIL Parameter error
¢ ESP_OK Success

esp_err_t es8388_set_mic_gain (es_mic_gain_t gain)
Set ES8388 mic gain.

%4 gain —db of mic gain

Bl
e ESP_FAIL Parameter error
e ESP_OK Success

esp_err_t es8388_config_adc_input (es_adc_input_t input)
Set ES8388 adc input mode.

4 input —adc input mode
Bl
¢ ESP_FAIL Parameter error
¢ ESP_OK Success

esp_err_t es8388_config_dac_output (es_dac_output_t output)
Set ES8388 dac output mode.

%% output —dac output mode
Bl
e ESP_FAIL Parameter error
* ESP_OK Success

esp_err_t es8388_write_reg (uint8_t reg_add, uint8_t data)
Write ES8388 register.

S
* reg_add —address of register
* data —data of register

Bl
e ESP_FAIL Parameter error
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* ESP_OK Success

void es8388_read_all (void)
Print all ES8388 registers.

esp_err_t es8388_config_i2s (audio_hal_codec_mode_t mode, audio_hal_codec_i2s_iface_t *iface)
Configure ES8388 codec mode and 12S interface.

S8
* mode —codec mode
* iface 128 config
Bl
* ESP_FAIL Parameter error
e ESP_OK Success

esp_err_t es8388_ctrl_state (audio_hal_codec_mode_t mode, audio_hal_ctrl_t ctrl_state)
Control ES8388 codec chip.

SH

* mode —codec mode

* ctrl_state —start or stop decode or encode progress
B M

e ESP_FAIL Parameter error

* ESP_OK Success

esp_err_t es8388_pa_power (bool enable)
Set ES8388 PA power.

%% enable —true for enable PA power, false for disable PA power
EA

* ESP_ERR_INVALID_ARG

* ESP_OK

Macros

ES8388_ADDR
0x22:CE=1;0x20:CE=0

ES8388_CONTROL1

ES8388_CONTROL2

ES8388_CHIPPOWER

ES8388_ADCPOWER
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ES8388_DACPOWER

ES8388_CHIPLOPOW1

ES8388_CHIPLOPOW2

ES8388_ANAVOLMANAG

ES8388_MASTERMODE

ES8388_ADCCONTROL1

ES8388_ADCCONTROLZ2

ES8388_ADCCONTROL3

ES8388_ADCCONTROL4

ES8388_ADCCONTROLS5

ES8388_ADCCONTROL6

ES8388_ADCCONTROL7

ES8388_ADCCONTROLS

ES8388_ADCCONTROLY

ES8388_ADCCONTROL10

ES8388_ADCCONTROL11

ES8388_ADCCONTROL12

ES8388_ADCCONTROL13

ES8388_ADCCONTROL14

ES8388_DACCONTROL1

ES8388_DACCONTROL2
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ES8388_DACCONTROL3

ES8388_DACCONTROL4

ES8388_DACCONTROLS

ES8388_DACCONTROL6

ES8388_DACCONTROL7

ES8388_DACCONTROLS

ES8388_DACCONTROLY

ES8388_DACCONTROL10

ES8388_DACCONTROL11

ES8388_DACCONTROL12

ES8388_DACCONTROL13

ES8388_DACCONTROL14

ES8388_DACCONTROL15

ES8388_DACCONTROL16

ES8388_DACCONTROL17

ES8388_DACCONTROL18

ES8388_DACCONTROL19

ES8388_DACCONTROL20

ES8388_DACCONTROL21

ES8388_DACCONTROL22

ES8388_DACCONTROL23
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ES8388_DACCONTROL24

ES8388_DACCONTROL25

ES8388_DACCONTROL26

ES8388_DACCONTROL27

ES8388_DACCONTROL28

ES8388_DACCONTROL29

ES8388_DACCONTROL30

2.9.4 ES8374 Driver

Driver for ES8374 codec chip.

API Reference

Header File

e components/audio_hal/driver/es8374/es8374.h

Functions

esp_err_t es8374_codec_init (audio_hal_codec_config t *cfg)
Initialize ES8374 codec chip.

%4 c£fqg —configuration of ES8374
Bl

* ESP_OK

* ESP_FAIL

esp_err_t es8374_codec_deinit (void)
Deinitialize ES8374 codec chip.

gml
- ESP_OK
« ESP_FAIL

esp_err_t es8374_config_fmt (es_module_t mode, es_i2s_fmt_t fmt)
Configure ES8374 12S format.

¢ mode —Set ADC or DAC or both
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» fmt —ES8374 12S format
B

» ESP_OK

» ESP_FAIL

esp_err_tes8374_i2s_config_clock (es_i2s_clock_t cfg)
Configure 12S clock in MSATER mode.

%% c£g -Set bits clock and WS clock
A

 ESP_OK

» ESP_FAIL

esp_err_t es8374_set_bits_per_ sample (es_module_t mode, es_bits_length_t bit_per_sample)
Configure ES8374 data sample bits.

S
¢ mode —Set ADC or DAC or both

* bit_per_ sample —Bit number of per sample

* ESP_OK
* ESP_FAIL

esp_err_t es8374_start (es_module_t mode)
Start ES8374 codec chip.

2% mode —Set ADC or DAC or both
A

 ESP_OK

* ESP_FAIL

esp_err_t es8374_stop (es_module_t mode)
Stop ES8374 codec chip.

%%, mode -Set ADC or DAC or both
Bl

« ESP_OK

* ESP_FAIL

esp_err_t es8374_codec_set_voice_volume (int volume)

Set voice volume.
%% volume —Voice volume (0~100)
B
* ESP_OK
e ESP_FAIL
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esp_err_t es8374_codec_get_voice_volume (int *volume)

Get voice volume.
%% *volume —[out] Voice volume (0~100)
A
* ESP_OK
» ESP_FAIL

esp_err_t es8374_set_voice_mute (bool enable)

Mute or unmute ES8374 DAC. Basically you can use this function to mute or unmute the output.

%% enable —[inout] Enable Mute(1) or Unmute(0)
B

e ESP_FAIL Parameter error

¢ ESP_OK Success

esp_err_t es8374_get_voice_mute (void)
Get ES8374 DAC mute status.

gml
« ESP_FAIL
- ESP_OK

esp_err_t es8374_set_mic_gain (es_mic_gain_t gain)
Set ES8374 mic gain.

%4 gain —[inout] gain db of mic gain
A

e ESP_FAIL Parameter error

* ESP_OK Success

esp_err_t es8374_config_adc_input (es_adc_input_t input)
Set ES8374 ADC input mode.

%%, input -[in] ADC input mode
&I
e ESP_FAIL Parameter error
e ESP_OK Success

esp_err_t es8374_config_dac_output (es_dac_output_t output)
Set ES8374 DAC output mode.

%4 output —[in] DAC output mode
Bl

¢ ESP_FAIL Parameter error

¢ ESP_OK Success
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esp_err_t es8374_write_reg (uint8_t reg_add, uint8_t data)
Write ES8374 register.

S8
* reg_add —Address of register
* data Data of register
Bl
e ESP_FAIL Parameter error
* ESP_OK Success

void es8374_read_all (void)
Print all ES8374 registers.

esp_err_t es8374_codec_config_i2s (audio_hal_codec_mode_t mode, audio_hal_codec_i2s_iface_t *iface)
Configure ES8374 codec mode and I2S interface.

S
* mode —Codec mode
» iface -12S config
Bl
e ESP_FAIL Parameter error
e ESP_OK Success

esp_err_t es8374_codec_ctrl_state (audio_hal_codec_mode_t mode, audio_hal_ctrl_t ctrl_state)
Control ES8374 codec chip.

S8

* mode —Codec mode

* ctrl_state —Start or stop decode or encode progress
B

e ESP_FAIL Parameter error

e ESP_OK Success

esp_err_t es8374_pa_power (bool enable)
Set ES8374 PA power.

%4 enable —True for enable PA power, false for disable PA power
B

* ESP_ERR_INVALID_ARG

* ESP_OK
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Macros

ES8374_ADDR

2.9.5 ZL.38063 Driver

Driver for Z1.38063 codec chip used in ESP32-LyraTD-MSC audio board.

API Reference

Header File

e components/audio_hal/driver/z138063/z138063.h

Functions

esp_err_t z138063_codec_init (audio_hal_codec_config_t *cfg)
Initialize Z1.38063 chip.

%% c£fg —configuration of ZL38063
Rl

* ESP_OK

* ESP_FAIL

esp_err_t z138063_codec_deinit (void)
Deinitialize ZL.38063 chip.

gml
- ESP_OK
« ESP_FAIL

esp_err_t z138063_codec_ctrl_state (audio_hal_codec_mode_t mode, audio_hal_ctrl_t ctrl_state)
Control Z1.38063 chip.

The functions z138063_ctrl_state and z138063_config_i2s are not used by this driver. They are kept here to maintain
the uniformity and convenience of the interface of the ADF project. These settings for z138063 are burned in
firmware and configuration files. Default i2s configuration: 48000Hz, 16bit, Left-Right channels. Use resampling
to be compatible with different file types.

S

* mode —codec mode

e ctrl_state —start or stop decode or encode progress
Bl

e ESP_FAIL Parameter error

* ESP_OK Success
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esp_err_t z138063_codec_config_i2s (audio_hal_codec_mode_t mode, audio_hal_codec_i2s_iface_t *iface)

Configure Z1L.38063 codec mode and I2S interface.
BH
* mode —codec mode
* iface 128 config
Bl
e ESP_FAIL Parameter error
* ESP_OK Success

esp_err_t z138063_codec_set_voice_mute (bool mute)
mute or unmute the codec

Z¥ mute —true, false
B

« ESP_OK

* ESP_FAIL

esp_err_t z138063_codec_set_voice_volume (int volume)

Set voice volume.
¥ volume —voice volume (0~100)
&Ml
* ESP_OK
* ESP_FAIL

esp_err_t z138063_codec_get_voice_volume (int *volume)

Get voice volume.
Z¥ *volume —[out] voice volume (0~100)
&
* ESP_OK
» ESP_FAIL

2.10 Configuration Options

Compile-time configuration options specific to ESP-ADF.
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2.10.1 ESP Speech Recognition

MODEL_DATA_PATH

model data path
Found in: ESP Speech Recognition
Available options:

« MODEL_IN_FLASH

« MODEL_IN_SDCARD

USE_AFE
use afe
Found in: ESP Speech Recognition

AFE_INTERFACE_SEL

Afe interface

Found in: ESP Speech Recognition
Select the afe interface to be used.
Available options:

* AFE_INTERFACE_V1

USE_NSNET

use nsnet

Found in: ESP Speech Recognition

SR_NSN_MODEL_LOAD

Select deep noise suppression

Found in: ESP Speech Recognition

Select the deep noise suppression to be loaded.

Available options:
* SR_NSN_NONE
¢ SR_NSN_NSNET1
¢ SR_NSN_NSNET2
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USE_WAKENET

use wakenet

Found in: ESP Speech Recognition

SR_WN_MODEL_LOAD

Select wake words

Found in: ESP Speech Recognition
Select the Wake Words to be loaded.

Available options:

SR_WN_WNS5_HILEXIN
SR_WN_WN5X3_HILEXIN
SR_WN_WNS5_NIHAOXIAOZHI
SR_WN_WN5X3_NIHAOXIAOZHI
SR_WN_WN5X3_NIHAOXIAOXIN
SR_WN_WNS8_ALEXA
SR_WN_WNO9_HILEXIN
SR_WN_WNO9_XITAOAITONGXUE
SR_WN_WNO9_ALEXA
SR_WN_WN9_HIESP
SR_WN_WNO9_HIMFIVE
SR_WN_WNO9_NIHAOXIAOZHI_TTS
SR_WN_WNO9_JARVIS_TTS
SR_WN_WN9_COMPUTER_TTS
SR_WN_WN9_HEYWILLOW_TTS
SR_WN_WNO9_SOPHIA_TTS
SR_WN_WNO9_NIHAOXIAOXIN_TTS
SR_WN_WNO9_XIAOMEITONGXUE_TTS
SR_WN_WNO9_HIXTAOXING_TTS
SR_WN_WN9_MYCROFT_TTS
SR_WN_WNO9_HEYPRINTER_TTS
SR_WN_WN9_XTAOLONGXIAOLONG_TTS
SR_WN_WN9_MIAOMIAOTONGXUE_TTS
SR_WN_WNO9_HIJIOY_TTS
SR_WN_WNO_HILILI_TTS
SR_WN_WNO_HITELLY_TTS
SR_WN_WN9_HEYWANDA_TTS
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SR_WN_WN9_HIMIAOMIAO_TTS

* SR_WN_WN9_XIAOBINXIAOBIN_TTS
* SR_WN_WN9_ASTROLABE_TTS

e SR_WN_WN9_CUSTOMWORD

* SR_WN_LOAD_MULIT_WORD

Load Multiple Wake Words

SR_WN_WN9_HILEXIN_MULTI

Hi, k%% (wn9_hilexin)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_ XIAOAITONGXUE_MULTI

/N [F)2# (wn9_xiaoaitongxue)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 NIHAOXIAOZHI_TTS_MULTI

R4F7NE (wn9_nihaoxiaozhi_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_ALEXA_MULTI

Alexa (wn9_alexa)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_HIESP_MULTI

Hi,ESP (wn9_hiesp)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 JARVIS_TTS_MULTI

Jarvis (wn9_jarvis_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
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SR_WN_WN9 COMPUTER_TTS_MULTI

computer (wn9_computer_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 HEYWILLOW_TTS_MULTI

Hey,Willow (wn9_heywillow_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 SOPHIA_TTS_MULTI

Sophia (wn9_sophia_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_NIHAOXIAOXIN_TTS_MULTI

ARIF-/N2% (wn9_nihaoxiaoxin_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_XIAOMEITONGXUE_TTS_MULTI

/NFE[F]2# (wn9_xiaomeitongxue._tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 HEYPRINTER_TTS_MULTI

Hey,Printer (wn9_heyprinter_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_ XIAOLONGXIAOLONG_TTS_MULTI

/NN IR (wn9_xiaolongxiaolong_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 MIAOMIAOTONGXUE_TTS_MULTI

Wi [H]2# (wn9_miaomiaotongxue_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
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SR_WN_WN9 HEYWANDA _TTS_MULTI

Hey,Wanda (wn9_heywanda_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 HIMIAOMIAO_TTS_MULTI

Hi, ¥ (wn9_himiaomiao_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 MYCROFT_TTS_MULTI

Mycroft (wn9_mycroft_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_HIJOY_TTS_MULTI

Hi,Joy (wn9_hijoy_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WNS9_HILILI_TTS_MULTI

Hi,Lily/Hi, #j#i] (wn9_hilili_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_HITELLY_TTS_MULTI

Hi, Telly/Hi, %% /7 (wn9_hitelly_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9_ XIAOBINXIAOBIN_TTS_MULTI

JINEEZINIEEL /N ZNK (wn9_xiaobinxiaobin_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
SR_WN_WN9 _ASTROLABE_TTS_MULTI

Astrolabe (wn9_astrolabe_tts)

Found in: ESP Speech Recognition > Load Multiple Wake Words
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USE_MULTINET

use multinet

Found in: ESP Speech Recognition

CHINESE_SR_MN_MODEL_SEL

Chinese Speech Commands Model
Found in: ESP Speech Recognition
Select the Wake Word Engine to be used.
Available options:
* SR_MN_CN_NONE
* SR_MN_CN_MULTINET2_SINGLE_RECOGNITION
e SR_MN_CN_MULTINET5_RECOGNITION_QUANTS
* SR_MN_CN_MULTINET6_QUANT
*« SR_MN_CN_MULTINET6_AC_QUANT
* SR_MN_CN_MULTINET7_QUANT
¢ SR_MN_CN_MULTINET7_AC_QUANT

ENGLISH_SR_MN_MODEL_SEL

English Speech Commands Model
Found in: ESP Speech Recognition
Select the Wake Word Engine to be used.
Available options:
 SR_MN_EN_NONE
¢ SR_MN_EN_MULTINET5_SINGLE_RECOGNITION_QUANTS
*« SR_MN_EN_MULTINET6_QUANT
* SR_MN_EN_MULTINET7_QUANT

Add Chinese speech commands

CN_SPEECH_COMMAND_IDO

1DO
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID1

ID1

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID2

D2

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID3

1D3

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID4

ID4

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID5

ID5

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID6

ID6

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID7

ID7

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID8

1D8
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID9

D9

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID10

ID10

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID11

ID11

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID12

ID12

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID13

ID13

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID14

ID14

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID15

ID15

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID16

ID16
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID17

ID17

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID18

ID18

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID19

ID19

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID20

1D20

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID21

ID21

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID22

1D22

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID23

D23

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID24

1D24
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID25

D25

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID26

D26

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID27

1D27

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID28

1D28

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID29

1D29

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID30

ID30

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID31

ID31

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID32

1D32
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID33

ID33

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID34

ID34

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID35

ID35

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID36

ID36

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID37

1D37

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID38

1ID38

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID39

ID39

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID40

1D40
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID41

D41

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID42

D42

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID43

D43

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID44

ID44

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID45

D45

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID46

1D46

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID47

1D47

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID48

1D48
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID49

1D49

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID50

ID50

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID51

ID51

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID52

ID52

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID53

ID53

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID54

ID54

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID55

ID55

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID56

ID56
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID57

ID57

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID58

ID58

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID59

ID59

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID60

ID60

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID61

ID61

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID62

ID62

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID63

1D63

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID64

1D64
Found in: ESP Speech Recognition > Add Chinese speech commands

2.10. Configuration Options

277



ADF E40 i FAFF R HEZ2F 11, & 1 latest

CN_SPEECH_COMMAND_ID65

ID65

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID66

ID66

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID67

1D67

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID68

ID68

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID69

1ID69

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID70

ID70

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID71

ID71

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID72

1D72
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID73

ID73

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID74

ID74

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID75

ID75

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID76

ID76

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID77

ID77

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID78

ID78

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID79

ID79

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID80

1D80
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID81

ID81

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID82

D82

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID83

1D83

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID84

ID84

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID85

D85

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID86

ID86

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID87

ID87

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID88

1D88
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID89

ID89

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID90

1D90

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID91

1D91

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID92

D92

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID93

1D93

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID94

1D9%4

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID95

D95

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID96

1D96
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID97

1D97

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID98

1ID98

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID99

1D99

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID100

ID100

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID101

ID101

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID102

ID102

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID103

ID103

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID104

ID104
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID105

ID105

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID106

ID106

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID107

ID107

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID108

ID108

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID109

ID109

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID110

ID110

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID111

ID111

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID112

ID112
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID113

ID113

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID114

ID114

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID115

ID115

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID116

ID116

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID117

ID117

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID118

ID118

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID119

ID119

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID120

1D120
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID121

ID121

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID122

D122

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID123

ID123

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID124

D124

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID125

ID125

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID126

ID126

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID127

ID127

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID128

1D128
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID129

ID129

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID130

ID130

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID131

ID131

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID132

ID132

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID133

ID133

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID134

ID134

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID135

ID135

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID136

ID136
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID137

ID137

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID138

ID138

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID139

ID139

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID140

ID140

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID141

ID141

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID142

ID142

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID143

ID143

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID144

1D144
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID145

ID145

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID146

ID146

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID147

1ID147

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID148

ID148

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID149

ID149

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID150

ID150

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID151

ID151

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID152

ID152
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID153

ID153

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID154

ID154

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID155

ID155

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID156

ID156

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID157

ID157

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID158

ID158

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID159

ID159

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID160

ID160
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID161

ID161

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID162

D162

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID163

ID163

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID164

ID164

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID165

ID165

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID166

ID166

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID167

ID167

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID168

ID168
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID169

D169

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID170

ID170

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID171

ID171

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID172

ID172

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID173

ID173

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID174

ID174

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID175

ID175

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID176

ID176
Found in: ESP Speech Recognition > Add Chinese speech commands

2.10. Configuration Options

291



ADF E40 i FAFF R HEZ2F 11, & 1 latest

CN_SPEECH_COMMAND_ID177

ID177

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID178

ID178

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID179

ID179

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID180

ID180

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID181

ID181

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID182

ID182

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID183

ID183

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID184

1D184
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID185

ID185

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID186

ID186

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID187

ID187

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID188

ID188

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID189

ID189

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID190

ID190

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND _ID191

ID191

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID192

1D192
Found in: ESP Speech Recognition > Add Chinese speech commands
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CN_SPEECH_COMMAND_ID193

ID193

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID194

ID194

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID195

ID195

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID196

ID196

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID197

ID197

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID198

ID198

Found in: ESP Speech Recognition > Add Chinese speech commands
CN_SPEECH_COMMAND_ID199

ID199

Found in: ESP Speech Recognition > Add Chinese speech commands

Add English speech commands

EN_SPEECH_COMMAND_IDO

1DO
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID1

ID1

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID2

D2

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID3

1D3

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID4

ID4

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID5

ID5

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID6

ID6

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID7

ID7

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID8

1D8
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID9

D9

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID10

ID10

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID11

ID11

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID12

ID12

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID13

ID13

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID14

ID14

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID15

ID15

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID16

ID16
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID17

ID17

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID18

ID18

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID19

ID19

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID20

1D20

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID21

ID21

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID22

1D22

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID23

D23

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID24

1D24
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID25

D25

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID26

D26

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID27

1D27

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID28

1D28

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID29

1D29

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID30

ID30

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID31

ID31

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID32

1D32
Found in: ESP Speech Recognition > Add English speech commands

298

Chapter 2. API Reference



ADF E45R AF ZEZRF M, A7 latest

EN_SPEECH_COMMAND_ID33

ID33

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID34

ID34

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID35

ID35

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID36

ID36

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID37

1D37

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID38

1ID38

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID39

ID39

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID40

1D40
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID41

D41

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID42

D42

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID43

D43

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID44

ID44

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID45

D45

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID46

1D46

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID47

1D47

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID48

1D48
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID49

1D49

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID50

ID50

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID51

ID51

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID52

ID52

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID53

ID53

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID54

ID54

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID55

ID55

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID56

ID56
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID57

ID57

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID58

ID58

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID59

ID59

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID60

ID60

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID61

ID61

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID62

ID62

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID63

1D63

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID64

1D64
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID65

ID65

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID66

ID66

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID67

1D67

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID68

ID68

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID69

1ID69

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID70

ID70

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID71

ID71

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID72

1D72
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID73

ID73

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID74

ID74

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID75

ID75

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID76

ID76

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID77

ID77

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID78

ID78

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID79

ID79

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID80

1D80
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID81

ID81

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID82

D82

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID83

1D83

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID84

ID84

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID85

D85

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID86

ID86

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID87

ID87

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID88

1D88
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID89

ID89

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID90

1D90

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID91

1D91

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID92

D92

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID93

1D93

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID94

1D9%4

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID95

D95

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID96

1D96
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID97

1D97

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID98

1ID98

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID99

1D99

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID100

ID100

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID101

ID101

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID102

ID102

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID103

ID103

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID104

ID104
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID105

ID105

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID106

ID106

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID107

ID107

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID108

ID108

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID109

ID109

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID110

ID110

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID111

ID111

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID112

ID112
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID113

ID113

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID114

ID114

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID115

ID115

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID116

ID116

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID117

ID117

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID118

ID118

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID119

ID119

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID120

1D120
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID121

ID121

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID122

D122

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID123

ID123

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID124

D124

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID125

ID125

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID126

ID126

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID127

ID127

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID128

1D128
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID129

ID129

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID130

ID130

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID131

ID131

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID132

ID132

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID133

ID133

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID134

ID134

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID135

ID135

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID136

ID136
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID137

ID137

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID138

ID138

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID139

ID139

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID140

ID140

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID141

ID141

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID142

ID142

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID143

ID143

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID144

1D144
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID145

ID145

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID146

ID146

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID147

1ID147

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID148

ID148

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID149

ID149

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID150

ID150

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID151

ID151

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID152

ID152
Found in: ESP Speech Recognition > Add English speech commands

2.10. Configuration Options

313



ADF E40 i FAFF R HEZ2F 11, & 1 latest

EN_SPEECH_COMMAND_ID153

ID153

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID154

ID154

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID155

ID155

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID156

ID156

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID157

ID157

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID158

ID158

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID159

ID159

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID160

ID160
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID161

ID161

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID162

D162

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID163

ID163

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID164

ID164

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID165

ID165

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID166

ID166

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID167

ID167

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID168

ID168
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID169

D169

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID170

ID170

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID171

ID171

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID172

ID172

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID173

ID173

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID174

ID174

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID175

ID175

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID176

ID176
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND_ID177

ID177

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID178

ID178

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID179

ID179

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID180

ID180

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID181

ID181

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID182

ID182

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID183

ID183

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID184

1D184
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID185

ID185

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID186

ID186

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID187

ID187

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID188

ID188

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID189

ID189

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID190

ID190

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID191

ID191

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID192

1D192
Found in: ESP Speech Recognition > Add English speech commands
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EN_SPEECH_COMMAND _ID193

ID193

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID194

ID194

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND _ID195

ID195

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID196

ID196

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID197

ID197

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID198

ID198

Found in: ESP Speech Recognition > Add English speech commands
EN_SPEECH_COMMAND_ID199

1D199

Found in: ESP Speech Recognition > Add English speech commands
2.10.2 ADF Features
ESP_DISPATCHER_DELEGATE_TASK_CORE

Delegation task core
Found in: ADF Features

Pinned delegate task to core O or core 1.
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ESP_DISPATCHER_DELEGATE_TASK_PRIO

Delegate task’ s prio
Found in: ADF Features
The delegate task’ s prio.

ESP_DISPATCHER_DELEGATE_STACK_SIZE

Delegate task’ s stack size
Found in: ADF Features

The delegate task’ s stack is located in DRAM, modify this size to make sure all the needed operation can
be run success in the it.

2.10.3 ADF Library Configuration
MEDIA_PROTOCOL_LIB_ENABLE
Enable Media Protocol Library
Found in: ADF Library Configuration
MEDIA_LIB_MEM_AUTO_TRACE

Support trace memory automatically after media_lib_sal init

Found in: ADF Library Configuration

MEDIA_LIB_MEM_TRACE_DEPTH

Memory trace stack depth
Found in: ADF Library Configuration

Set memory trace depth

MEDIA_LIB_MEM_TRACE_NUM

Memory trace number
Found in: ADF Library Configuration

Set memory trace number
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MEDIA_LIB_MEM_TRACE_MODULE

Trace for module memory usage

Found in: ADF Library Configuration

MEDIA_LIB_MEM_TRACE_LEAKAGE

Trace for memory leakage

Found in: ADF Library Configuration

MEDIA_LIB_MEM_TRACE_SAVE_HISTORY

Trace to save memory history

Found in: ADF Library Configuration

MEDIA_LIB_MEM_SAVE_CACHE_SIZE

Cache buffer size to store save history
Found in: ADF Library Configuration

Set cache size for memory history

MEDIA_LIB_MEM_TRACE_SAVE_PATH

Memory trace save path
Found in: ADF Library Configuration

Set memory trace save path

2.10.4 Audio HAL

AUDIO_BOARD

Audio board
Found in: Audio HAL
Select an audio board to use with the ESP-ADF
Available options:

¢ AUDIO_BOARD_CUSTOM

« ESP_LYRAT_V4_3_BOARD

« ESP_LYRAT_V4_2_BOARD
ESP_LYRATD_MSC_V2_1_BOARD
ESP_LYRATD_MSC_V2_2_BOARD
ESP_LYRAT_MINI_V1_1_BOARD

2.10. Configuration Options
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» ESP32_KORVO_DU1906_BOARD

» ESP32_S2 KALUGA_1_V1_2_BOARD
» ESP32_S3_KORVO2_V3_BOARD

» ESP32_S3_KORVO2L_V1_BOARD

« ESP32_S3_BOX_LITE_BOARD

» ESP32_S3_BOX_BOARD

» ESP32_S3_BOX_3_BOARD

* ESP32_C3_LYRA_V2 BOARD

» ESP32_C6_DEVKIT_BOARD

» ESP32 P4 FUNCTION_EV_BOARD

ESP32_KORVO_DU1906_DAC

ESP32 KORVO DU1906 Board DAC chip
Found in: Audio HAL
Select DAC chip to use on ESP32_KORVO_DU1906 board
Available options:
» ESP32_KORVO_DU1906_DAC_TAS5805M
» ESP32_KORVO_DU1906_DAC_ES7148

ESP32_KORVO_DU1906_ADC

ESP32 KORVO DU1906 Board ADC chip

Found in: Audio HAL

Select ADC chip to use on ESP32_KORVO_DU1906 board
Available options:

« ESP32_KORVO_DU1906_ADC_ES7243
2.10.5 Audio Codec Device Configuration

CODEC_I2C_BACKWARD_COMPATIBLE

Enable backward compatibility for the I2C driver (force use of the old i2c_driver above v5.3)
Found in: Component config > Audio Codec Device Configuration

Enable this option for backward compatibility with the old I2C driver
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CODEC_ES8311_SUPPORT

Support ES8311 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ES8311.

CODEC_ES7210_SUPPORT

Support ES7210 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ES7210.

CODEC_ES7243_SUPPORT

Support ES7243 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ES7243.

CODEC_ES7243E_SUPPORT

Support ES7243E Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ES7243E.

CODEC_ES8156_SUPPORT

Support ES8156 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ES8156.

CODEC_AW88298_SUPPORT

Support AW88298 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec AW88298.

2.10. Configuration Options

323



ADF E40 i FAFF R HEZ2F 11, & 1 latest

CODEC_ES8374_SUPPORT

Support ES8374 Codec Chip
Found in: Component config > Audio Codec Device Configuration
Enable this option to support codec ES8374.

CODEC_ES8388_SUPPORT

Support ES8388 Codec Chip
Found in: Component config > Audio Codec Device Configuration
Enable this option to support codec ES8388.

CODEC_TAS5805M_SUPPORT

Support TAS5805M Codec Chip
Found in: Component config > Audio Codec Device Configuration
Enable this option to support codec TAS5805M.

CODEC_ZL38063_SUPPORT

Support Z1.38063 Codec Chip
Found in: Component config > Audio Codec Device Configuration

Enable this option to support codec ZL38063. Z1.38063 firmware only support xtensa, don’ t enable for
RISC-V IC.

2.10.6 DuerOS Service

DUEROS_GEN_PROFILE

Generate the nvs partition which include the profile of dueros

Found in: Component config > DuerOS Service

DUEROS_FLASH_PROFILE

Flash the generated nvs partition

Found in: Component config > DuerOS Service
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DUEROS_DEVICE_NAME

Duer device name

Found in: Component config > DuerOS Service
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CHAPTER 3

Design Guide

The ESP32 is a powerful chip well positioned as a MCU of the audio projects. This section is intended to provide guidance
on process of designing an audio project with the ESP32 inside.
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3.2 Design Considerations

Depending on the audio data format, that may be lossless, lossy or compressed, e.g. WAV, MP3 or FLAC and the quality
expressed in sampling rate and bitrate, the project will require different resources: memory, storage space, input / output
throughput and the processing power. The resources will also depend on the project type and features discussed in 771 H
%4t

This section describes capacity and performance of ESP32 system resources that should be considered when designing
an audio project to meet required data format, audio quality and functionality.
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3.2.1 Memory

The spare internal Data-RAM is about 290kB with “hello_world” example. For audio system this may be insufficient,
and therefore the ESP32 incorporates the ability to use up to 4MB of external SPI RAM (i.e. PSRAM) memory. The
external memory is incorporated in the memory map and is, within certain restrictions, usable in the same way internal
Data-RAM is.

Refer to External SPI-connected RAM section in IDF documenation for details, especially pay attention to its Restrictions
section which is very important.

To be able to use the PSRAM, if installed on your board, it should be enabled in menucofig under Component config >
ESP32-specific > SPI RAM config. The option CONFIG_SPIRAM_CACHE_WORKAROUND, set by default in the same
menu, should be kept enabled.

% 1¥: Bluetooth and Wi-Fi can not coexist without PSRAM because it will not leave enough memory for an audio
application.
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Optimization of Internal RAM and Use of PSRAM

Internal RAM is more valuable asset since there are some restrictions on PSRAM. Here are some tips for optimizing
internal RAM.

e If PSRAM is in use, set all the static buffer to minimum value in Component config > Wi-Fi; if PSRAM is not used
then dynamic buffer should be selected to save memory. Refer to Wi-Fi Buffer Usage section in IDF documentation
for details.

e If PSRAM and BT are used, then CONFIG_BT_ALLOCATION_FROM_ SPIRAM_FIRST and CON-
FIG_BT_BLE_DYNAMIC_ENV_MEMORY should be set as “yes” under Component config > Bluetooth >
Bluedroid Enable, to allocate more of 40kB memory to PSRAM

* If PSRAM and Wi-Fi are used, then CONFIG_WIFI_LWIP_ALLOCATION_FROM_SPIRAM_FIRST should be set
as “yes” under Component config > ESP32-specific > SPI RAM config, to allocate some memory to PSRAM

» Set CONFIG_WL_SECTOR_SIZE as 512 in Component config > Wear Levelling

£47:: The smaller the size of sector be, the slower the Write / Read speed will be, and vice versa, but only 512 and 4096
are supported.

e Call char *buf = heap_caps_malloc (1024 * 10, MALLOC_CAP_SPIRAM |
MALLOC_CAP_8BIT) instead of malloc (1024 * 10) to use PSRAM, and call char *buf =
heap_caps_malloc (512, MALLOC_CAP_INTERNAL | MALLOC_CAP_S8BIT) touse internal RAM.

* Not relying on malloc () to automatically allocate PSRAM allows to make a full control of the memory. By
avoiding the use of the internal RAM by othermalloc () calls, you can reserve more memory for high-efficiency
usage and task stack since PSRAM cannot be used as task stack memory.

e The task stack will always be allocated at internal RAM. On the other hand you can use of the
xTaskCreateStatic () function that allows to create tasks with stack on PSRAM (see options in PSRAM
and FreeRTOS menuconfig), but pay attention to its help information.

H%: Don’ tuse ROM code in xTaskCreateStatic task: The ROM code itself is linked in components/
esp32/1d/esp32.rom.1d. However, you also need to consider other pieces of code that call ROM functions, as
well as the code that is not recompiled against the CONFIG_SPIRAM_CACHE_WORKAROUND patch, like the Wi-Fi and
Bluetooth libraries. In general, we advise using this only in threads that do not call any IDF libraries (including libc),
doing only calculations and using FreeRTOS primitives to talk to other threads.

Memory Usage by Component Overview

Below is a table that contains ESP-ADF components and their memory usage. Choose the components needed and find
out how much internal RAM is left. The table is divided into two parts, when PSRAM is used or not. If PSRAM (external
RAM) is in use, then some of the memory will be allocated at PSRAM automatically.

The initial spare internal RAM is 290kB.

Component | Internal RAM Required

PSRAM not used With PSRAM
Wi-Fi ! 50kB+ 50kB+
Bluetooth 140kB (50kB if only BLE needed) | 95kB (50kB if only BLE needed)
Flash Card ? | 12kB+ 12kB+
1283 Configurable, 8kB for reference Configurable, 8kB for reference
RingBuffer # | Configurable, 30kB for reference OkB, all moved into PSRAM
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Notes to the table above

1.

According to the Wi-Fi menuconfig each Tx and Rx buffer occupies 1.6kB internal RAM. The value of 50kB RAM
is assuming use of 5 Rx static buffers and 6 Tx static buffers. If PSRAM is not in use, then the “Type of WiFi Tx
Buffer” option should be set as DYNAMIC in order to save RAM, in this case, the RAM usage will be far less than
50kB, but programmer should keep at least 50kB available for the Wi-Fi to be able to transmit the data. [Internal
RAM only]

Taking ESP32-LyraT V4.3 as an example, depending on value of SDCARD_OPEN_FILE_NUM_MAX in au-
dio_board/lyrat_v4_3/board_def.h, that is then used in sdcard_mount () function, the RAM needed will in-
crease with a greater number of maximum open files. 12kB is the RAM needed with 5 max files and 512 bytes
CONFIG_WL_SECTOR_SIZE. [Internal RAM only]

Depending on configuration settings of the I2S stream, refer to audio_stream/include/i2s_stream.h and au-
dio_stream/i2s_stream.c. [Internal RAM only]

Depending on configuration setting of the Ringbuffer, refer to DEFAULT PIPELINE_RINGBUF _SIZE in au-
dio_pipeline/include/audio_pipeline.h or user setting, if the buffer is created with e.g. rb_create ().

3.2.2 System Settings

The following settings are recommended to achieve a high Wi-Fi performance in an audio project.

#&1¥#: Use ESP32 modules and boards from reputable vendors that put attention to product design, component selection
and product testing. This is to have confidence of receiving well designed boards with calibrated RF.

* Set these following options in menuconfig.

Flash SPI mode as QIO
Flash SPI speed as SOMHz
CPU frequency as 240MHz

Set Default receive window size as 5 times greater than Maximum Segment Size in Component config > LWIP
>TCP

If external antenna is used, then set PHY RF_CAL_PARTIAL as PHY RF_CAL_FULL in *‘ ’ esp-
idf/components/esp32/phy_init.c’’

3.3 Software Design

Espressif audio framework project.

3.3.1 Features

A

All of Streams and Codecs based on audio element.
All events based on queue.

Audio pipeline supports dynamic combination.
Audio pipeline supports multiple elements.

Pipeline Support functionality plug-in.
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Audio common peripherals support work in the one task.
Support post-event mechanism in peripherals.
Support high level audio play API based on element and audio pipeline.

Audio high level interface supports dynamic adding of codec library.

© Y ® =2

Audio high level interface supports dynamic adding of input and output stream.

11. ESP audio supports multiple audio pipelines.

3.3.2 Desigh Components

Five basic components are - Audio Element, Audio Event, Audio Pipeline, ESP peripherals, ESP audio

Audio Element

Example

Please refer to audio_stream/fatfs_stream.c for an example of using an audio element.

Audio Event

Example

Please refer to player/pipeline_http_mp3/main/play_http_mp3_example.c for an example of using an audio event.
Audio Pipeline

Example

Please refer to player/pipeline_play_sdcard_music/main/play_sdcard_music_example.c for an example of linking ele-
ments into an audio pipeline.

Audio Peripheral

Example

ESP_LOGI (TAG, "[ 3 ] Start and wait for Wi-Fi network");
esp_periph_config_t periph_cfg = DEFAULT_ESP_PERIPH_SET_CONFIG() ;
esp_periph_set_handle_t set = esp_periph_set_init (&éperiph_cfqg);
periph_wifi_cfg_t wifi_cfg = {
.wifi_config.sta.ssid = CONFIG_WIFI_SSID,
.wifi_config.sta.password = CONFIG_WIFI_PASSWORD,
bi
esp_periph_handle_t wifi_handle = periph_wifi_init (s&wifi_cfqg);
esp_periph_start (set, wifi_handle);
periph_wifi_wait_for_connected(wifi_handle, portMAX_ DELAY);
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Audio Player

Example

Please refer to cli for an example of initializing esp_audio as an audio player.

3.4 Development Boards

Below are getting started guides and hardware details of audio development boards designed by Espressif.
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Getting Started with ESP32-LyraT

Getting Started with ESP32-LyraT-Mini

Hardware Reference of ESP32-LyraT

Hardware Reference of ESP32-LyraT-Mini

Getting Started with ESP32-Korvo-DU1906

Getting Started with ESP32-S3-Korvo-2
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o ESP32-LyraT-Mini V1.2 J5 7 [¥] (PDF)

e ESP32-LyraT-Mini V1.2 R 5t & (PDF)

o ESP32-LyraT-Mini V1.2 Hardware Reference
ESP32 $ AR HLHS 15 (PDF)

e ESP32-WROVER-E $; R##% 4 (PDF)

3.4.2 ESP32-LyraT-Mini V1.2 Hardware Reference

This guide provides functional descriptions and configuration options for ESP32-LyraT-Mini V1.2 audio development
board. As an introduction to functionality and using the LyraT, please see ESP32-LyraT-Mini V1.2 X145 %.

In this Section

e QOverview

* Functional Description

e Allocation of ESP32 Pins to Test Points
— JTAG Test Point
— UART Test Point

* MicroSD Card

GPIO Allocation Summary
* Notes on Power Distribution

— Power Supply over USB and from Battery

— Independent Audio and Digital Power Supply
o Selecting of the Audio Output

o Related Documents

Overview

ESP32-LyraT is a hardware platform designed for the dual-core ESP32 audio applications, e.g., Wi-Fi or BT audio
speakers, speech-based remote controllers, connected smart-home appliances with one or more audio functionality, etc.

The block diagram below presents main components of ESP32-LyraT-Mini.
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Kl 6: ESP32-LyraT-Mini V1.2 Electrical Block Diagram

Functional Description

The following list and figure describe key components, interfaces, and controls of the ESP32-LyraT-Mini board. The list
provides description starting from the picture’ s top right corner and going clockwise.

MicroSD Slot The development board supports a MicroSD card in SPI/1-bit modes, and can store or play audio files in
the MicroSD card. See MicroSD Card for pinout details.

Microphone On-board microphone connected to AINRP/AINRP of the Audio ADC Chip.

System LEDs Two general purpose LEDs (green and red) controlled by ESP32-WROVER-E Module to indicate
certain operation states of the audio application using dedicated API.

Audio Codec The audio codec chip, ES8311, is a low power mono audio codec. It consists of 1-channel ADC, 1-
channel DAC, low noise pre-amplifier, headphone driver, digital sound effects, analog mixing, and gain functions.
Itis interfaced with ESP32-WROVER-E Module over 12S and I2C buses to provide audio processing in hardware
independently from the audio application.

Audio Output Output socket to connect headphones with a 3.5 mm stereo jack. One of the socket’ s terminals is wired
to ESP32 to provide jack insertion detection.

ADC The audio codec chip, ES7243, is a low power multi-bit delta-sigma audio ADC and DAC. In this board this chip
is used as the microphone interface.

PA A power amplifier used to amplify the audio signal from the Audio Codec Chip for driving the speaker.

Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins have a
2.00 mm / 0.08” pitch.

Function Press Keys Six press keys labeled Rec, Mode, Play, Set, Vol-, and Vol+. They are routed to ESP32-
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WROVER-E Module and intended for development and testing of a Ul for audio applications using dedicated
APL

UART Terminals JTAG Terminals

10000000 e
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ESP32-WROVER-E
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Power On LED
Power On Switch

System
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ESP32-LyraT-Mini_V1.2
USB-UART Port

Automatic Upload

Reset / Boot Press Keys Function Press Keys

& 7: ESP32 LyraT-Mini V1.2 Board Layout

Boot/Reset Press Keys Boot: holding down the Boot button and momentarily pressing the Reset button initiates the
firmware upload mode. Then user can upload firmware through the serial port. Reset: pressing this button alone
resets the system.

Automatic Upload A simple two transistor circuit to put ESP32 into firmware upload mode depending on the status of
UART DTR and RTS signals. The signals are controlled by an external application to upload the firmware over the
USB-UART interface.

USB-UART Port Functions as the communication interface between a PC and the ESP32 module.
USB-UART Bridge A single chip USB-UART bridge CP2102N provides up to 3 Mbps transfers rates.
USB Power Port Provides the power supply for the board.

Standby/Charging LEDs The Standby green LED indicates that power has been applied to the USB Power Port. The
Charging red LED indicates that a battery connected to the Battery Socket is being charged.

Battery Socket Two-pin socket to connect a single cell Li-ion battery. The pins have a 2.00 mm / 0.08” pitch. The
battery serves as an alternative power supply to the USB Power Port for charging the board. Make sure to use a
Li-ion battery that has protection circuit and fuse. The recommended specifications of the battery: capacity > 1000
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mAbh, output voltage 3.7 V, input voltage 4.2 V -5 V. Please verify if polarity on the battery plug matches polarity
of the socket as marked on the board’ s soldermask besides the socket.

Battery Charger Constant current and constant voltage linear charger for single cell lithium-ion batteries AP5056. Used
for charging of a battery connected to the Battery Socket over the USB Power Port.

Power Supervisor Provides EN signal to enable ESP32 once power supply voltage stabilizes.

Power On Switch Power on/off knob: toggling it to the top powers the board on; toggling it to the down powers the
board off.

£241:: The Power On Switch does not affect / disconnect the Li-ion battery charging. More information, you can
refer to ESP32-LyraT-Mini V1.2 schematic (PDF).

Power On LED Red LED indicating that Power On Switch is turned on.

ESP32-WROVER-E Module The ESP32-WROVER-E module contains ESP32 chip to provide Wi-Fi / Bluetooth
connectivity and data processing power as well as integrates 4 MB external SPI flash and an additional 8§ MB
PSRAM for flexible data storage.

UART Termininals Serial port: provides access to the serial TX/RX signals between ESP32-WROVER-E Module
and USB-UART Bridge Chip. See UART Test Point for pinout details.

JTAG Termininals Provides access to the JTAG interface of ESP32-WROVER-E Module. It may be used for de-
bugging, application upload, as well as implementing several other functions, e.g., Application Level Tracing. See
JTAG Test Point for pinout details.

Allocation of ESP32 Pins to Test Points

This section describes allocation of test points available on the ESP32-LyraT-Mini board.

The test points are bare through hole solder pads and have standard 2.54 mm / 0.1 inch pitch. User may need to populate
them with pin headers or sockets for easy connection of external hardware.

JTAG Test Point

. | ESP32 Pin JTAG Signal
1 | MTDO / GPIO15 | TDO
2 | MTCK/GPIO13 | TCK
3 | MTDI/GPIO12 | TDI
4 | MTMS /GPIO14 | TMS
UART Test Point
. | ESP32 Pin | Pin Description
1 | RXDO RX
2 | TXDO TX
3 | GND GND
4 | n/a 33V
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MicroSD Card

Implemented on this board MicoSD card interface operates in SPI/1-bit mode. The board is able to support SPI/4-b it
mode after populating couple of additional components on locations reserved on the PCB. See ESP32-LyraT-Mini V1.2
schematic (PDF) for additional information. Not populated components are marked (NC) on the schematic.

. | ESP32 Pin MicroSD Signal
1 | MTDI/GPIO12 | —

2 | MTCK/GPIO13 | —

3 | MTDO/ GPIO15 | CMD

4 | MTMS/GPIO14 | CLK

5 | GPIO2 DATAO

6 | GPIO4 -

7 | GPIO34 CD

GPIO Allocation Summary

The table below provides allocation of GPIOs exposed on terminals of ESP32-WROVER-E Module to control specific
components or functions of the board.

PinT | Pin Name | ES8311 ES7243 Keys MicroSD Other

3 EN EN_KEY

4 S_VP 12S_DATA

5 S_VN REC, MODE, PLAY, SET, VOL-, VOL+

6 1034 CD

7 1035 12SO0_ASDOUT

8 1032 12S1_SCLK

9 1033 12S1_LRCK

10 1025 12SO_LRCK

11 1026 12S0_DSDIN

12 1027 Blue_LED

13 1014 CLK

14 1012 NC (DATA2)

16 1013 NC (DATA3)

17 SD2

18 SD3

19 CMD

20 CLK

21 SDO

22 SD1

23 1015 CMD

24 102 102_KEY DATAO

25 100 12S0_MCLK 12S1_MCLK | IO0_KEY

26 104 NC (DATA1)

27 NC (I016)

28 NC (I017)

29 105 12S0_SCLK

30 1018 12C_SDA 12C_SDA

31 1019 PJ_DET 2

33 1021 PA_CTRL’

TTI4RE:
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R1-ZIW

PinT [ Pin Name | ES8311 ES7243 Keys MicroSD Other

34 RXDO RXDO *

35 TXDO TXDO *

36 1022 Green_LED
37 1023 12C_SCK 12C_SCL

1. Pin - ESP32-WROVER-E module pin number, GND and power supply pins are not listed

PJ_DET - phone jack insertion detect signal

PA_CTRL - NS4150 power amplifier chip control signal

RXDO0, TXDO - serial communication signals connected to TXD and RXD pins of CP2102N USB-UART bridge

A

NC - not connected

Notes on Power Distribution

The ESP32-LyraT-Mini board provides some basic features to isolate noise from digital components by providing separate
power distribution for audio and digital subsystems.

Power Supply over USB and from Battery

There are two ways to power the development board: 5 V USB Power Port or 3.7 V optional battery. The optional battery
is preferable for applications where a cleaner power supply is required.

Independent Audio and Digital Power Supply

The board features independent power supplies to the audio components and the ESP32 module. This should reduce
noise in the audio signal from digital components and improve overall performance of the components.

Selecting of the Audio Output
The board provides a mono audio output signal on pins OUTN and OUTP of the ES8311 codec chip. The signal is routed
to two outputs:

¢ Power amplifier (PA) to drive an external speaker

* Phone jack socket to drive external headphones

The board design assumes that selection between one of these outputs is implemented in software, as opposed to using
traditional mechanical contacts in a phone jack socket, that would disconnect the speaker once a headphone jack is
inserted.

Two digital 1O signals are provided to implement selection between the speaker and the headphones:
* PJ_DET - digital input signal to o detect when a headphone jack is inserted,
« PA_CTRL - digital output signal to enable or disable the amplifier IC.

The application running on ESP32 may then enable or disable the PA with PA_CTRL basing on status of PJ_DET.
Please see GPIO Allocation Summary for specific GPIO numbers allocated to these signals.
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Power System:

USB<->UART:
VBUS VUSB
1 o
6 1
7| GND VBUS |5 b1 4
g |GND D/ ci
9 {GND D+ [H5—>
GND NC fFg—*
GND D2 E
USB_CONS LESD5D5.0CT1G ;
2
E
GND  GND GND
VBUS
2
6 %
[7| GND veus [5—F
3 gg :Et T - USE DP
e L
GND 3 bs ba
USB_CON8 LESDSDS5.0CT1G
LESDSD5.0CT1G
LESDSD5.0CT1G
GND GND

€l 8: ESP32-LyraT-Mini V1.2 - Dedicated USB Power Supply Socket
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Charge Circuit:
VBUS

R33 . A 1K(1%)
4 4 1K ,

Accurary of R4l should be 1

TEMP1 8 D11 RED LED
R41 1K(1%) 2 | TEMP __CE I3 N
GND STDBY M

4
T VCC  BAT g D12 GREEN LED
c15 .
= U6 AP50% = VBAT
5 GND
>
<
__g A 4 c16 |c18
= = 1 —-— =
— 2 o o
GND GND 5 e =
2 |5
" | g |3
A2001WR-S2P = g E
GND =
BATTERY = |2
3.7,2000mAh |
GND

K 9: ESP32-LyraT-Mini V1.2 - Power Supply from a Battery

Module Power Supply:

VBAT For_LDO US SGM2212-3.3XKC3G/TR VDD33
-
T 3 P 2 VouT W@Lﬁﬂj
+ + VIN < vour \ el
z 4
|-::1o |c11 O vour c12 |c13
3 |2 : £ R
5| % 2
2 2 2 2
8 |3 ABE
£ 2 2 £
y i =
DGND DGND DGND

&l 10: ESP32-LyraT-Mini V1.2 - Digital Power Supply
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Audio Power Supply:

VDD33 AU_3V3 Codec_3V3
VBAT_For_Audio ? 7
U7 RT9043GB@400mA

VIN

L3 ~~v~_OR(5%)

L5 _~v~v—~v_OR(5%)

5]

Audio_LDO_EN 3

| EN

ADC_3V3

(%01)A9 14N}

(%0Z)A91/4Nn0L
(%02A9L/an0tl [Q

[

AU_GND AU _GND

K 11: ESP32-LyraT-Mini V1.2 - Audio Power Supply
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o ESP32-LyraT V4.2 Getting Started Guide
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ESP32-LyraT V4.3 Hardware Reference

e ESP32 LyraT V4.3 schematic (PDF)

e ESP32-LyraT V4.3 Component Layout (PDF)
* ESP32 i A%+ (PDF)

« ESP32-WROVER-E $; K ##45 (PDF)

3.4.4 ESP32-LyraT V4.3 Hardware Reference

This guide provides functional descriptions, configuration options for ESP32-LyraT V4.3 audio development board. As
an introduction to functionality and using the LyraT, please see ESP32-LyraT V4.3 N 1145 #%. Check section Other
Versions of LyraT if you have different version of the board.

In this Section

e QOverview
e Functional Description
— Hardware Setup Options
« Enable MicroSD Card in 1-wire Mode
» Enable MicroSD Card in 4-wire Mode
x Enable JTAG
« Using Automatic Upload
— Allocation of ESP32 Pins

— Pinout of Extension Headers

x UART Header / JP2
« [2S Header / JP4
« [2C Header / JP5
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+ JTAG Header / JP7
— Notes of Power Distribution
» Power Supply Separation
# Three Dedicated LDOs
« Separate Power Feed for the PAs
— Selecting of the Audio Output
o Other Versions of LyraT

o Related Documents

Overview

The ESP32-LyraT development board is a hardware platform designed for the dual-core ESP32 audio applications, e.g.,
Wi-Fi or BT audio speakers, speech-based remote controllers, smart-home appliances with audio functionality(ies), etc.

The block diagram below presents main components of the ESP32-LyraT.

MIC1 & MIC2
1= R [N (A (' () W .
a7V sy MicroSD
—|* 1 —» Do |-
— Battery Auto Select [ A
i [Charger 5 2
; | Lpo @ v ) E
i 1 | —O/D_ > | Audio AUX
Power o Codec
Supply : 125 FE
= L DO 2% <—»| ES8388 :
USB1 ° 12¢ .
0 ESP32 Headphone
' o " -

: Automat Output
Programming > B;Io:dlc — WROVER-E :{E
UsB2 <« D | USB / UART L :

UART
‘ Vi3V | PA1
Q
) ) :
| PA2 |+
Push Buttons 1 - 4 Touch Pads 1 - 4 - '

K| 14: ESP32-LyraT V4.3 Electrical Block Diagram
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Functional Description

The following list and figure describe key components, interfaces and controls of the ESP32-LyraT board.

ESP32-WROVER-E Module The ESP32-WROVER-E module contains ESP32 chip to provide Wi-Fi / Bluetooth
connectivity and data processing power as well as integrates 4 MB external SPI flash and an additional 8 MB
PSRAM for flexible data storage.

Green LED A general purpose LED controlled by the ESP32-WROVER-E Module to indicate certain operation states
of the audio application using dedicated API.

Function DIP Switch Used to configure function of GPIO12 to GPIO15 pins that are shared between devices, primarily
between JTAG Header and MicroSD Card. By default, the MicroSD Card is enabled with all switches in OFF
position. To enable the JTAG Header instead, switches in positions 3, 4, 5 and 6 should be put ON. If JTAG is not
used and MicroSD Card is operated in the one-line mode, then GPIO12 and GPIO13 may be assigned to other
functions. Please refer to ESP32 LyraT V4.3 schematic for more details.

JTAG Header Provides access to the JTAG interface of ESP32-WROVER-E Module. It may be used for debugging,
application upload, as well as implementing several other functions, e.g., Application Level Tracing. See JTAG
Header /JP7 for pinout details. Before using JTAG signals to the header, Function DIP Switch should be enabled.
Please note that when JTAG is in operation, MicroSD Card cannot be used and should be disconnected because
some of JTAG signals are shared by both devices.

UART Header Serial port: provides access to the serial TX/RX signals between ESP32-WROVER-E Module and
USB-UART Bridge Chip.

I2C Header Provides access to the I12C interface. Both ESP32-WROVER-E Module and Audio Codec Chip are
connected to this interface. See I2C Header / JP5 for pinout details.

MicroSD Slot The development board supports a MicroSD card in SP1/1-bit/4-bit modes, and can store or play audio
files in the MicroSD card. Note that JTAG cannot be used and should be disconnected by setting Function DIP
Switch when MicroSD Card is in operation, because some of signals are shared by both devices.

I2S Header Provides access to the I2S interface. Both ESP32-WROVER-E Module and Audio Codec Chip are
connected to this interface. See 125 Header / JP4 for pinout details.

Left Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.

AUX Input Auxiliary input socket connected to IN2 (left and right channel) of the Audio Codec Chip. Use a 3.5 mm
stereo jack to connect to this socket.

Headphone Output Output socket to connect headphones with a 3.5 mm stereo jack.

£41:: The socket may be used with mobile phone headsets and is compatible with OMPT standard headsets only.
It does work with CTIA headsets. Please refer to Phone connector (audio) on Wikipedia.

Right Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.

Left Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

Right Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

PA Chip A power amplifier used to amplify stereo audio signal from the Audio Codec Chip for driving two speakers.

Boot/Reset Press Keys Boot button: holding down the Boot button and momentarily pressing the Reset button to initiate
the firmware download mode. Then you can download firmware through the serial port. Reset button: pressing
this button alone resets the system.
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&l 15: ESP32-LyraT V4.3 Board Layout
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Touch Pad Buttons Four touch pads labeled Play, Sel, Vol+ and Vol-. They are routed to ESP32-WROVER-E Module
and intended for development and testing of a UI for audio applications using dedicated APIL.

Audio Codec Chip The Audio Codec Chip, ES8388, is a low power stereo audio codec with a headphone amplifier.
It consists of 2-channel ADC, 2-channel DAC, microphone amplifier, headphone amplifier, digital sound effects,
analog mixing and gain functions. It is interfaced with ESP32-WROVER-E Module over 12S and I2S buses to
provide audio processing in hardware independently from the audio application.

Automatic Upload Install three jumpers on this header to enable automatic loading of application to the ESP32. Install
all jumpers together on all three headers. Remove all jumpers after upload is complete.

Function Press Keys Two key labeled Rec and Mode. They are routed to ESP32-WROVER-E Module and intended
for developing and testing a UI for audio applications using dedicated API.

USB-UART Bridge Chip A single chip USB-UART bridge provides up to 1 Mbps transfers rate.
USB-UART Port Functions as the communication interface between a PC and the ESP32 module.
USB Power Port Provides the power supply for the board.

Standby / Charging LEDs The Standby green LED indicates that power has been applied to the Micro USB Port.
The Charging red LED indicates that a battery connected to the Battery Socket is being charged.

Battery Socket Two pins socket to connect a single cell Li-ion battery.

4 1k:  Please verify if polarity on the battery plug matches polarity of the socket as marked on the board’ s
soldermask besides the socket.

Battery Charger Chip Constant current & constant voltage linear charger for single cell lithium-ion batteries AP5056.
Used for charging of a battery connected to the Battery Socket over the Micro USB Port.

Power On LED Red LED indicating that Power On Switch is turned on.

#&1¥: The Power On Switch does not affect / disconnect the Li-ion battery charging.

Power Switch Power on/off knob: toggling it to the left powers the board on; toggling it to the right powers the board
off.

Hardware Setup Options

There are a couple of options to change the hardware configuration of the ESP32-LyraT board. The options are selectable
with the Function DIP Switch.

Enable MicroSD Card in 1-wire Mode

DIP SW | Position
OFF
OFF
OFF
OFF
OFF
OFF
OFF !
n/a

0| [N N KW I~
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1. AUX Input detection may be enabled by toggling the DIP SW 7 ON. Note that the AUX Input signal pin should
not be be plugged in when the system powers up. Otherwise the ESP32 may not be able to boot correctly.

In this mode:
* JTAG functionality is not available

¢ Vol- touch button is available for use with the API

Enable MicroSD Card in 4-wire Mode

DIP SW | Position
ON

ON
OFF
OFF
OFF
OFF
OFF

n/a

ol A V| | K| W DI —

In this mode:
* JTAG functionality is not available
¢ Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available

Enable JTAG

DIP SW | Position
OFF
OFF
ON

ON

ON

ON

ON

n/a

O AN KW | —

In this mode:
* MicroSD Card functionality is not available, remove the card from the slot
¢ Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available
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Using Automatic Upload

Entering of the ESP32 into upload mode may be done in two ways:

* Manually by pressing both Boot and RST keys and then releasing first RST and then Boot key.

¢ Automatically by software performing the upload. The software is using DTR and RTS signals of the serial inter-
face to control states of EN, I00 and 102 pins of the ESP32. This functionality is enabled by installing jumpers
in three headers JP23, JP24 and JP25. For details see ESP32 LyraT V4.3 schematic. Remove all jumpers after

upload is complete.

Allocation of ESP32 Pins

Several pins ESP32 module are allocated to the on board hardware. Some of them, like GPIO0 or GPIO2, have multiple

functions. Please refer to the table below or ESP32 LyraT V4.3 schematic for specific details.

GPIO Pin Type | Function Definition
SENSOR_VP | 1 Audio Rec (PB)

SENSOR_VN | I Audio Mode (PB)

1032 1/0 Audio Set (TP)

1033 1/0 Audio Play (TP)

1027 1/0 Audio Vol+ (TP)

1013 1/0 JTAG MTCK, MicroSD D3, Audio Vol- (TP)
1014 1/0 JTAG MTMS, MicroSD CLK
1012 1/0 JTAG MTDI, MicroSD D2, Aux signal detect
1015 1/0 JTAG MTDO, MicroSD CMD
102 1/0 Automatic Upload, MicroSD D0
104 1/0 MicroSD D1

1034 I MicroSD insert detect

100 /0 Automatic Upload, 12S MCLK
105 1/0 12S SCLK

1025 /0 I12S LRCK

1026 1/0 12S DSDIN

1035 I 12S ASDOUT

1019 1/0 Headphone jack insert detect
1022 1/0 Green LED indicator

1021 1/0 PA Enable output

1018 1/0 12C SDA

1023 1/0 12C SCL

¢ (TP) - touch pad
¢ (PB) - push button
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Pinout of Extension Headers

There are several pin headers available to connect external components, check the state of particular signal bus or debug

operation of ESP32. Note that some signals are shared, see section Allocation of ESP32 Pins for details.

UART Header / JP2

12S Header / JP4

12C Header / JP5

JTAG Header / JP7

Header Pin

3.3V

X

RX

AW N —

GND

12C Header Pin | ESP32 Pin
1 | MCLK GPIO
2 | SCLK GPIOS
1 | LRCK GPIO25
2 | DSDIN GPIO26
3 | ASDOUT GPIO35
3 | GND GND
12C Header Pin | ESP32 Pin
1 | SCL GPIO23
2 | SDA GPIO18
3 | GND GND
ESP32 Pin JTAG Signal
1 | MTDO / GPIO15 | TDO
2 | MTCK /GPIO13 | TCK
3 | MTDI/ GPIO12 TDI
4 | MTMS / GPIO14 | TMS
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Notes of Power Distribution

The board features quite extensive power distribution system. It provides independent power supplies to all critical com-
ponents. This should reduce noise in the audio signal from digital components and improve overall performance of the

components.

Power Supply Separation

The main power supply is 5V and provided by a USB. The secondary power supply is 3.7V and provided by an optional
battery. The USB power itself is fed with a dedicated cable, separate from a USB cable used for an application upload.
To further reduce noise from the USB, the battery may be used instead of the USB.

Power System:

USB<->UART: Charge Circuit:
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& 16: ESP32 LyraT V4.3 - Power Supply Separation

360 Chapter 3. Design Guide



ADF E45R AF ZEZRF M, A7 latest

Three Dedicated LDOs

ESP32 Module
To provide enough current the ESP32, the development board adopts LD1117S33CTR LDO capable to supply the max-

imum output current of 800mA.

Module Power Supply:

VBAT_For_LDO U3 VDD33
-
3 3 2 5
N 2 vour _ yout 120 OR(1%) |
g YT
R16 & vour
[ [D1117833CTR
K(1%) c13 191 10 c14
" TouFev(10%) b.1uFr16v(10%) UF/18Y(10%) MOUF/6Y(10%)
D8
RED LED
3
4£ — pe— — 0
= = = = benp || Re22 OR(G%) | gnp
DGND DGND DGND DGND v

Kl 17: ESP32 LyraT V4.3 - Dedicated LDO for the ESP32 Module
MicroSD Card and Audio Codec

Two separate LDOs are provided for the MicorSD Card and the Audio Codec. Both circuits have similar design that
includes an inductor and double decoupling capacitors on both the input and output of the LDO.

SDIO Power Supply:

VBAT_For_SDIO
o GND

u9

3.3V/150mA
e SDIO_3V3

0y AR
L13 3A@1200hm(25%),25mohm VIN VOUT

/ R223 2 | aND
o —— ik 3 4

[}
(8}
o
©
e}
[N}
=}
=
[¢]
R
=
%)
N
=
~

Murata: J—
BLM18SG121TN1D ON/OFF BYPASS p—
[P2985A-33DBVT

0.1uF/16Y(10%)

-

R224 c208

10uF/16V/(10%)

10nF/50V(10%)

10UF/16V(10%)
1UF/25V(10%)

10K(1%)(NC)

GND GND

9]
=z
o
(2]
Z
[w]

K 18: ESP32 LyraT V4.3 - Dedicated LDO for the MicroSD Card
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Separate Power Feed for the PAs

The audio amplifier unit features two NS4150 that require a large power supply for driving external speakers with the
maximum output power of 3W. The power is supplied directly to both PAs from the battery or the USB. The development
board adds a set of LC circuits at the front of the PA power supply, where L uses 1.5A magnetic beads and C uses 10uF

aluminum electrolytic capacitors, to effectively filter out power crosstalk.

©\VDD33
PA Output:
R143
10K(1%)(NC) ut1
1021 R144 OR(1%) 1 8 PA_OUTL+
2 |CTRL = OUT+ 7 1. 5A@1800hm(25%) 90mohm(BLM18PG181SN1D)
PA_INL+ 3 | Bypass  GND g PA_PVDD1 L8 VBAT_For_Audio
PA_INL- 4| IN+ Vee s PA_OUTL-
R142 IN- ouT- 98
10K(1%) k224 +C101
NS4150 uF8v(10%)
uFI16V(10% RVT 10UF/16V(10%)
AU_GN AU_GND AU_GND =
AU_GND
©VDD33
R236
10K(1%)(NC)
u12
1 8 PA_OUTR+
2 gTRL OGUJS 7 1. 5A@1800hm(25%) 90mohm(BLM18PG181SN1D)
PA_INR+ 3| Bypass 5 PA_PVDD2 114 VBAT_For_Audio
R235  PA_INR- 4| N+ Vee 75 PA_OUTR-
10K(1%) IN- ouT- 215
k225 +C213
NS4150 huFev(10%)
uFmsv 10%) RVT 10uF/16V(10%)
U_GN AU_GND AU_GND

AU_GND

& 19: ESP32 LyraT V4.3 - Power Supply for the PAs

Selecting of the Audio Output

The development board uses two mono Class D amplifier ICs, model number NS4150 with maximum output power of
3W and operating voltage from 3.0V to 5.25V.

The audio input source is the digital-to-analog converter (DAC) output of the ES8388. Audio output supports two external
speakers.

An optional audio output is a pair of headphones feed from the same DACs as the amplifier ICs.

To switch between using headphones and speakers, the board provides a digital input signal to detect when a headphone
jack is inserted and a digital output signal to enable or disable the amplifier ICs. In other words selection between
speakers and headphones is under software control instead of using mechanical contacts that would disconnect speakers
once a headphone jack is inserted.
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Other Versions of LyraT

o ESP32-LyraT V4.2 Getting Started Guide
o ESP32-LyraT V4 Getting Started Guide

Related Documents

e ESP32 LyraT V4.3 schematic (PDF)

o ESP32-LyraT V4.3 X115

e ESP32 Datasheet (PDF)

¢ ESP32-WROVER-E Datasheet (PDF)
* JTAG Debugging

3.4.5 ESP32-LyraT V4.2 Getting Started Guide
This guide provides users with functional descriptions, configuration options for ESP32-LyraT V4.2 audio development
board, as well as how to get started with the ESP32-LyraT board.

The ESP32-LyraT development board is a hardware platform designed for the dual-core ESP32 audio applications, e.g.,
Wi-Fi or BT audio speakers, speech-based remote controllers, smart-home appliances with audio functionality(ies), etc.

If you like to start using this board right now, go directly to section Start Application Development.

What You Need

e 1 x ESP32 LyraT V4.2 board

* 2 x Speaker or headphones with a 3.5 mm jack. If you use a speaker, it is recommended to choose one no more
than 3 watts, and JST PH 2.0 2-Pin plugs are needed. In case you do not have this type of plug it is also fine to use
Dupont female jumper wires during development.

¢ 2 x Micro-USB 2.0 cables, Type A to Micro B
¢ 1 x PC loaded with Windows, Linux or Mac OS

Overview

The ESP32-LyraT V4.2 is an audio development board produced by Espressif built around ESP32. It is intended for
audio applications, by providing hardware for audio processing and additional RAM on top of what is already onboard of
the ESP32 chip. The specific hardware includes:

+ ESP32-WROVER Module"

* Audio Codec Chip

* Dual Microphones on board

* Headphone input

¢ 2 x 3-watt Speaker output

* Dual Auxiliary Input

¢ MicroSD Card slot (1 line or 4 lines)
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¢ Six buttons (2 physical buttons and 4 touch buttons)
¢ JTAG header
¢ Integrated USB-UART Bridge Chip
¢ Li-ion Battery-Charge Management
The superscript * indicates that the product is in EOL status. The same applies below.

The block diagram below presents main components of the ESP32-LyraT and interconnections between components.

Wi-Fi / BT
>
I—I A
BAT - . ‘
' : | Battery . -
T = 3 ESP32 f-
. : Charger Audio
| : : Codec
UsB

gy Edpt

Keys f Touch Pads

......................................................................................................

€l 20: ESP32-LyraT Block Diagram

Functional Description

The following list and figure describe key components, interfaces and controls of the ESP32-LyraT board.

ESP32-WROVER Module® The ESP32-WROVER module” contains ESP32 chip to provide Wi-Fi / BT connectivity
and data processing power as well as integrates 32 Mbit SPI flash and 32 Mbit PSRAM for flexible data storage.

Green and Red LEDs Two general purpose LEDs controlled by ESP32-WROVER Module” to indicate certain op-
eration states of the audio application using dedicated API.

Function DIP Switch Used to configure function of GPIO12 to GPIO15 pins that are shared between devices, primarily
between JTAG Header and MicroSD Card. By default, the MicroSD Card is enabled with all switches in OFF
position. To enable the JTAG Header instead, switches in positions 3, 4, 5 and 6 should be put ON. If JTAG is not
used and MicroSD Card is operated in the one-line mode, then GPIO12 and GPIO13 may be assigned to other
functions. Please refer to ESP32 LyraT V4.2 schematic for more details.

JTAG Header Provides access to the JTAG interface of ESP32-WROVER Module”. It may be used for debugging,
application upload, as well as implementing several other functions, e.g., Application Level Tracing. See JTAG
Header /JP7 for pinout details. Before using JTAG signals to the header, Function DIP Switch should be enabled.
Please note that when JTAG is in operation, MicroSD Card cannot be used and should be disconnected because
some of JTAG signals are shared by both devices.
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UART Header Serial port: provides access to the serial TX/RX signals between ESP32-WROVER Module” and
USB-UART Bridge Chip.

I2C Header Provides access to the 12C interface. Both ESP32-WROVER Module” and Audio Codec Chip are con-
nected to this interface. See /2C Header / JP5 for pinout details.

MicroSD Card The development board supports a MicroSD card in SPI/1-bit/4-bit modes, and can store or play audio
files in the MicroSD card. See MicroSD Card / J5 for pinout details. Note that JTAG cannot be used and should
be disconnected by setting Function DIP Switch when MicroSD Card is in operation, because some of signals
are shared by both devices.

12S Header Provides access to the 128 interface. Both ESP32-WROVER Module” and Audio Codec Chip are con-
nected to this interface. See /25 Header / JP4 for pinout details.

Left Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.

AUX Input Auxiliary input socket connected to IN2 (left and right channel) of the Audio Codec Chip. Use a 3.5 mm
stereo jack to connect to this socket.

Headphone Output Output socket to connect headphones with a 3.5 mm stereo jack.

‘ TAG ‘ UART
ESP3§0\3’$SVER Header !Header MicroSD 125
Card Header
12C
Header

——
Green LED DIP Switch

et G ER ¥ ¥ senBfAy
& @

Left
Microphone

Power On
LED
= AUX Input
Power On : . : ‘.
Switch aly . T .
: 32_L1¥ra1' _EE o Headphone
Battery £ : .E = . : B _"; = : Lﬂput
Charger Chip > = = 4 ea : k:
! = : 5 Right
Battery Socket . Microphone
Stanby / - f-)
Charging LEDs g Left
— | Speaker
USB Power Port Qutput
Right
Speaker
: Output
USB-UART Port
PA
USB-UART e \ / \ / . Chip
Bridge Chip i Volt )
Function 100 EN Audio Codec Touch Pad Boot / Reset
Press Keys Header || Header Chip Buttons Press Keys

& 21: ESP32-LyraT V4.2 Board Layout

Right Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.
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Left Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

Right Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

PA Chip A power amplifier used to amplify stereo audio signal from the Audio Codec Chip for driving two speakers.

Boot/Reset Press Keys Boot: holding down the Boot button and momentarily pressing the Reset button initiates the
firmware upload mode. Then user can upload firmware through the serial port. Reset: pressing this button alone
resets the system.

Touch Pad Buttons Four touch pads labeled Play, Sel, Vol+ and Vol-. They are routed to ESP32-WROVER Module”
and intended for development and testing of a UI for audio applications using dedicated API.

Audio Codec Chip The Audio Codec Chip, ES8388, is a low power stereo audio codec with a headphone amplifier.
It consists of 2-channel ADC, 2-channel DAC, microphone amplifier, headphone amplifier, digital sound effects,
analog mixing and gain functions. It is interfaced with ESP32-WROVER Module" over 12S and 12S buses to
provide audio processing in hardware independently from the audio application.

EN Header Install a jumper on this header to enable automatic loading of application to the ESP32. Install or remove
jumpers together on both I00 and EN headers.

100 Header Install a jumper on this header to enable automatic loading of application to the ESP32. Install or remove
jumpers together on both I00 and EN headers.

Function Press Keys Two key labeled Rec and Mode. They are routed to ESP32-WROVER Module” and intended
for developing and testing a Ul for audio applications using dedicated API.

USB-UART Bridge Chip A single chip USB-UART bridge provides up to 1 Mbps transfers rate.
USB-UART Port Functions as the communication interface between a PC and the ESP32 module.
USB Power Port Provides the power supply for the board.

Standby / Charging LEDs The Standby green LED indicates that power has been applied to the Micro USB Port.
The Charging red LED indicates that a battery connected to the Battery Socket is being charged.

Battery Charger Chip Constant current & constant voltage linear charger for single cell lithium-ion batteries AP5056.
Used for charging of a battery connected to the Battery Socket over the Micro USB Port.

Power On Switch Power on/off knob: toggling it to the left powers the board on; toggling it to the right powers the board
off.

Battery Socket Two pins socket to connect a single cell Li-ion battery.

Power On LED Red LED indicating that Power On Switch is turned on.

#&1¥: The Power On Switch does not affect / disconnect the Li-ion battery charging.
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Hardware Setup Options

There are a couple of options to change the hardware configuration of the ESP32-LyraT board. The options are selectable

with the Function DIP Switch.

Enable MicroSD Card in 1-wire Mode

DIP SW | Position
OFF
OFF
OFF
OFF
OFF
OFF
OFF !
n/a

O | O\ | K| W DI —

1. AUX Input detection may be enabled by toggling the DIP SW 7 ON
In this mode:
* JTAG functionality is not available

¢ Vol- touch button is available for use with the API

Enable MicroSD Card in 4-wire Mode

DIP SW | Position
ON

ON
OFF
OFF
OFF
OFF
OFF

n/a

O | O\ | K| WD —

In this mode:
* JTAG functionality is not available
¢ Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available
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Enable JTAG

In this mode:

¢ MicroSD Card functionality is not available, remove the card from the slot

DIP SW

Position

OFF

OFF

ON

ON

ON

ON

ON

O AN | KW —

n/a

¢ Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available

Allocation of ESP32 Pins

Several pins / terminals of ESP32 modules are allocated to the on board hardware. Some of them, like GPIOO or GP102,
have multiple functions. Please refer to the tables below or ESP32 LyraT V4.2 schematic for specific details.

Red / Green LEDs

Touch Pads

ESP32 Pin | LED Color
1 | GPIO19 Red LED
2 | GPIO22 Green LED

ESP32 Pin | Touch Pad Function

GPIO33 Play

GPIO32 Set

GPIO13 Vol- 1

Bl =

GPIO27 Vol+

1. Vol- function is not available if JTAG is used. It is also not available for the MicroSD Card configured to operate

in 4-wire mode.
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MicroSD Card / J5

UART Header / JP2

ESP32 Pin

MicroSD Signal

MTDI / GPIO12

DATA2

MTCK / GPIO13

CD / DATA3

MTDO / GPIO15

CMD

MTMS / GPIO14

CLK

GPIO2

DATAO

GPIO4

DATA1

NN AW~

GPIO21

CD

Header Pin

3.3V

X

RX

AW N —

GND

EN and 100 Headers / JP23 and J24

12S Header / JP4

ESP32 Pin

Header Pin

1 | n/a

EN_Auto

2 | EN

EN

ESP32 Pin

Header Pin

1 | n/a

100_Auto

GPIOO0

100

12C Header Pin | ESP32 Pin
1 | MCLK GPIO
2 | SCLK GPIO5
1 | LRCK GPIO25
2 | DSDIN GPIO26
3 | ASDOUT GPIO35
3 | GND GND
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12C Header / JP5

12C Header Pin | ESP32 Pin

1 | SCL GPI023

2 | SDA GPIO18

3 | GND GND

JTAG Header / JP7
ESP32 Pin JTAG Signal

1 | MTDO / GPIO15 | TDO
2 | MTCK /GPIO13 | TCK
3 | MTDI/ GPIO12 TDI
4 | MTMS / GPIO14 | TMS

Function DIP Switch / JP8

Switch OFF Switch ON
1 | GPIO12 not allocated | MicroSD Card 4-wire
2 | Touch Vol- enabled MicroSD Card 4-wire
3 | MicroSD Card JTAG
4 | MicroSD Card JTAG
5 | MicroSD Card JTAG
6 | MicroSD Card JTAG
7 | MicroSD Card 4-wire | AUX IN detect !
8 | not used not used

1. The AUX Input signal pin should not be be plugged in when the system powers up. Otherwise the ESP32 may not
be able to boot correctly.

Start Application Development

Before powering up the ESP32-LyraT, please make sure that the board has been received in good condition with no
obvious signs of damage.

Initial Setup

Prepare the board for loading of the first sample application:

1. Install jumpers on IO0 and EN headers to enable automatic application upload. If there are no jumpers then upload
may be triggered using Boot / RST buttons.

2. Connect speakers to the Right and Left Speaker Output.Connecting headphones to the Headphone Output is
an option.

3. Plug in the Micro-USB cables to the PC and to both USB ports of the ESP32 LyraT.

4. The Standby LED (green) should turn on. Assuming that a battery is not connected, the Charging LED will
blink every couple of seconds.
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5. Toggle left the Power On Switch.
6. The red Power On LED should turn on.

If this is what you see on the LEDs, the board should be ready for application upload. Now prepare the PC by loading
and configuring development tools what is discussed in the next section.

Develop Applications

Once the board is initially set up and checked, you can start preparing the development tools. The Section Installation
Step by Step will walk you through the following steps:

* Set up ESP-IDF to get a common development framework for the ESP32 (and ESP32-S2) chips in C language;
* Get ESP-ADF to install the API specific to audio applications;

* Set up env to make the framework aware of the audio specific API,;

 Start a Project that will provide a sample audio application for the board;

* Connect Your Device to prepare the application for loading;

¢ Build the Project to finally run the application and play some music.

Related Documents

e ESP32 LyraT V4.2 schematic (PDF)
¢ ESP32 Datasheet (PDF)

JTAG Debugging
o ESP32-LyraT V4 Getting Started Guide

3.4.6 ESP32-LyraT V4 Getting Started Guide

This guide provide users with functional descriptions, configuration options for ESP32-LyraT V4 audio development
board, as well as how to get started with ESP32-LyraT board.

The ESP32-LyraT development board is a hardware platform specifically designed for the dual-core ESP32 audio appli-
cations, e.g., Wi-Fi or BT audio speakers, speech-based remote controllers, smart-home appliances with audio function-
ality(ies), etc.

If you like to start using this board right now, go directly to section Start Application Development.

What You Need

e 1 x ESP32-LyraT V4 board

» 2 x Speaker or headphones with a 3.5 mm jack. If you use a speaker, it is recommended to choose one no more
than 3 watts, and JST PH 2.0 2-Pin plugs are needed. In case you do not have this type of plug it is also fine to use
Dupont female jumper wires during development.

* 1 x Micro USB 2.0 Cable, Type A to Micro B
¢ 1 x PC loaded with Windows, Linux or Mac OS
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Overview

The ESP32-LyraT V4 is an audio development board produced by Espressif built around ESP32. It is intended for audio
applications, by providing hardware for audio processing and additional RAM on top of what is already onboard of the
ESP32 chip. The specific hardware includes:

+ ESP32-WROVER Module”
¢ Audio Codec Chip
¢ Dual Microphones on board
* Headphone input
* 2 x 3 Watt Speaker output
¢ Dual Auxiliary Input
e MicroSD Card slot (1 line or 4 lines)
* 6 buttons (2 physical buttons and 4 touch buttons)
¢ JTAG header
¢ Integrated USB-UART Bridge Chip
¢ Li-ion Battery-Charge Management
The superscript * indicates that the product is in EOL status. The same applies below.

The block diagram below presents main components of the ESP32-LyraT and interconnections between components.

Wi-Fi / BT
f-\ﬁ
'y |
BAT | ; :
( : | Batt ; :
(Ul : Cr?ar&;;gr ESP32

[ uses | | e praes
I UART

o ESP32 Lyral |

& 22: ESP32-LyraT block diagram
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Functional Description

The following list and figure below describe key components, interfaces and controls of the ESP32-LyraT board.

ESP32-WROVER Module® The ESP32-WROVER" module contains ESP32 chip to provide Wi-Fi / BT connectivity
and data processing power as well as integrates 32 Mbit SPI flash and 32 Mbit PSRAM for flexible data storage.

Green and Red LEDs Two general purpose LEDs controlled by ESP32-WROVER Module” to indicate certain op-
eration states of the audio application using dedicated API.

Function DIP Switch Used to configure function of GPIO12 to GPIO1S5 pins that are shared between devices, primarily
between JTAG Header and MicroSD Card. By default MicroSD Card is enabled with all switches in OFF
position. To enable JTAG Header instead, switches in positions 3, 4, 5 and 6 should be put ON. If JTAG is
not used and MicroSD Card is operated in one-line mode, then GPIO12 and GPIO13 may be assigned to other
functions. Please refer to ESP32 LyraT V4 schematic for more details.

JTAG Header Provides access to the JTAG interface of ESP32-WROVER Module". May be used for debugging,
application upload, as well as implementing several other functions, e.g., Application Level Tracing. See JTAG
Heacder /JP7 for pinout details. Before using JTAG signals to the header, Function DIP Switch should be enabled.
Please note that when JTAG is in operation, MicroSD Card cannot be used and should be disconnected because
some of JTAG signals are shared by both devices.

UART Header Serial port provides access to the serial TX/RX signals between ESP32-WROVER Module” and USB-
UART Bridge Chip.

12C Header Provides access to the I2C interface. Both ESP32-WROVER Module” and Audio Codec Chip are con-
nected to this interface. See I2C Header / JP5 for pinout details.

MicroSD Card The development board supports a MicroSD card in SPI/1-bit/4-bit modes, and can store or play audio
files in the MicroSD card. See MicroSD Card /J5 for pinout details. Note that JTAG cannot be used and should be
disconnected by setting Function DIP Switch when MicroSD Card is in operation, because some of the signals
are shared by both devices.

I12S Header Provides access to the 128 interface. Both ESP32-WROVER Module” and Audio Codec Chip are con-
nected to this interface. See /25 Header / JP4 for pinout details.

Left Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.

AUX Input Auxiliary input socket connected to IN2 (left and right channels) of the Audio Codec Chip. Use a 3.5 mm
stereo jack to connect to this socket.

Headphone Output Output socket to connect headphones with a 3.5 mm stereo jack.
Right Microphone Onboard microphone connected to IN1 of the Audio Codec Chip.

Left Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

Right Speaker Output Output socket to connect a speaker. The 4-ohm and 3-watt speaker is recommended. The pins
have a 2.00 mm / 0.08” pitch.

PA Chip A power amplifier used to amplify stereo audio signal from the Audio Codec Chip for driving two speakers.

Boot/Reset Press Keys Boot: holding down the Boot button and momentarily pressing the Reset button initiates the
firmware upload mode. Then user can upload firmware through the serial port. Reset: pressing this button alone
resets the system.

Touch Pad Buttons Four touch pads labeled Play, Sel, Vol+ and Vol-. They are routed to ESP32-WROVER Module”
and intended for development and testing of a UI for audio applications using dedicated API.

Audio Codec Chip The Audio Codec Chip, ES8388, is a low-power stereo audio codec with headphone amplifier. It
consists of 2-channel ADC, 2-channel DAC, microphone amplifier, headphone amplifier, digital sound effects,
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UART
Header

JTAG
ESP32 WROVER Header
Module

MicroSD 125

Card Header
Red LED Function prxger
— DIP Switch

Left
Microphone

AUX Input

Power On LED

Headphone
Output
Battery Socket =5 Right
Microphone
Battery |
Charger Chi = —
g . e : AP Left
Stanby / 2 v g 22 @ | Speaker
Charging LEDs 3 o Output
e 0 : i GA & L i Q'\\ Right
Micro USB = ' - Speaker
Port PRl P Zemp Output
USB-UART
Bridge Chip | ) PA
" ’ 2 Chip
, 1 I \ \
Function Power On Audio Codec Touch Pad Boot / Reset
Press Keys Switch Chip Buttons Press Keys

K 23: ESP32 LyraT V4 board layout
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analog mixing and gain functions. It is interfaced with ESP32-WROVER Module” over 12S and 12S buses to
provide audio processing in hardware independently from the audio application.

Function Press Keys Two key labeled Rec and Mode. They are routed to ESP32-WROVER Module” and intended
for developing and testing a UI for audio applications using dedicated API.

USB-UART Bridge Chip A single chip USB-UART bridge provides up to 1 Mbps transfer rate.

Micro USB Port USB interface. It functions as the power supply for the board and the communication interface between
a PC and the ESP32 module.

Standby / Charging LEDs The Standby green LED indicates that power has been applied to the Micro USB Port.
The Charging red LED indicates that a battery connected to the Battery Socket is being charged.

Battery Charger Chip Constant current & constant voltage linear charger for single cell lithium-ion batteries AP5056.
Used for charging of a battery connected to the Battery Socket over the Micro USB Port.

Power On Switch Power on/off knob: toggling it to the left powers the board on; toggling it to the right powers the board
off.

Battery Socket Two pins socket to connect a single cell Li-ion battery.

Power On LED Red LED indicating that Power On Switch is turned on.

% 1#: The Power On Switch does not affect / disconnect the Li-ion battery charging.

Hardware Setup Options

There are couple of options to change the hardware configuration of the ESP32-LyraT board. The options are selectable
with the Function DIP Switch.

Enable MicroSD Card in 1-wire Mode

DIP SW | Position
OFF
OFF
OFF
OFF
OFF
OFF
OFF !
n/a

0| QNN KW I —

1. AUX Input detection may be enabled by toggling the DIP SW 7 ON
In this mode:
* JTAG functionality is not available

¢ Vol- touch button is available for use with the API
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Enable MicroSD Card in 4-wire Mode

DIP SW | Position
ON

ON
OFF
OFF
OFF
OFF
OFF

n/a

O AN | KW —

In this mode:
* JTAG functionality is not available
¢ Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available

Enable JTAG

DIP SW | Position
OFF
OFF
ON

ON

ON

ON

ON

n/a

0| [N N KW I~

In this mode:
* MicroSD Card functionality is not available, remove the card from the slot
 Vol- touch button is not available for use with the API

¢ AUX Input detection from the API is not available

Allocation of ESP32 Pins

Several pins / terminals of ESP32 modules are allocated to the onboard hardware. Some of them, like GPIO0 or GPIO2,
have multiple functions. Please refer to tables below or ESP32 LyraT V4 schematic for specific details.
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Red / Green LEDs

Touch Pads

ESP32 Pin

LED Color

GPIO19

Red LED

GP1022

Green LED

ESP32 Pin

Touch Pad Function

GPIO33

Play

GPIO32

Set

GPIO13

Vol- !

EENRUSIE ol

GPIO27

Vol+

1. Vol- function is not available if JTAG is used. It is also not available for the MicroSD Card configured to operate

in 4-wire mode.

MicroSD Card / J5

UART Header / JP2

12S Header / JP4

ESP32 Pin MicroSD Signal
1 | MTDI/ GPIO12 DATA2
2 | MTCK/GPIO13 | CD/DATA3
3 | MTDO/ GPIO15 | CMD
4 | MTMS/GPIO14 | CLK
5 | GPIO2 DATAO
6 | GPIO4 DATAI
7 | GPIO21 CD
Header Pin
1|33V
2 | TX
3 | RX
4 | GND

12C Header Pin | ESP32 Pin
1 | MCLK GPIO
2 | SCLK GPIO5
1 | LRCK GPIO25
2 | DSDIN GPIO26
3 | ASDOUT GPIO35
3 | GND GND
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12C Header / JP5

12C Header Pin | ESP32 Pin

1 | SCL GPI023

2 | SDA GPIO18

3 | GND GND

JTAG Header / JP7
ESP32 Pin JTAG Signal

1 | MTDO / GPIO15 | TDO
2 | MTCK /GPIO13 | TCK
3 | MTDI/ GPIO12 TDI
4 | MTMS / GPIO14 | TMS

Function DIP Switch / JP8

Switch OFF Switch ON
1 | GPIOI12 not allocated | MicroSD Card 4-wire
2 | Touch Vol- enabled MicroSD Card 4-wire
3 | MicroSD Card JTAG
4 | MicroSD Card JTAG
5 | MicroSD Card JTAG
6 | MicroSD Card JTAG
7 | MicroSD Card 4-wire | AUX IN detect !
8 | not used not used

1. The AUX Input signal pin should not be plugged in when the system powers up. Otherwise the ESP32 may not be
able to boot correctly.

Start Application Development

Before powering up the ESP32-LyraT, please make sure that the board has been received in good condition with no
obvious signs of damage.

Initial Setup

Prepare the board for loading of the first sample application:

1. Connect speakers to the Right and Left Speaker Output. Optionally connect headphones to the Headphone
Output.

2. Plug in the Micro-USB cable to the PC and to the Micro USB Port of the ESP32-LyraT.

3. The Standby LED (green) should turn on. Assuming that a battery is not connected, the Charging LED will
momentarily blink every couple of seconds.

4. Toggle left the Power On Switch.
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5. The red Power On LED should turn on.

If this is what you see on the LEDs, the board should be ready for application upload. Now prepare the PC by loading
and configuring development tools what is discussed in the next section.

Develop Applications

Once the board is initially set up and checked, you can start preparing the development tools. The Section Installation
Step by Step will walk you through the following steps:

¢ Set up ESP-IDF to get a common development framework for the ESP32 (and ESP32-S2) chips in C language;
* Get ESP-ADF to install the API specific to audio applications;

* Set up env to make the framework aware of the audio specific API,;

¢ Start a Project that will provide a sample audio application for the board;

* Connect Your Device to prepare the application for loading;

* Build the Project to finally run the application and play some music.

Related Documents

e ESP32 LyraT V4 schematic (PDF)
e ESP32 Datasheet (PDF)
* JTAG Debugging

3.4.7 ESP32-LyraTD-MSC V2.2 A\ | JiEF

AFEr BAE [ 74 ESP32-LyraTD-MSC V2.2 40T A AR DIHE . @Eﬁiﬁiﬁ: DA AT BRI AT o

ESP32-LyraTD-MSC 2 — 2 [fi 6] 8 BE &5 45 71 AL B JlFL R IR (P4, 2457522 [ 7 4 1% (Acoustic Echo
Cancelation, AEC). H3lIiE& lR 71 (Automatic Speech Recognition, ASR) ﬂﬂeﬁuﬁ@@g (Wake-up Interrupt) DA} 15
¥ H.3l (Voice Interaction) I fE .

BEETE

e 1 x ESP32-LyraTD-MSC V2.2 board

* 2x fiEdeel 3.5 mm WHAL GRS, ERNEE 3 FURE, 7AMREEE NN ISTPH 2.0 2
K2 BN, AL, TFA R AR O A R )

* 2 x Micro-USB 2.0 ¥##4k (Type A %% Micro B)
e 1 xPC (Windows, Linux B Mac OS)
AFE LRI T Aot , T E R R R X TS T A
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e

ESP32-LyraTD-MSC V2.2 Jg—gbE T /4% ESP32 i B BIT Ao, L R RESAEAI AL I R F T3, R
ESP32 3t 5 IS BIREAFAL, IEIGIS TR RS AP 22 v 51 LA K Jig RAM

ESP32-LyraTD-MSC V2.2 i EARAI I AR 2HA, bt (B) SR =22 7 XUE41) . DhREs4 Al LED 4T, Tk
(A) £ ESP32-WROVER-E ##4 . MicroSemi Digital Signal Processing (DSP) ith [ DA M i YR A5 FRAR B

Lower Board (A)

& 24: ESP32-LyraTD-MSC 1ill 1 [

HARAURE DA N RE -
« ESP32-WROVER-E ##i4f]
« DSP i B
o 3 WUSCRRIL I - e T BRI 22 T X
* 2/~ 3-watt 37 7 2 i
« HHLHi
* MicroSD A (—£RAEaal Py k=)
o BT RGNS 12 A~ LED 4T, Al ko745 i
o 6 NThREHCHE, WIHCE N IRE
o ZAuE I 12S, 12C, SPI. JTAG
* 48 USB-UART #4585
o P I 7 P A R
T BRI 2 ESP32-LyraTD-MSC ) 32520 {4 DA S 20 1427 ) iy i3 2 X
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I"."III:

@ ‘ . _%

[CEo

Upper Board (B) @

LED|
5&
Wi-Fi / BT E%
o |z5
£5
= s
Ay
—32 ESP32 §—
BAT ..
I" Battery PA
; Charger

USE 1 USB / DSP oA
| UART Chip

Lower Board (A)

Legend

PBE = Push Button
PA = Power Amplifier ESP32-LyraTD-MSC V2.2
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HiF

PATR BN )7 (438 bz ESP32-LyraTD-MSC ) 2400, 5 A=l 70, RURR HRiprdErE e, B2
WIS F AR L A R .

ESP32-WROVER-E Eifl ESP32-WROVER-E #i4[5F F ESP32 ith F, A28 Wi-Fi/s A4 fERAb 3, [H
BHEE Y, 4 MB 4pB SPI flash 1 8 MB SPI PSRAM, ] SZ 3 5% V% I B A7

DSP g Ji- ZL38063 DSP it i M1 A ghif a F I AR, AT AN ve RS SR BCE St . i B &
DAC 3 I it E A5 5

FpL s o A AT 3.5 mm 37 R FEH AL

R I ARSI EL, RS OMPT R HALIEE, 5 CTIA HALAHE . HE2HAUR
WS BE VT ) 4E 2 E Bl Phone connector (audio) 4% .

FED RS S F A, RN 2.00 mm /0.08” HEFHIRIEE, AIER: 4 BRI 3 TURHA A -
Aillismosds ity 00 LAy, R 2.00 mm /0.08” HEFHIRIEE, HSGEH 4 KU 3 FLAF & -

ESP32-WROVER-E

Power On LED

Power Switch

Standby LED

USB Power

r';—..—.:;ﬁ] > 1 i
o = B DSP Chip

Charging LED g Headphone
Qutput
USB-UART .
Port —@ §

Left Speaker
®—— Output

Right Speaker
Output

& 26: ESP32-LyraTD-MSC V2.2 [z (A) 241

USB-UART $:11 1§ PC 1 ESP32-WROVER-E #41  [a] i@ (55 1,
USB fiEH g 11 hIF AL
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FOVSEARRET 200 REBLI R AT, FORHIHE A Micro USB £:11; ZL(8 selifin T oy, %
ANTERE R Wl 1 B A ST .

FLDEIF G HLUETT/ Ol s o SR SR HNTF A L JETT IS, ) Ze e s UL 3 5 P
HLJRARAT ZL O d8n TS8R WRIFRE TP

Boot Button

Reset Button

[ 27: ESP32-LyraTD-MSC V2.2 |4k (B) ZH{4: &

AR g K4k Boot B, SRJS Sk Reset Bk AL SR, Rl i AT 0 AL A
AL AUHE T Reset i HEEE B R4,

MRERFFER
ESP32-LyraTD-MSC EHLZ |, 3§ B el At se i g, HoEM B) MR (A) B EE .

Mg E

BCEIT KM, DAt BBl ARy -
L Ry iE i 2 WA s a s iy, SO EA LR 2 AL .
2. i A Micro-USB %54k, #%#: PC 5 ESP32-LyraTD-MSC F1 & M i) Wi~ USB ¥ I .
3. U, SR FRBURARKT I SRS . AR R, 20t sl R Rk R LD IR —IK .
4. RS WIEIFR.
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5. LI, 2L IR AT BT .

WEARAR T EAR R, WP EC 2 se M, TFAMRA T RN AT . BHE, 5% T 0 ghatritie

HPC ERIF AT R,

EXFIEFE

O SEMAIR R B TAE, WESH & TH, Waiftinsallation Step by Step ZH VAN L HR:
« Set up ESP-IDF #{l.—4 ESP32 il ESP32-S2 ;s Hf) C 15 PC JF & ik 3rss ;

* Get ESP-ADF SRIUT A &4 b #2711 APL;

* Setup Path to ESP-ADF {ii JJ- & HEZE R EE] 545 W ] APT;
* Start a Project I K L5550 1R e on 15

« Connect Your Device 75 In#k W R ;

* Build the Project :217N FAR)T, &SR,

f&iTmse

o M FAEZH A ESP32-WROVER-B T #i 5 ESP32-WROVER-E,

Hith LyraT RIIFER

o ESP32-LyraT V4.3 N 11354
 ESP32-LyraT-Mini V1.2 X135 %

R

e ESP32-LyraTD-MSC V2.2 Schematic Lower Board (A) (PDF)
e ESP32-LyraTD-MSC V2.2 Schematic Upper Board (B) (PDF)
* ESP32 7R JIA% 15 (PDF)

« ESP32-WROVER-E # R HiH%15 (PDF)

3.4.8 ESP32-Korvo-DU1906

ARSCRYA R T a4 ] ESP32-Korvo-DU1906 % #x .«
o NTVAEE: FENZT ESP32-Korvo-DU1906 FIRE{:. R E e
o TFUETFE R 0 PRI T ESP32-Korvo-DU1906 [ 7T % it e«
o AEKSAS B TR O SORY I R .
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